Contribute
Register

BRIX/BRIX PRO Audio - Realtek ALC269

Status
Not open for further replies.

toleda

Moderator
Joined
May 20, 2010
Messages
23,941
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Mavericks: Gigabyte BRIX/BRIX Pro Audio
BRIX Realtek ALC AppleHDA/Realtek ALC269

This thread is deprecated and no longer supported

MultiBeast 7.1/BRIX/ALC269, BRIX Pro/ALC283 and NUC/ALC283 Support

See Post #1, Realtek ALC AppleHDA

Change Lo
g
11/29/14 - Deprecated
v1.0 - 4/30/14 - Initial release​

Requirements


  1. OS X versions supported:
    1. Mavericks 10.9.2 and newer
  2. Supported Audio
    1. Realtek ALC269
    2. Audio ID: 1
Audio Devices (Outputs only, no Inputs)

  1. AirPlay
  2. Headphone
  3. SPDIF/Optical
  4. HDMI
  5. DP
Installation - Chimera/Chameleon/Clover/BRIX AppleHDA

  1. S/L/E/AppleHDA.kext
    1. MultiBeast - TBA
    2. audio_BRIX - TBA
    3. Download View attachment brix-applehda_v2.6.0-2.zip (10.9.2)
      1. KextBeast (Copy AppleHDA.kext to Desktop)
  2. S/L/E/AppleIntelFramebufferAzul.kext
    1. Download (View Raw): graphics_intel_hd5k-azul-e-90_patch.command.zip
    2. Double click Downloads/graphics_intel_hd5k-azul-e-90_patch.command
      1. Do not move file
      2. Enter password
      3. Save Terminal Log
        1. Terminal/File/Export Test As...
  3. SSDT.aml
    1. Download View attachment audio_ssdt-hdmi-nuc_hd5k-1_v2.zip
    2. Rename SSDT-1.aml to SSDT.aml
    3. Chimera/Chameleon
      1. Finder/File/Copy/SSDT.aml to Extra/SSDT.aml
    4. Clover
      1. Finder/File/Copy/SSDT.aml to EFI/Clover/ACPI/patched/SSDT.aml
Installation - Clover/native AppleHDA

  1. audio_cloverBRIX - TBA
    1. See README.txt
    2. config.plist/KernelAndKextsToPatch/KextsToPatch
      1. config-audio_cloverBRIX.plist
    3. Install layout1.zml.zlib and Platforms.zml.zlib to S/L/E/AppleHDA.kext
      1. Terminal: audio_cloverBRIX-92_patch
    4. realtekBRIX.kext
      1. Finder/File/Copy/realtekBRIX.kext to EFI/Clover/kexts/10.9/realtekBRIX.kext
    5. SSDT.aml
      1. Finder/File/Copy/SSDT.aml to EFI/Clover/ACPI/patched/SSDT.aml
Tools

  1. Clover Configurator
  2. IOReg or IOJones
    1. IORegistryExplorer_v2.1 (View Raw)
    2. IOJones
Problem Reporting (Post to this thread)

  1. Description of BRIX audio problem
  2. OS X version/BRIX model/BIOS version/processor/graphics
  3. S/L/E/AppleHDA.kext
  4. Copy of IOReg or IOJones
  5. Chimera/Chameleon
    1. Extra/org.chameleon.Boot.plist
    2. Extra/SSDT.aml
  6. Clover
    1. EFI/Clover/config.plist
    2. EFI/Clover/misc/debug.log (Set config.plist/Boot/Debug/YES)
    3. EFI/Clover/ACPI/patched/SSDT.aml

Screenshot

Screen Shot 2014-04-28 at 4.21.25 PM.png
 
Last edited:

tonymacx86

Administrator
Staff member
Joined
Nov 18, 2009
Messages
8,475
Motherboard
GA-Z270X-UD5
CPU
Core i3-7100
Graphics
HD 630
Mac
MacBook Pro, Mac mini
Classic Mac
Apple, PowerBook
Mobile Phone
iOS
BRIX Audio

ALC269 confirmed working with Chimera 3.0?
1. BRIX HD4000
2. BRIX HD4400
3. BRiX Pro HD5200
1. No audio ports- HDMI yes
2. Yes
3. Yes
 
Joined
Jun 16, 2012
Messages
39
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Hello,

I notice that sound through the headphone port stops randomly. A reboot of the computer fixes this. I'm not sure if you have a solution.

1. Brix pro, with 4770r.
2. 10.9.3/GB-BXi7-4770R/F3/Intel i7-4770R/Intel® Iris™ Pro graphics 5200
3. I can't attach AppleHDA.kext for some reason. It is the file that you provided.
4. IOJones attached.
5. Chimera/Chameleon are not applicable.
6. Clover
a. EFI/Clover/config.plist, attached.
b. EFI/Clover/misc/debug.log, attached.
c. EFI/Clover/ACPI/patched/SSDT.aml, 2 files attached.
 

Attachments

Joined
Jun 16, 2012
Messages
39
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Hi,

I can't get audio through HDMI for some reason. I probably should have led with that issue. All the information is the same as my previous post. The only interfaces that show are headphones and digital through the headphone port.

I have applied and removed the patches you provided in this post multiple times.

Is there any other troubleshooting that I can do?

Thanks.
 
Joined
Jun 16, 2012
Messages
39
Motherboard
Lenovo x270
CPU
i7-7500
Graphics
HD 620
Ok. I think I solved my own issue.

I was using a SyncMaster P2770, which is a PC monitor with HDMI and DVI as the input. The monitor also has a speaker jack for HDMI. HDMI audio was not detected until I connected my speakers to the monitor and rebooted everything. All is well now.

Thanks.
 
Joined
Jun 20, 2014
Messages
655
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
I couldn't get HDMI audio out working following this guide. I'm not sure if it's because I updated to OSX 10.9.4 today but I found installing the AppleIntelFramebufferAzul.kext from this post worked.
 
Joined
Jun 20, 2014
Messages
655
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
After every Software Update: Post #1, Installation, Step 2. S/L/E/AppleIntelFramebufferAzul.kext.
I only attempted following your post after doing the update. Audio using the patch method would not work (I would get digital out and headphone jack only). After using the kext in the link I posted I got HDMI out also.
 
Joined
Jun 20, 2014
Messages
655
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070 Max-Q / 4K
After every Software Update: Post #1, Installation, Step 2. S/L/E/AppleIntelFramebufferAzul.kext.
Your method worked for me with the latest update so I'm guessing I made a mistake of some sort. Also for other people out there the azul-e-90, azul-f-90, azul-g-90 etc. are NOT version numbers. Thank you very much for your work on this.

PS The graphics_intel_hd5k-azul-e-90_patch.command.zip link in your post is broken.
 
Status
Not open for further replies.
Top