Contribute
Register

Brand new build. GTX 980 woes.

Status
Not open for further replies.
Joined
May 31, 2015
Messages
2
CPU
i7 4.0
Graphics
EVGA GTX 980
Mac
Classic Mac
Mobile Phone
Hey all,

I've got my build up and running for the most part. Everything is going well except that I can't get my GPU drivers installed, as Yosemite does not have support for the 980 built into the OS. When downloading from official Nvidia sites, the installer (such as "WebDriver-346.01.02f02") does not even let me begin to install because it is not supported in 10.10.3. I have found what I believe to be a beta download at http://us.download.nvidia.com/Mac/Quadro_Certified/346.01.02f03/WebDriver-346.01.02f03.pkg

This package will let me install, but on reboot, I can only get back into the OS using "-x -no-zp" or "-x nv_disable=1". When entering back into the OS, it is as if I never attempted to install the drivers. I am not sure what the "-x" boot tag means, but I was thinking that it might be safe mode or something similar. If anyone has any advice, please let me know. Again, I am new to the hackintosh world and would be very appreciative of some direction. Thank you!
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,258
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Hey all,

I've got my build up and running for the most part. Everything is going well except that I can't get my GPU drivers installed, as Yosemite does not have support for the 980 built into the OS. When downloading from official Nvidia sites, the installer (such as "WebDriver-346.01.02f02") does not even let me begin to install because it is not supported in 10.10.3. I have found what I believe to be a beta download at http://us.download.nvidia.com/Mac/Quadro_Certified/346.01.02f03/WebDriver-346.01.02f03.pkg

This package will let me install, but on reboot, I can only get back into the OS using "-x -no-zp" or "-x nv_disable=1". When entering back into the OS, it is as if I never attempted to install the drivers. I am not sure what the "-x" boot tag means, but I was thinking that it might be safe mode or something similar. If anyone has any advice, please let me know. Again, I am new to the hackintosh world and would be very appreciative of some direction. Thank you!

That is a final release driver, hence the "f" in f03. Beta drivers would end with a "b" in front of the last two numbers.


Once the drivers are installed you must use the flag nvda_drv=1. Get rid of -x as that is really the flag that is allowing you to boot since that puts it in safe mode. You should be able to boot with just nv_disable=1 but that won't give you gpu acceleration.
 
Joined
May 31, 2015
Messages
2
CPU
i7 4.0
Graphics
EVGA GTX 980
Mac
Classic Mac
Mobile Phone
Yes! Thank you slim.jim. That was incredibly helpful and everything is now working on my machine. I owe you a beer. Thanks again. Very excited to get some software installed on here and get it up and going.
 
Status
Not open for further replies.
Top