Contribute
Register
Joined
Oct 11, 2012
Messages
13
CPU
I5 3570k
Graphics
660
Mac
Mac Pro
Classic Mac
eMac
Mobile Phone
Android
Hi,

So I have just installed Sierra (not using Unibest) and as of right now I am booting off a clover boot loader built onto the memory stick with the install bits. I have just done a fresh install as when I used Multibeast it broke the system, same happens when using stand alone version of Clover, and when I use Chameleon I get the infamous can't find mach_kernel error.

I would prefer to use Chameleon but I can't get round the issue above, pointing it in the direction of the kernel using
'/System/Library/Kernels/kernel' with Chameleon Customiser doesn't work.

Hopefully this is an easy fix, hopefully I can get some help, thanks.
 
Joined
Mar 3, 2014
Messages
796
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
Hi,

So I have just installed Sierra (not using Unibest) and as of right now I am booting off a clover boot loader built onto the memory stick with the install bits. I have just done a fresh install as when I used Multibeast it broke the system, same happens when using stand alone version of Clover, and when I use Chameleon I get the infamous can't find mach_kernel error.

I would prefer to use Chameleon but I can't get round the issue above, pointing it in the direction of the kernel using
'/System/Library/Kernels/kernel' with Chameleon Customiser doesn't work.

Hopefully this is an easy fix, hopefully I can get some help, thanks.

If I understand correctly, Sierra cannot be installed using Chamelion (Chimera) per the older tonymacx86 methods. I was successful by creating a Unibeast v 7.0.1-installed 16 GB USB drive, followed by a Multibeast v 9.0.1 post-installation. I chose the iMac 14,2 SMBIOS during that install. I have also recently successfully updated Clover itself to version "Clover_v2.3k_r3949" using Clover Configurator version 4.36.0 and everything continues to work perfectly.

My only installation issue was having to plug my USB drive into one of my USB 3.0/2.0 ports to do the install, since the installation would hang when the Mac installation app started, if using a USB 3.0 (only) port. Otherwise it went smoothly. I am currently running Mac OS 10.12.2.

If you wish to play "Obduction" or similar games using the Unreal4 game engine, you definitely need to run the latest Mac OS for its improvements of Apple's new "Metal" API.

Strongly advise you read all relevant articles in this forum on installation recommendations before you start a new install, if you choose to do that.
 
Joined
Oct 11, 2012
Messages
13
CPU
I5 3570k
Graphics
660
Mac
Mac Pro
Classic Mac
eMac
Mobile Phone
Android
But mine did work with Chameleon in that themes worked and the timeout settings etc, it was just when I clicked the Sierra drive it just can't find mach_kernel, and I struggle to see what I can do with Clover as soon as I install it the computer will not boot back in, even if I use the USB drive, it just doesn't see the Sierra drive anymore.
 
Joined
Mar 3, 2014
Messages
796
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
Sorry I cannot help you further. No expert here; just a user who had success with Clover after many tries. When Apple moved to El Capitan, tonymacx86 transitioned to Clover, and certainly for Sierra, there is no support on this forum for a Chameleon or Chimera boot loader. As I wrote above, I had success downloading the 10.12 update from the App Store, and using the Unibeast app to make an installation USB drive, followed by the Multibeast post-installation procedure. Since then the updates to 10.12.2 have worked for me without problems. You might have better luck using the tonymacx86 apps than whatever you used previously.
 
Joined
Oct 11, 2012
Messages
13
CPU
I5 3570k
Graphics
660
Mac
Mac Pro
Classic Mac
eMac
Mobile Phone
Android
Solved..

Don't want to jinx it but, used Multibeast and used Clover in Legacy mode and then tweaked it with the Clover configurator. :)
 
Joined
Mar 3, 2014
Messages
796
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
If you are not using your UEFI firmware, your configuration is fundamentally different from mine. Happy New Year!
 
Top