Contribute
Register

Booting with Radeon 7850 not possible, how fix it? (its for Windows, in Mac OS I'm using HD 4000)

Status
Not open for further replies.
Joined
Jun 7, 2012
Messages
5
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5 3570k
Graphics
Zotac Geforce GT 640
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Hello, first I want to say sorry for my bad english, I'm from germany, but I will try my best!

Today I installed succesfully my Hackintosh system!

Components:
Gigabyte GA-Z77-DS3H
Intel i5-3570
Sapphire Radeon 7850

My plan was to work with two BIOS profiles. In the Mac OS Profile I enabled the integrated Graphics (HD 4000) and set it to init first on Display. This works great!
For booting Win 7 I want to choose a Win 7 BIOS profile where I will disable the HD 4000.

So when I today installed Mountain Lion I had to plug of the Power Adapter from the Radeon because otherwise the installation didnt run. Well, now all is installed and works great. But when I turn the pc off, plug the radeon on and try to boot Mac OS (with enabled HD 4000 and init display first IGFX), it doesnt boot!

GraphicsEnabler is YES, because with NO the HD 4000 doesnt work correct, i couldn't set my resolution (full HD) and there were some graphic faults.

So, how can i fix this problem?

I don't want to plug in and out the Radeon everytime when I switch the OS!

Thanks for help!
 
Joined
Jun 7, 2012
Messages
5
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5 3570k
Graphics
Zotac Geforce GT 640
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Joined
Jul 19, 2010
Messages
342
Motherboard
GA-Z68-UD3H-B3
CPU
Core i7 2600k
Graphics
EVGA GTX670
Mac
  1. MacBook
  2. Mac mini
Classic Mac
Mobile Phone
  1. iOS
for all I've seen, the 7850 is completely unsupported.
It simply will not work, at all.

And the chances of it being supported anytime in the near future are ~0%, unless Apple changes direction and goes with AMD rather than Nvidia.

But again, all signs are pointing to Nvidia partnering with Apple for the foreseeable future.

This is only what I've read, so...

Edit: srr, just read it is for Windows.
I assume you are using Bootcamp?

If you are not using bootcamp then there is no reason it shouldn't work if you set your BIOS to PCI grfx. If you are using bootcamp, I have no idea.
 
Joined
Jun 7, 2012
Messages
5
Motherboard
Gigabyte GA-Z77-DS3H
CPU
Intel i5 3570k
Graphics
Zotac Geforce GT 640
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
Hi, thank you for the answer!

Yes, its only for Windows, and no, i don't use bootcamp.

I have set Bios to use the HD 4000, not PCI Grfx, like you wrote!

But when I want to boot it dont boot Mac OS, it only works when I plug off the Power cable of the Radeon.
 
Joined
Oct 15, 2012
Messages
5
Motherboard
p8z77-v
CPU
i7 3770k
Graphics
7850 HD
Mac
Classic Mac
Mobile Phone
Hey did you found any solution for yourself? because I have the exact same problem.
 
Joined
Mar 25, 2012
Messages
1
Motherboard
ga-z68a-d3h-b3
CPU
2600k
Graphics
radeon 6950 x2
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. Mac mini
Classic Mac
Mobile Phone
  1. iOS
I have the same problem but with running two 6970 in crossfire.
I have never been able to get them to work properly in my hack so i figured a way around the situation.
First of all i only use windows for gaming thus the two 6970. With that said
My monitor has multiple inputs hdmi dvi vga etc etc.
I ran my video straight off the board as bootable into my hack.
in windows i set my 6950 as the default graphic card.
I then set my monitor to auto detect signal.
When i boot up it boots in with the 4000 graphic setting active.
If i choose to game in windows i reboot luanch windows and my 6950 pic up and launch.
I now its childish but it works. My monitor was actually the hero in my build.
 
Joined
Oct 2, 2011
Messages
7
Motherboard
Mavericks
CPU
Intel i7 4770k
Graphics
EVGA 780 GTX Classified
Mac
Classic Mac
Mobile Phone
I just bought a 7950 and had the exact same problem.

I set up my bios to use the integrated 3000HD igpu then when I get to the bootloader I enter GraphicsEnabler=No -v -f and everything boots okay.

*Edit* Re-read your opening post, seems you had the same problem as me with GraphicsEnabler=No, 1024x768 and no graphic acceleration.

Is there a way to force the bootloader to use the 3000HD, rather than trying to init the PCIE card instead?
 
Joined
Oct 2, 2011
Messages
7
Motherboard
Mavericks
CPU
Intel i7 4770k
Graphics
EVGA 780 GTX Classified
Mac
Classic Mac
Mobile Phone
Joined
Nov 11, 2012
Messages
5
Motherboard
gigabyte z77x ud3h
CPU
3570K
Graphics
HD4000 + AMD 6950
Mac
Classic Mac
Mobile Phone
Hello guys. I have the same problem. But I stuck at finding gfxutil program. Is this program still available?

And here it is my problem in 2 sentences. I have 3570k + gigabyte z77x-udh3 and if I do not use (physically) my Radeon 6950 everything is fine. But I do not want to plug my dedicated video card in order to boot the windows where I will play games and unplug it to boot the Mac OS.

Do you have ideas what could be done in order to make the OS X understand that it should use the hd4000 instead of the Radeon?
 
Joined
Nov 10, 2012
Messages
8
Motherboard
ASUS Z170 Pro Gaming
CPU
i5-6600K
Graphics
MSI GTX 970
You can find gfxutil in the archive here. Although I haven't tested it yet.
 
Status
Not open for further replies.
Top