Contribute
Register

Booting into Big Sur Installer ends up in black screen

Joined
Jul 16, 2017
Messages
22
Motherboard
Gigabyte GA-Z87-D3HP
CPU
Intel Core i5-4570
Graphics
Intel HD Graphics 4600 & NVIDIA GT740
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey folks,

due to the release of macOS Big Sur I created a USB installer by using createinstallmedia command.
I followed Dortanias OpenCore Guide to create a good EFI and to get the right SSDTs, drivers and kexts I need. Even Sanity Checker says everything is OK.

When I'm trying to boot into the USB Installer it looks like it won't have problems booting into it, but then it ends up just in a black screen.
After a few seconds my PC doesn't send any signal to the monitor.

What I tried:

- use another SMBIOS (in Catalina I used iMac14,2, support for it ended in Big Sur) tried iMac15,1 and iMac16,2

- found a EFI folder in this forum from another user (yes, I know that it's bad to use a strange EFI, because hardware does not match 100%)
who had the same mainboard like me and who had success installing Big Sur
-> I was able to boot into the installer, but if I try to select where to install Big Sur I just get the error "Your Mac needs a firmware update in order to install to this volume, try formatting with Mac OS Extended (Journaled). But APFS is needed since Mojave(?).

- reactivate iGPU in BIOS and try switching to HDMI port of the iGPU when I reach the black screen


What I should mention:

- I deactivated iGPU in BIOS because I use Gigabyte GT740 for graphics which is supported out of box.
- changed BIOS settings according to Dortanias Big Sur guide

I uploaded my EFI folder I use to boot into the installer.


Thanks much for your help!
 

Attachments

  • EFI.zip
    1.9 MB · Views: 54
Joined
Jul 16, 2017
Messages
22
Motherboard
Gigabyte GA-Z87-D3HP
CPU
Intel Core i5-4570
Graphics
Intel HD Graphics 4600 & NVIDIA GT740
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Just for the case somebody gets the same error one day, I found the problem.

Try another SMBIOS. That's what caused the problem in my case.
On Catalina I used iMac14,2 (Haswell), now I'm using iMac16,1 for the installer.

I hope the installation will be successfully.

Have a nice day/night
 
Top