Boot Sound / Chime

Discussion in 'Customization' started by nicoSWD, Aug 13, 2013.

  1. nicoSWD

    nicoSWD

    Joined:
    Nov 12, 2010
    Messages:
    9
    Mobo:
    GA-EP45-UD3P
    CPU:
    Intel Q9450
    Graphics:
    R9 280X OC 3GB
    Mac:
    MacBook Air, Mac Pro
    Classic Mac:
    iMac
    Mobile Phone:
    iOS
    Aug 13, 2013 at 8:50 AM #1
    nicoSWD

    nicoSWD

    Joined:
    Nov 12, 2010
    Messages:
    9
    Mobo:
    GA-EP45-UD3P
    CPU:
    Intel Q9450
    Graphics:
    R9 280X OC 3GB
    Mac:
    MacBook Air, Mac Pro
    Classic Mac:
    iMac
    Mobile Phone:
    iOS
    New Startup Sound (Chime) Launch Daemon

    I made a new launch daemon that plays the boot sound/chime on startup. (Currently in beta!)

    Unlike most similar apps, this one adds a new launch daemon that plays the sound, meaning, it runs much earlier during the boot process, even before the login screen appears. It also comes with an easy installer, which you can download here:

    - https://github.com/nicoSWD/Carillon/releases/tag/1.0b

    Another version, using an alternative approach can be downloaded here, if the above one doesn't work for you.

    - https://github.com/nicoSWD/Carillon/releases/tag/v1.2b

    The source is available on Github:

    - https://github.com/nicoSWD/Carillon

    [​IMG]

    Here's a video:


    Please test, and let me know if it works for you. Please provide some system details when reporting.

    To uninstall, remove the following files from your system:
    Code (Text):

    /usr/local/bin/Carillon
    /System/Library/LaunchDaemons/com.nicoswd.Carillon.plist
     
     
    DifferentComputers likes this.
    Last edited: Aug 24, 2016
  2. Wolfie81

    Wolfie81

    Joined:
    Oct 10, 2012
    Messages:
    592
    Mobo:
    Wolfies BeQuiet
    CPU:
    6700k + Gigabyte Z170X Designare
    Graphics:
    EVGA 1080ti FTW3
    Mac:
    iMac
    Aug 13, 2013 at 12:14 PM #2
    Wolfie81

    Wolfie81

    Joined:
    Oct 10, 2012
    Messages:
    592
    Mobo:
    Wolfies BeQuiet
    CPU:
    6700k + Gigabyte Z170X Designare
    Graphics:
    EVGA 1080ti FTW3
    Mac:
    iMac
    Didn't work for me.
    A youtube video would be nice to see how it works.
     
  3. nicoSWD

    nicoSWD

    Joined:
    Nov 12, 2010
    Messages:
    9
    Mobo:
    GA-EP45-UD3P
    CPU:
    Intel Q9450
    Graphics:
    R9 280X OC 3GB
    Mac:
    MacBook Air, Mac Pro
    Classic Mac:
    iMac
    Mobile Phone:
    iOS
    Aug 13, 2013 at 12:22 PM #3
    nicoSWD

    nicoSWD

    Joined:
    Nov 12, 2010
    Messages:
    9
    Mobo:
    GA-EP45-UD3P
    CPU:
    Intel Q9450
    Graphics:
    R9 280X OC 3GB
    Mac:
    MacBook Air, Mac Pro
    Classic Mac:
    iMac
    Mobile Phone:
    iOS
    Thanks for testing!

    Can you give me some more details about your setup? OS X version? How did you get audio to work? Which kext(s), or external USB adapter? And if it's not too much trouble, could you open Console.app, and search for "Carillon"? Perhaps there's a hint as to why it failed.

    Thanks!

    EDIT: Added a video to the main post.
     
  4. Adrian B

    Adrian B Moderator

    Joined:
    Mar 18, 2012
    Messages:
    6,835
    Mobo:
    Gigabyte GA-B75M-HD3
    CPU:
    G2020 Dual Core
    Graphics:
    Asus EAH5570
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    Other
    Aug 13, 2013 at 1:28 PM #4
    Adrian B

    Adrian B Moderator

    Joined:
    Mar 18, 2012
    Messages:
    6,835
    Mobo:
    Gigabyte GA-B75M-HD3
    CPU:
    G2020 Dual Core
    Graphics:
    Asus EAH5570
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    Other
    This is what I get when I try to download either the installer or the software.


    "trouble shooting boot with -v verbose this works with all osx versions by stehor

    please remove any hardware thats not needed for install such as extra hdds,pci/pcie cards all of them if u have an incompatable hardware u will get iobluetooth hang also disable vt-d,ieee 1394,lan,intel vertualization technology in bios. if u get a kp=kernel panic it because u made a bad multibeast choice or hardware isnt compatable or a bad kext in the extensions folder. theres no support for vga except on old 8xxx and 9xxx nvida gfx cards. if u get gray screen,black,no signal u have gfx issues. boot flags reboot system when u see the tonymacx86.com apple u have 5 secs to act press the spacebar. example u have gfx issues chimera defaults are GE=YES PCIRoot=1 npci=0x2000 if not working then use GE=NO or PCIRoot=0,1,2,3,4,5 if u have nvida 6xxx use flag GE=NO now assuming u have fixed now put in each pcie/pci device one at a time and reboot with -v each time to make sure theres no issues. if for some reason u cant disable vt-d in bios and your cpu has it u need this flag dart=0 it will disable vt-d if u get pci config begin then add flag npci=0x3000 edit note for gfx dont open plist with chameleon wizard it will break gfx support. system defs if using ivy mobo/cpu use MacMini6,1 for i5 for i7 6,2 dont use 13,1 or 13,2 it only has 2 p states then use prgen for ssdt for proper p states make sure u its in the extra folder as SSDT.aml


    system freezes

    a bad stick of ram download memtest86 or a bad dim port,ssd needs firmware update,ssd has trim enabled,or fakesmc plugin is causing this"


    ?


    Adrian B
     
  5. Wolfie81

    Wolfie81

    Joined:
    Oct 10, 2012
    Messages:
    592
    Mobo:
    Wolfies BeQuiet
    CPU:
    6700k + Gigabyte Z170X Designare
    Graphics:
    EVGA 1080ti FTW3
    Mac:
    iMac
    Aug 13, 2013 at 1:31 PM #5
    Wolfie81

    Wolfie81

    Joined:
    Oct 10, 2012
    Messages:
    592
    Mobo:
    Wolfies BeQuiet
    CPU:
    6700k + Gigabyte Z170X Designare
    Graphics:
    EVGA 1080ti FTW3
    Mac:
    iMac
    Sorry I have already uninstalled it. My system is at the bottom of my post (link) only difference is im 10.8.4 now. My audio runs through the USB cable from the 24 inch Cinema display...
    Everything in terms of install went great, no issues at all but it just didnt chime.

    Ill try send you details when I reinstall it later on when I get a chance.
    A quick search from Console with Carillion got this..

    13/08/13 9:09:22.346 PM sudo[4365]: root : TTY=unknown ; PWD=/private/tmp/PKInstallSandbox.cW3WlF/Scripts/com.nicoswd.carillon.com.nicoswd.Carillon.pkg.1q6Ati ; USER=root ; COMMAND=/usr/sbin/chown root:wheel /System/Library/LaunchDaemons/com.nicoswd.Carillon.plist
    13/08/13 9:09:22.373 PM sudo[4368]: root : TTY=unknown ; PWD=/private/tmp/PKInstallSandbox.cW3WlF/Scripts/com.nicoswd.carillon.Carillon.pkg.lz4cOl ; USER=root ; COMMAND=/usr/sbin/chown root:wheel /usr/local/bin/Carillon
     
  6. neuwelt

    neuwelt

    Joined:
    Mar 8, 2013
    Messages:
    4
    Mobo:
    hp 4540s 64 bit
    CPU:
    i3 3110M
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Sep 1, 2013 at 3:10 PM #6
    neuwelt

    neuwelt

    Joined:
    Mar 8, 2013
    Messages:
    4
    Mobo:
    hp 4540s 64 bit
    CPU:
    i3 3110M
    Graphics:
    HD 4000
    Mobile Phone:
    iOS
    Working alright :thumbup: Thanking You.

    HP Probook 4540s Ivy Bridge
    Peocessor 2.9 Ghz Intel Core i3
    Memory 4 GB 1600 Mhz DDR3
    Graphics Intel HD Graphics 4000 512 MB
    Software OS X 10.8.4 (12E5 5)
     
  7. MrRod

    MrRod

    Joined:
    Jul 19, 2013
    Messages:
    12
    Mobo:
    HP Probook 4540s
    CPU:
    Intel Core i5 3210M 2.50GHz
    Graphics:
    Intel HD Graphics 4000
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    Android
    Sep 6, 2013 at 8:24 PM #7
    MrRod

    MrRod

    Joined:
    Jul 19, 2013
    Messages:
    12
    Mobo:
    HP Probook 4540s
    CPU:
    Intel Core i5 3210M 2.50GHz
    Graphics:
    Intel HD Graphics 4000
    Mac:
    iMac, MacBook Pro
    Mobile Phone:
    Android
    This worked on my HP Probook 4540s i5 under 10.8.4 until a week ago, the sound just doesn't play anymore. I tried reinstalling it but no dice.
     
  8. lexone

    lexone Moderator

    Joined:
    Apr 13, 2012
    Messages:
    509
    Mobo:
    GA-Z87X-OC
    CPU:
    Intel® Core™ i7-4770K @3.50GHz
    Graphics:
    NVIDIA GeForce GTX780
    Mac:
    iMac, Mac Pro
    Mobile Phone:
    iOS
    Oct 15, 2013 at 8:35 PM #8
    lexone

    lexone Moderator

    Joined:
    Apr 13, 2012
    Messages:
    509
    Mobo:
    GA-Z87X-OC
    CPU:
    Intel® Core™ i7-4770K @3.50GHz
    Graphics:
    NVIDIA GeForce GTX780
    Mac:
    iMac, Mac Pro
    Mobile Phone:
    iOS
    Did not work for me. I believe I read that this calls AppleHDA to run it??? I am using VoodooHDA.kext in my setup to get proper audio working. AppleHDA causes my machine to KP so I must delete it. It got reinstalled when I ran the 10.8.5 supplemental update so I had to delete and repair permissions so that my system could boot normally and have audio. Do you have a version that will work with VoodooHDA? I've tried the debug version with no luck. Also tried the alternative method where it installes the chime sound and uses some other native daemon to play the sound but it didn't work for me either...so i have removed all instances. Any other suggestions?
     
  9. Robbish

    Robbish

    Joined:
    Mar 31, 2011
    Messages:
    575
    Mobo:
    GA-Z77-DS3H Rev 1.0 (BIOS: F11a) incl. Patched DSDT & SSDT (Clover UEFI) SMBIOS: Macmini6,2
    CPU:
    Intel Core i5-3570K 3.4GHz Ivy Bridge (OC'd to 4.4GHz)
    Graphics:
    Intel HD4000
    Mobile Phone:
    Android
    Oct 15, 2013 at 11:05 PM #9
    Robbish

    Robbish

    Joined:
    Mar 31, 2011
    Messages:
    575
    Mobo:
    GA-Z77-DS3H Rev 1.0 (BIOS: F11a) incl. Patched DSDT & SSDT (Clover UEFI) SMBIOS: Macmini6,2
    CPU:
    Intel Core i5-3570K 3.4GHz Ivy Bridge (OC'd to 4.4GHz)
    Graphics:
    Intel HD4000
    Mobile Phone:
    Android
    installed the Carillon app and it and worked for me with no issues - tried it twice and all good :thumbup:

    FYI - on my system, the chime begins during the Apple Boot Logo boot screen and ends when OSX desktop appears

    Props nicoSWD ;)
     
  10. Wolfie81

    Wolfie81

    Joined:
    Oct 10, 2012
    Messages:
    592
    Mobo:
    Wolfies BeQuiet
    CPU:
    6700k + Gigabyte Z170X Designare
    Graphics:
    EVGA 1080ti FTW3
    Mac:
    iMac
    Oct 25, 2013 at 5:34 PM #10
    Wolfie81

    Wolfie81

    Joined:
    Oct 10, 2012
    Messages:
    592
    Mobo:
    Wolfies BeQuiet
    CPU:
    6700k + Gigabyte Z170X Designare
    Graphics:
    EVGA 1080ti FTW3
    Mac:
    iMac
    Its now working on my system. Thanks very much for it!
    I read it needed Apple HDA as per two posts above so I installed it and thats what got it going!
     

Share This Page