Contribute
Register

BoomR's “Power UP” for 360/VR Production Build: GA-Z370 AORUS UG - i7 8700K - GA AORUS RX580

Joined
Mar 15, 2012
Messages
85
Motherboard
GIGABYTE Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
I just updated to Catalina. So far so good. I updated the following:
- Updated Clover to 4961 from Tonymac Clover builds​
- Updated to newest Lilu and WhateverGreen kexts​
Then I installed. It took a while, and that booted me into Black Screen. I had to load up a backup, and edit my Clover parameters. I added the following to my Clover config.plist:
- Inject ATI under the Graphics Section​
- agdpmod=pikera as a boot argument​

Now all is good. I will report back any problems.

BruceX Test dropped from 15 secs to 10 secs.
 
Last edited:
Joined
Mar 15, 2012
Messages
85
Motherboard
GIGABYTE Z370 AORUS Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Update. All is stable, but ran into problems with DRM and the new Apple TV+ app. It would black screen movies I had already purchased. Found this fix....

I had to compile newest whatevergreenkext version 1.3.5 and use following boot arguments:

shikigva=160 shiki-id=Mac-7BA5B2D9E42DDD94
 
Joined
Jul 12, 2017
Messages
18
Motherboard
Gigabyte GA-Z370 AORUS Ultra Gaming
CPU
Intel Core i7-8700K
Graphics
Gigabyte AORUS Radeon RX 580 8GB
Mac
  1. iMac
Mobile Phone
  1. Android
Update. All is stable, but ran into problems with DRM and the new Apple TV+ app. It would black screen movies I had already purchased. Found this fix....

I had to compile newest whatevergreenkext version 1.3.5 and use following boot arguments:

shikigva=160 shiki-id=Mac-7BA5B2D9E42DDD94

Thanks for letting us know. A complete Catalina upgrade tutorial would be awesome!
 
Joined
Aug 9, 2018
Messages
8
Motherboard
GA-Z370 AORUS
CPU
i7 8700K
Graphics
Rx 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I just updated to Catalina. So far so good. I updated the following:
- Updated Clover to 4961 from Tonymac Clover builds​
- Updated to newest Lilu and WhateverGreen kexts​
Then I installed. It took a while, and that booted me into Black Screen. I had to load up a backup, and edit my Clover parameters. I added the following to my Clover config.plist:
- Inject ATI under the Graphics Section​
- agdpmod=pikera as a boot argument​

Now all is good. I will report back any problems.

BruceX Test dropped from 15 secs to 10 secs.
Hi, you did a new installation or did it on the Mojave version?
 

BoomR

Moderator
Joined
Dec 18, 2011
Messages
1,260
Motherboard
Gigabyte Z490 VISION D
CPU
i9-10850K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Apple
  2. Performa
  3. Power Mac
  4. Quadra
Mobile Phone
  1. Android
Hi, you did it direct from the appstore?
Yes. That's really the only way to get macOS updates & upgrades legally.
 
Joined
Aug 9, 2018
Messages
8
Motherboard
GA-Z370 AORUS
CPU
i7 8700K
Graphics
Rx 580
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
I just updated to Catalina. So far so good. I updated the following:
- Updated Clover to 4961 from Tonymac Clover builds​
- Updated to newest Lilu and WhateverGreen kexts​
Then I installed. It took a while, and that booted me into Black Screen. I had to load up a backup, and edit my Clover parameters. I added the following to my Clover config.plist:
- Inject ATI under the Graphics Section​
- agdpmod=pikera as a boot argument​

Now all is good. I will report back any problems.

BruceX Test dropped from 15 secs to 10 secs.
Hi njcoons and BoomR,
I'm following your stepts for my mojave update, after the Catalina installation, when the system is loading and almost completed, appears in my screen a few purples lines, and suddenly the screen turns into black and don't recieve signals from the computer.
Then I reboot from a backup and make the modifications on my conflig.plist.
But the problem continues.
would you know what happen?
I reviewed all the stepts and all looks good :(

Thanks in advance
 

Attachments

  • IMG_1748.PNG
    IMG_1748.PNG
    229.3 KB · Views: 15

BoomR

Moderator
Joined
Dec 18, 2011
Messages
1,260
Motherboard
Gigabyte Z490 VISION D
CPU
i9-10850K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Apple
  2. Performa
  3. Power Mac
  4. Quadra
Mobile Phone
  1. Android
Hi njcoons and BoomR,
I'm following your stepts for my mojave update, after the Catalina installation, when the system is loading and almost completed, appears in my screen a few purples lines, and suddenly the screen turns into black and don't recieve signals from the computer.
Then I reboot from a backup and make the modifications on my conflig.plist.
But the problem continues.
would you know what happen?
I reviewed all the stepts and all looks good :(

Thanks in advance
What happened when you tried the instructions from posts #361 & #362 (above)?
 
Top