Contribute
Register

BoomR's “Power UP” for 360/VR Production Build: GA-Z370 AORUS UG - i7 8700K - GA AORUS RX580

Joined
Jan 10, 2014
Messages
69
Motherboard
Gigabyte Z370 Aorus Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey look in my EFI (previous post) and pick up the usb injector. Made for the Z370 UG and iMacPro SMBIOS.

Hi mate. So, does that mean that USB 3 devices do work in my USB 3 ports? I got it to work lately by using the patches but lost it when I upgraded to 10.14.1...

Was looking at creating a SSDT but I couldn't figure it out. Would be massive if your files work! I will let you know! Thanks in advance.
 
Joined
Feb 19, 2018
Messages
32
Motherboard
Gigabyte AORUS Z370 Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys, I just updated to the Mojave 10.14.1, at first vídeo and sound was off, but once I inserted the new whatevergreen kext, vídeo started to work again. The only problem now is that I have no audio, I already tried the new AppleHDA and Lilu but didn't work. What should I do?
 
Joined
Feb 19, 2018
Messages
32
Motherboard
Gigabyte AORUS Z370 Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Where can I find this kext?
 
Joined
Feb 19, 2018
Messages
32
Motherboard
Gigabyte AORUS Z370 Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Did it, still no sound :(
 
Joined
Jan 10, 2014
Messages
69
Motherboard
Gigabyte Z370 Aorus Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi Sorry my first answer was for @DapperDuck !!!
Try another layer for the sound injection.

Hi @yellocab. I just kinda copied your whole Clover folder, and I must say that my Hack runs pretty well with the config and the iMacPro SMBios. I did, of course, change the serial number by generating a new one. I'm even logged into with iCloud (pro's of having an older iCloud account.)

Funny thing is, my front USB 3.0 ports are currently working! Both USB 2 and 3 devices work in these ports.

The only downside is that the 2 USB 2.0 front ports are kinda non existent. Plugging a USB 2/3 device into it doesn't work as they do not appear on my Hackintosh.

Can you help me out or give me some directions?
 
Joined
Sep 23, 2016
Messages
189
Motherboard
Z390 Designare
CPU
i9 9900k
Graphics
Nitro+ Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi @yellocab. I just kinda copied your whole Clover folder, and I must say that my Hack runs pretty well with the config and the iMacPro SMBios. I did, of course, change the serial number by generating a new one. I'm even logged into with iCloud (pro's of having an older iCloud account.)

Funny thing is, my front USB 3.0 ports are currently working! Both USB 2 and 3 devices work in these ports.

The only downside is that the 2 USB 2.0 front ports are kinda non existent. Plugging a USB 2/3 device into it doesn't work as they do not appear on my Hackintosh.

Can you help me out or give me some directions?

Hi

It's completely normal because I had injected my own USB ports and I only have 2 USB3 front ports. You need to modify the kext. I did for the injection (very easy to do).

You'll need USBinjectAll.kext, IOJones for the analysis and something to edit the plist file. Look at this and try to translate the website. I did my own kext with this method.

Yello
 
Joined
Feb 19, 2018
Messages
32
Motherboard
Gigabyte AORUS Z370 Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi Sorry my first answer was for @DapperDuck !!!
Try another layer for the sound injection.
Can you explain better for me?
I still trying to get sound back, since I updated to mojave I have no Audio devices neither.
When I go to IOReg and search for CodecDevice, I cant find it even If I follow the steps.
Do I need to reinstall my OS to get the AppleHDA native back or can I just use kextwizard to install the newest?
Need to work guys, Im stuck here, please help!
 
Top