Contribute
Register

BoomR's “Power UP” for 360/VR Production Build: GA-Z370 AORUS UG - i7 8700K - GA AORUS RX580

Joined
Aug 22, 2018
Messages
30
Motherboard
Gigabyte Z370 AORUS Ultra Gaming (rev. 1.0)
CPU
i7-8700
Graphics
RX 580
Thanks so much for this guide! I based my first Hackintosh build on this. I tried to get my previous existing system up and running but had issues getting all three of my monitors to work and my motherboard's NIOS had some issue with being able to see the EFI partition so I always needed the USB installed to be able to boot into the MacOS. Had been wanting to upgrade the system so I chose your system to emulate.

I used the exact same hardware as yours for the CPU (except I went with the 8700 non K), MOBO and Video card. I followed your guide exactly except that the version of Multibeast I used did not have the options for:

Drivers->USB - Increase Max Port Limit 200 Series
Customize->Graphics Configuration - AMD Graphics Fixup (required for AMD card!)

I also found if I used iMac 18,3 only one of my three monitors worked. If I chose 14,2 all three worked so I left it there. The only other issue I have is the the onboard audio is't working. I'm not overly concerned about that at this point because I use a USB DAC for my audio that is working. I would like to sort out the onboard though just in case.

So thanks so much for taking the time to outline you build and create this guide. It has been invaluable to a newb like me. Much appreciated!!
 
Joined
Oct 4, 2015
Messages
42
Motherboard
ASUS Prime Z370-a bios version 1412
CPU
i3-8100
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
This is a great build and exactly the sort of machine I'm going to be building, thank you for posting it and hope you don't mind if I hit you up for a few questions during the build.
 
Joined
Aug 12, 2018
Messages
13
Motherboard
Z370 AORUS Ultra Gaming
CPU
i7 8700K
Graphics
HD 630
Mac
  1. iMac
Mobile Phone
  1. Android
Hey @BoomR, I made a similar build to you as I had seen you are an audio guy, too, and seemed very knowledgeable with this stuff. (I am new to Hackintosh myself.) I know you do not use onboard WiFi, and I also don't need this. But I see you use Bluetooth peripherals, and I would like to use them too (Magicpad). I wonder how you got your onboard Bluetooth to work? Any particular MultiBeast or Clover settings? Mine says its working (i.e. says its "on") but won't pair with or recognize any BT devices.

Any advice would be greatly appreciated.
 
Joined
Jan 10, 2014
Messages
69
Motherboard
Gigabyte Z370 Aorus Ultra Gaming
CPU
i7-8700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Has anyone been able to fix the USB 3.0 issues by creating a custom SSDT or something else?

I cannot figure it out how to fix it. USB 2.0 devices work well in USB 3.0 ports but USB 3.0 devices won't.
 
Joined
Sep 21, 2013
Messages
1,027
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900KS
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. Classic
  2. iBook
  3. Power Mac
  4. PowerBook
  5. Quadra
  6. SE/30
Mobile Phone
  1. iOS
Has anyone been able to fix the USB 3.0 issues by creating a custom SSDT or something else?

I cannot figure it out how to fix it. USB 2.0 devices work well in USB 3.0 ports but USB 3.0 devices won't.

What's odd is that although I'm supposed to write a SSDT for USB, the only thing not displaying properly are the PCIe items and of course Thunderbolt.
My build and setup is not special. I only used the recommended settings in this thread.
 
Joined
Sep 23, 2016
Messages
189
Motherboard
Z390 Designare
CPU
i9 9900k
Graphics
Nitro+ Vega 64
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Has anyone been able to fix the USB 3.0 issues by creating a custom SSDT or something else?

I cannot figure it out how to fix it. USB 2.0 devices work well in USB 3.0 ports but USB 3.0 devices won't.

Hey look in my EFI (previous post) and pick up the usb injector. Made for the Z370 UG and iMacPro SMBIOS.
 
Top