Bluetooth Stopped Working. Switched back SSD, still not working.

Not open for further replies.
Apr 28, 2011
GA-Z270X-Ultra Gaming
RX 580
  1. MacBook Pro
Mobile Phone
  1. iOS
TLDR: Upgraded NVME, bluetooth stopped working even with copied files. Switched back NVME, still not working.

Context: I recently ordered a new WD SN750 NVME SSD. I have a 970 EVO but was running out of storage.

1. I made a backup disk bundle with carbon copy cloner to my secondary SSD.
2. Copied files from current EFI partition to a flash drive
3. Swapped current NVME SSD with new one.
4. Booted from USB (bluetooth not working)
5. Restored backup to new NVME
6. Booted from USB
7. Ran Unibeast on new SSD (to make a new EFI partition). Replaced files in new EFI partition with old ones on flash drive

I've tried resetting the NVRAM, the bluetooth module, using and not using a broadcom kext (my understanding is I dont need this with the Fenvi T919), and switching PCI slots. When I switched back to using the old SSD, it will work a little bit after plugging in my keyboard but lags out. It often will show that it's connected, I type on the keyboard and nothing happens. I cant pair my airpods either. I assume this is a software issue? I cant imagine that the card would fail at the same time that I swapped my SSD? I just don't want to wait weeks and spend $60 to replace something that seems to be a software issue.

Any help in this area is much appreciated.
Running macOS 10.15.6 (19G73)


  • ttc-config.plist
    10.4 KB · Views: 21
Not open for further replies.