Contribute
Register

Bluetooth Problems workaround - El Capitan

Joined
Jun 4, 2011
Messages
42
Motherboard
GA-Z270X Gaming 8
CPU
i7-7700k
Graphics
Radeon RX 580
On on both my desktop and my Laptop bluetooth was working under Yosemite and is no longer working under El Capitan
For Laptop (Dell DW155 - Broadcom devices), I tried Rehabman fix:
https://bitbucket.org/RehabMan/os-x-brcmpatchram/overview
It is working on Laptop but not on my Desktop.
For Desktop, I use since Leopard a Bluetooth V2.0 Dongle working OOB:
Supplier : 0x0a12 (Cambridge Silicon Radio Ltd.) - Product : 0x0001
I used a dirty solution, rolling back the bluetooth kexts to Yosemite 10.10.5.
(before trying check that your USB port is working, there are also lot of issues).
How to do and kexts are in the attachement. Note that the kext installer in no longer disabling system protection (method no longer valid in final version). It is making a backup of Kexts.
Kexts in the zip are untouched.
Good luck.
Hi,

I have just updated to 10.11.1 and realised this doesn't seem to work as before. I reinstalled the rollback kexts after updating and now my bluetooth is recognised but won't search/connect to anything. Has anyone else had this problem? I can't think of anything else that has changed since updating.
 

Attachments

Joined
Jul 23, 2012
Messages
8
Motherboard
ASROCK Z77 Extreme 4
CPU
core I5 3.4ghz
Graphics
Radeon RX460
Mac
iMac
Classic Mac
Color Classic, iMac, Plus, Power Mac, SE/30
Mobile Phone
iOS
I used the Yosemite Bluetooth Kexts as suggested and my Bluetooth usb works but my apple mouse has no scroll or swipe functions. When iI try to use the advanced setup options for mouse in system preferences it can't find the mouse even though I am using it. I've tried the other option suggested but does not work for me. Can anyone help
 
Joined
Feb 1, 2012
Messages
3
Motherboard
MSI P67S-C43 B3
CPU
Intel Core i5 2500K @ 4.3GHz
Graphics
Zotac GeForce GTX 680 AMP
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Same Cambridge Silicon Radio Ltd. bluetooth dongle worked with those kexts on 10.11.1, thanks a lot!
I've been using the same dongle with 10.8.5 and there was some kinda occasional lag with the mouse pointer, which can be irritating sometimes. But it seems to be working much better right now!
 
Joined
Dec 3, 2012
Messages
9
Motherboard
GA-Z87M-D3H (Z87 Express chipset)
CPU
i7-4790
Graphics
on-board HD4600
Mac
iMac, MacBook Air
Classic Mac
iMac
Mobile Phone
Android
Hi Guys
Having problems with Bluetooth. Installed OS X 10.11.1 using Unibeast 6.1.1 and Multibeast 8.0.1.
All was well, and working. My Apple trackpad worked fine with a USB dongle, but with the latest update to El Capitan, OS X 10.11.2, it does not. The cursor tracks OK and the left click works but none of the other gestures work, not even the one tap left click.
I applied ReHabMan’s patch - BrcmPatchRAM2.kext and BcmFirmwareRepo.kext using KextBeast into /System/Library/Extensions and it still does not work. The update to the Broadcomm driver appears to have worked but no luck.
I attach my System Report Bluetooth page and the output from the system log.
Any help would be appreciated,
Thanks

Later:
I have, I think, determined that the real problem is probably not Bluetooth, but USB ports. The Bluetooth dongle works fine with the trackpad, but only when it is plugged into certain USB ports. It does not matter whether it is USB 2 or USB 3 or whether on the motherboard or the remote ports. I cannot yet work out why only certain ports work - they work fine with other USB devices, btw. Frustrating? Yes!
Gigabyte Z87M-D3H mobo
 

Attachments

Last edited:
Joined
Jan 2, 2016
Messages
2
Motherboard
Gigabyte GA-X58A-UD3R v2, El Capitan 10.11.2
CPU
Intel® Core™ i7-930 2.80 GHz
Graphics
NVIDIA GeForce GT 720 1Gb
Mac
Classic Mac
Mobile Phone
Android, iOS
Thank you very much. This "dirty" solution is working for me!
 
Joined
Dec 16, 2015
Messages
18
Motherboard
Gigabyte Z97X Gaming 7
CPU
Core i7 4790k
Graphics
GTX 1080
The sensors died on TWO of my magic mouse 1s.

Bought the magic mouse 2 and found it wouldn't work with Yosemite (thanks Apple!)

I've done a clean install of El Crapitan 10.11.3. iogear gbu521

I've tried everything... I've lost track of all the fixes I've tried now.

Bluetooth shows up and it connects and works with the MM1 (but the dead sensor won't track).

It pairs to the MM2 but it won't actually connect with it.

Is there something I need to add to get the Magic Mouse 2 to work?

System report sees the mouse...

Address: AC-BC-32-E6-33-A6
Major Type: Peripheral
Minor Type: Mouse
Services: Magic Mouse 2
Paired: Yes
Configured: Yes
Connected: No
Manufacturer: Broadcom (0x5, 0x240C)
Firmware Version: 0x0064
Vendor ID: 0x004C
Product ID: 0x0269
Class of Device: 0x05 0x20 0x2580
Host Connectable: Yes
EDR Supported: Yes
eSCO Supported: No
SSP Supported: Yes

Thanks for any help!!! :banghead:
 
Joined
Dec 16, 2015
Messages
18
Motherboard
Gigabyte Z97X Gaming 7
CPU
Core i7 4790k
Graphics
GTX 1080
Update: Did a clean install.

During the setup screen after installation, I unplugged my wired mouse and waited for the magic mouse to connect.

It did... The mouse works out of the box :)
 
Joined
Aug 28, 2012
Messages
4
Motherboard
GA-Z68X-UD3H-B3 U1h UEFI
CPU
i5 3.34 Ghz
Graphics
NVIDIA GeForce GTX 650 1024 MB
Mac
MacBook Pro
Classic Mac
Mobile Phone
Android, iOS
Thank you so much [Op].
This [fix] worked for me. I could see my Bluetooth dongle in the USB section but no bluetooth. Using the Yosemite kexts works perfectly for my system. Both Apple mouse and trackpad paired and all gestures working fine. Cheers :clap:

Bluetooth Dongle 2.0 (Cheap crap one)
Product ID:
0x0001Vendor ID: 0x0a12 (Cambridge Silicon Radio Ltd.)
Version: 1.00
Speed: Up to 12 Mb/sec
Manufacturer: Bluetooth v2.0
Location ID: 0x1d110000 / 3




 
Joined
Aug 22, 2015
Messages
8
Motherboard
GA-Z97X-UD7 TH
CPU
i7 4970K
Graphics
GTX 970
Mac
Classic Mac
Mobile Phone
iOS
This [fix] worked for me. Using the Yosemite kexts works perfectly for my system. My keyboard works great!.

Thanks!!
 
Joined
Feb 2, 2013
Messages
25
Motherboard
MSI Z97 Gaming 5
CPU
i7 4790K 4GHz
Graphics
MSI Geforce GTX 970 4GB GDDR5 Video Ram
Mac
iMac
Mobile Phone
Android
This [fix] worked for me. Using the Yosemite kexts works perfectly for my system. My keyboard works great!.

Thanks!!

Hey guys,

I had the same problem another workaround is to install windows in a virtual machine. It works right out the box and just make you windows share with you mac and presto.

I run a windows 10 vm in my mac for productivity as Im in school, this prevents me from having to switch over to windows 10 that I have dual booted all the time. It runs really good with the Parallels updates and of course having plenty of ram and a good CPU is good to. I have 32 Gb of ram and a I7 4790k Overclocked and it run great within my Mac.

So if you dont get it working natively this is a great work around, also if you do alot of youtube uploads and you want to limit your upload so you can still use the internet like watch Netflix while videos are uploading this works great too if you install a software such as Netlimiter and it works wonders.

Hope this helped,

~Gamer~
 
Top