Contribute
Register

Bluetooth not working, icon shows with wavy line (BCM94352)

Joined
Sep 24, 2016
Messages
15
Motherboard
GIGABYTE GA-Z170N-WIFI
CPU
i5 6500
Mac
MacBook Air
Mobile Phone
iOS
Hi everyone
I did successfully update to High Sierra and everything was fine, but after several reboots my bluetooth devices did disconnected. I tried to play with Kext Patches, but nothing helps. After the last reboot I catch bluetooth icon with wave line (Bluetooth: Not Available)
Screen Shot 2017-10-12 at 22.07.17.png


I used next patches:
FakePCIID_Broadcom_WiFi.kext
FakePCIID.kext
FakeSMC.kext
Lilu.kext
IntelMausiEthernet.kext
USBInjectAll.kext
BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext


PCI List here and my config attached
Screen Shot 2017-10-12 at 22.04.09.png
Any ideas how to fix it?
Thanks!
 

Attachments

Joined
Sep 24, 2016
Messages
15
Motherboard
GIGABYTE GA-Z170N-WIFI
CPU
i5 6500
Mac
MacBook Air
Mobile Phone
iOS
any suggestions?
 
Joined
Sep 24, 2016
Messages
15
Motherboard
GIGABYTE GA-Z170N-WIFI
CPU
i5 6500
Mac
MacBook Air
Mobile Phone
iOS
I did try to use MultiBeast, there is no my drive there. Probably because I have APFS?
Screen Shot 2017-10-14 at 12.09.56.png
 
Joined
Feb 3, 2017
Messages
9
Motherboard
h370m ds3h
CPU
i5 8400
Graphics
MSI RX 560 2GB
Mac
iMac
Mobile Phone
Android
Hi everyone
I did successfully update to High Sierra and everything was fine, but after several reboots my bluetooth devices did disconnected. I tried to play with Kext Patches, but nothing helps. After the last reboot I catch bluetooth icon with wave line (Bluetooth: Not Available)
View attachment 285231

I used next patches:
FakePCIID_Broadcom_WiFi.kext
FakePCIID.kext
FakeSMC.kext
Lilu.kext
IntelMausiEthernet.kext
USBInjectAll.kext
BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext


PCI List here and my config attached
View attachment 285233
Any ideas how to fix it?
Thanks!
Hi Dude.
I have the same Card. Wifi is OK but no BT.
Did you fix it.
 
Joined
May 15, 2012
Messages
7
Motherboard
GA-Z170N-Gaming 5 Mini ITX
CPU
Intel - Core i7-6700K 4.0 GHz
Graphics
EVGA Geforce GTX 980 Ti
Mac
iMac
Same issue, almost all the same kexts too. Updating to 10.13.1 to see if this has any effect (the release notes mention fixing bluetooth issues with ApplePay). If anyone figures out a solution, it would be most appreciated if you posted here. Thanks!
 
Joined
Feb 3, 2017
Messages
9
Motherboard
h370m ds3h
CPU
i5 8400
Graphics
MSI RX 560 2GB
Mac
iMac
Mobile Phone
Android
Same issue, almost all the same kexts too. Updating to 10.13.1 to see if this has any effect (the release notes mention fixing bluetooth issues with ApplePay). If anyone figures out a solution, it would be most appreciated if you posted here. Thanks!
Below how I have half success with the bluetooth.
Half success because If I turn off my headset, BT cannot be turned ON/OFF. It's like it no more responding.
Otherwise, AirDrop, peering, search work.
After 2 weeks of hassle, Adding XHCI to HXC and XHC1 to XHC DSDT activated the BT.
I didn't check if both are required.

Screen Shot 2017-11-19 at 10.14.32 PM.png


I didn't need any kext patch and I noticed BrcmFirmwareData.kext and BrcmPatchRAM2.kext are the only needed.
Removing USBInjectAll.Kext and BT Card is detected.

Screen Shot 2017-11-19 at 10.17.17 PM.png


And It is detected as USB3 . (Not sure if it is OK).

Screen Shot 2017-11-19 at 10.21.48 PM.png
 
Joined
Mar 9, 2012
Messages
1,584
Motherboard
GA-Z87X-OC Force
CPU
i7-4770K
Graphics
HD 5770
Mac
iMac, Mac Pro
Mobile Phone
iOS
One method to try -Experiencing Bluetooth problems on your Mac? Try this - The one method that always work for me is if you have another OS X install you need to go to S/L/E in your current build and delete these two kexts IOBluetoothFamily.kext and IOBluetoothHIDDriver.kext and replace them with the ones from your other OS X install.

I don't use use a kext utility - I find them a bit hit and miss with High Sierra, just drag and drop (with SIP partially disabled or disabled), grant permission with password, repair permission, reboot and bluetooth is back on line.
I have attached the two Kexts as mentioned. It's your call if you want to try my method - Good luck.
 

Attachments

Joined
May 15, 2012
Messages
7
Motherboard
GA-Z170N-Gaming 5 Mini ITX
CPU
Intel - Core i7-6700K 4.0 GHz
Graphics
EVGA Geforce GTX 980 Ti
Mac
iMac
Thanks for the advice! I'm using BrcmPatchRAM2 instead of BrcmNonPatchRAM2 and that at least gets the Bluetooth card to show up properly. However, the Bluetooth manager is unable to discover new Bluetooth devices. Since I only really use it for AirDrop, and AirDrop now works, I'm relatively happy with it. I'm running 10.13.2 with FileVault enabled. If anyone discovers a better fix, I'll give it shot.
 
Top