Contribute
Register

Bluetooth not working although displayed as active

Joined
May 3, 2013
Messages
15
Mac
Classic Mac
Mobile Phone
Hello,

I got my Mavericks up and running like a charm now, only thing I would like to have is Bluetooth.

My Bluetooth Adapter is:

Qualcomm Atheros AR3012 Bluetooth 4.0 + HS
class=0xE0, subclass=0x01, vendor=0x0CF3, product=0x3004

And the problem is as follows:
In the bluetooth settings tab i have "Bluetooth: On" but a greyed out button "Turn Bluetooth Off", also it is mentioned that my device is discoverable.

In the system information I have
Code:
[FONT=Lucida Grande]Apple Bluetooth Software Version:    4.2.0f6 12982[/FONT]
[FONT=Lucida Grande]  Hardware Settings:[/FONT]
[FONT=Lucida Grande]  Address:    [/FONT]
[FONT=Lucida Grande]  Manufacturer:    Qualcomm Atheros[/FONT]
[FONT=Lucida Grande]  Name:    b[/FONT]
[FONT=Lucida Grande]  Firmware Version:    5.258 (6.1)[/FONT]
[FONT=Lucida Grande]  Bluetooth Power:    On[/FONT]
[FONT=Lucida Grande]  Discoverable:    Off[/FONT]
[FONT=Lucida Grande]  Connectable:    No[/FONT]
[FONT=Lucida Grande]  Auto Seek Keyboard:    On[/FONT]
[FONT=Lucida Grande]  Auto Seek Pointing:    On[/FONT]
[FONT=Lucida Grande]  Remote wake:    On[/FONT]
[FONT=Lucida Grande]  Vendor ID:    0x0CF3[/FONT]
[FONT=Lucida Grande]  Product ID:    0x3004[/FONT]
[FONT=Lucida Grande]  HCI Version:    0x5[/FONT]
[FONT=Lucida Grande]  HCI Revision:    0x102[/FONT]
[FONT=Lucida Grande]  LMP Version:    0x6[/FONT]
[FONT=Lucida Grande]  LMP Subversion:    0x01[/FONT]
[FONT=Lucida Grande]  Device Type (Major):    Computer[/FONT]
[FONT=Lucida Grande]  Device Type (Complete):    Mac Portable[/FONT]
[FONT=Lucida Grande]  Composite Class Of Device:    0x38010C[/FONT]
[FONT=Lucida Grande]  Device Class (Major):    0x01[/FONT]
[FONT=Lucida Grande]  Device Class (Minor):    0x03[/FONT]
[FONT=Lucida Grande]  Service Class:    0x1C0[/FONT]

The reality is:
My device is not discoverable to others and it cannot find any devices (Magic Mouse for example).

What I tried:
1. Setting the ControllerPowerState manually via:
Code:
sudo defaults write /Library/Preferences/com.apple.Bluetooth ControllerPowerState -int 1
sudo launchctl unload /System/Library/LaunchDaemons/com.apple.blued.plist
sudo launchctl load /System/Library/LaunchDaemons/com.apple.blued.plist
-> no change

2. RehabMan's IOath3kfrmwr.kext -> no change (though I'm not sure if I did it right, installed it once as kext but also tried it via the clover kext folder)

3. Some general bluetooth fix for 10.9 by Edwin_3930K on insanelymac in this post: http://www.insanelymac.com/forum/topic/289871-bluetooth-stuck-in-on-state-and-not-working/
which also didn't work.

I'm out of options, every other solutions I could find are just other ways of doing one of the above 3 things.

Thanks for your help!
 
Joined
May 3, 2013
Messages
15
Mac
Classic Mac
Mobile Phone
I modified the debug version of IOath3kfrmwr.kext to recognise my Bluetooth chip with
PHP:
<key>IOath3kfrmwr-0cf3-3004</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.rehabman.driver.IOath3kfrmwr</string>
<key>CheckEndpoints</key>
<array/>
<key>IOClass</key>
<string>org_rehabman_IOath3kfrmwr</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>PipeNumber</key>
<integer>0</integer>
<key>bcdDevice</key>
<integer>512</integer>
<key>idProduct</key>
<integer>12292</integer>
<key>idVendor</key>
<integer>3315</integer>
</dict>

and didn't get any errors concerning IOath3kfrmwr during boot, bluetooth related messages are still:

PHP:
kernel[0]: **** [IOBluetoothHostControllerUSBTransport][start] -- completed -- result = TRUE -- 0xb000 ****

kernel[0]: [IOBluetoothHCIController][staticBluetoothHCIControllerTransportShowsUp] -- Received Bluetooth Controller register service notification -- 0xb000

kernel[0]: [IOBluetoothHCIController][start] -- completed

kernel[0]: **** [IOBluetoothHostControllerUSBTransport][configurePM] -- ERROR -- waited 30 seconds and still did not get the commandWakeup() notification -- 0xb000 ****

kernel[0]: [IOBluetoothHCIController::setConfigState] calling registerService

kernel[0]: **** [IOBluetoothHCIController][protectedBluetoothHCIControllerTransportShowsUp] -- Connected to the transport successfully -- 0x3700 -- 0x3000 -- 0xb000 ****

The behaviour hasn't changed to the above. So I guess its unrelated to the kexts.
 
Joined
May 20, 2011
Messages
42
Motherboard
Asus H81
CPU
i7-4790
Graphics
GT 740
Mac
  1. iMac
Mobile Phone
  1. Android
same issue here:

patched IOath3kfrmwr disables Bluetooth,:thumbdown

i've also created a a new entry in info.plist/IOKitPersonalities

<key>IOath3kfrmwr-0cf3-3004</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.rehabman.driver.IOath3kfrmwr</string>
<key>CheckEndpoints</key>
<array>
<dict>
<key>EndpointNumber</key>
<integer>2</integer>
<key>TransferType</key>
<integer>0</integer>
</dict>
<dict>
<key>EndpointNumber</key>
<integer>1</integer>
<key>TransferType</key>
<integer>1</integer>
</dict>
</array>
<key>IOClass</key>
<string>org_rehabman_IOath3kfrmwr</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>PipeNumber</key>
<integer>2</integer>
<key>bcdDevice</key>
<integer>1</integer>
<key>idProduct</key>
<integer>12292</integer>
<key>idVendor</key>
<integer>3315</integer>
</dict>

sysPrefs:
Bluetooth:

Apple Bluetooth Software Version: 6.0.5f3
Hardware, Features, and Settings:
Name: lenovo z710
Address: a4-db-30-4b-c6-c2
Bluetooth Low Energy Supported: No
Handoff Supported: No
Instant Hot Spot Supported: No
Manufacturer: Qualcomm Atheros
Transport: USB
Firmware Version: 5.258 (6.1)
Bluetooth Power: On
Discoverable: Off
Connectable: No
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x0CF3
Product ID: 0x3004
HCI Version: 3.0 (0x5)
HCI Revision: 0x102
LMP Version: 4.0 (0x6)
LMP Subversion: 0x01
Device Type (Major): Computer
Device Type (Complete): Mac Portable
Composite Class Of Device: 0x38010C
Device Class (Major): 0x01
Device Class (Minor): 0x03
Service Class: 0x1C0
Auto Seek Keyboard: On
Services:
Bluetooth File Transfer:
Folder other devices can browse: ~/Public
When receiving items: Accept all without warning
State: Disabled
Bluetooth File Exchange:
Folder for accepted items: ~/Downloads
When other items are accepted: Save to location
When receiving items: Accept all without warning
State: Disabled
Bluetooth Internet Sharing:
State: Disabled
Incoming Serial Ports:
Bluetooth-Incoming-Port:
RFCOMM Channel: 3
Requires Authentication: No
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I modified the debug version of IOath3kfrmwr.kext to recognise my Bluetooth chip with
PHP:
<key>IOath3kfrmwr-0cf3-3004</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.rehabman.driver.IOath3kfrmwr</string>
<key>CheckEndpoints</key>
<array/>
<key>IOClass</key>
<string>org_rehabman_IOath3kfrmwr</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>PipeNumber</key>
<integer>0</integer>
<key>bcdDevice</key>
<integer>512</integer>
<key>idProduct</key>
<integer>12292</integer>
<key>idVendor</key>
<integer>3315</integer>
</dict>

and didn't get any errors concerning IOath3kfrmwr during boot, bluetooth related messages are still:

PHP:
kernel[0]: **** [IOBluetoothHostControllerUSBTransport][start] -- completed -- result = TRUE -- 0xb000 ****

kernel[0]: [IOBluetoothHCIController][staticBluetoothHCIControllerTransportShowsUp] -- Received Bluetooth Controller register service notification -- 0xb000

kernel[0]: [IOBluetoothHCIController][start] -- completed

kernel[0]: **** [IOBluetoothHostControllerUSBTransport][configurePM] -- ERROR -- waited 30 seconds and still did not get the commandWakeup() notification -- 0xb000 ****

kernel[0]: [IOBluetoothHCIController::setConfigState] calling registerService

kernel[0]: **** [IOBluetoothHCIController][protectedBluetoothHCIControllerTransportShowsUp] -- Connected to the transport successfully -- 0x3700 -- 0x3000 -- 0xb000 ****

The behaviour hasn't changed to the above. So I guess its unrelated to the kexts.
same issue here:

patched IOath3kfrmwr disables Bluetooth,:thumbdown

i've also created a a new entry in info.plist/IOKitPersonalities

<key>IOath3kfrmwr-0cf3-3004</key>
<dict>
<key>CFBundleIdentifier</key>
<string>org.rehabman.driver.IOath3kfrmwr</string>
<key>CheckEndpoints</key>
<array>
<dict>
<key>EndpointNumber</key>
<integer>2</integer>
<key>TransferType</key>
<integer>0</integer>
</dict>
<dict>
<key>EndpointNumber</key>
<integer>1</integer>
<key>TransferType</key>
<integer>1</integer>
</dict>
</array>
<key>IOClass</key>
<string>org_rehabman_IOath3kfrmwr</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>PipeNumber</key>
<integer>2</integer>
<key>bcdDevice</key>
<integer>1</integer>
<key>idProduct</key>
<integer>12292</integer>
<key>idVendor</key>
<integer>3315</integer>
</dict>

sysPrefs:
Bluetooth:

Apple Bluetooth Software Version: 6.0.5f3
Hardware, Features, and Settings:
Name: lenovo z710
Address: a4-db-30-4b-c6-c2
Bluetooth Low Energy Supported: No
Handoff Supported: No
Instant Hot Spot Supported: No
Manufacturer: Qualcomm Atheros
Transport: USB
Firmware Version: 5.258 (6.1)
Bluetooth Power: On
Discoverable: Off
Connectable: No
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x0CF3
Product ID: 0x3004
HCI Version: 3.0 (0x5)
HCI Revision: 0x102
LMP Version: 4.0 (0x6)
LMP Subversion: 0x01
Device Type (Major): Computer
Device Type (Complete): Mac Portable
Composite Class Of Device: 0x38010C
Device Class (Major): 0x01
Device Class (Minor): 0x03
Service Class: 0x1C0
Auto Seek Keyboard: On
Services:
Bluetooth File Transfer:
Folder other devices can browse: ~/Public
When receiving items: Accept all without warning
State: Disabled
Bluetooth File Exchange:
Folder for accepted items: ~/Downloads
When other items are accepted: Save to location
When receiving items: Accept all without warning
State: Disabled
Bluetooth Internet Sharing:
State: Disabled
Incoming Serial Ports:
Bluetooth-Incoming-Port:
RFCOMM Channel: 3
Requires Authentication: No

Firmware in the kext not likely to be compatible with your device.
You should replace BT/WiFi hardware with compatible Broadcom.
Refer to the FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
May 20, 2011
Messages
42
Motherboard
Asus H81
CPU
i7-4790
Graphics
GT 740
Mac
  1. iMac
Mobile Phone
  1. Android
Firmware in the kext not likely to be compatible with your device.
You should replace BT/WiFi hardware with compatible Broadcom.
Refer to the FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
lenovo laptops include a wifi hw bios white list i'll check if there's any osx compatible Broadcom board supported,
if i load firmware from linux and the reset it works perfectly, so maybe there's a command line option to load it directly, or a EFI module loaded from drivers64UEFI,
do you think it's worth it to develop?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
lenovo laptops include a wifi hw bios white list i'll check if there's any osx compatible Broadcom board supported,
if i load firmware from linux and the reset it works perfectly, so maybe there's a command line option to load it directly, or a EFI module loaded from drivers64UEFI,
do you think it's worth it to develop?

You could always develop your own firmware loader kext based on Linux sources.
Seems like a lot of work for a BT chip that still won't perform very well in macOS though...
 
Joined
May 20, 2011
Messages
42
Motherboard
Asus H81
CPU
i7-4790
Graphics
GT 740
Mac
  1. iMac
Mobile Phone
  1. Android
You could always develop your own firmware loader kext based on Linux sources.
Seems like a lot of work for a BT chip that still won't perform very well in macOS though...
i find it interesting more challenge than practical, i'm currently using a BT dongle that works perfectly,
is your braoadcom firmware loader a good starting point?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
i find it interesting more challenge than practical, i'm currently using a BT dongle that works perfectly,
is your braoadcom firmware loader a good starting point?

I don't think your BT device is Broadcom, is it?
 
Joined
May 20, 2011
Messages
42
Motherboard
Asus H81
CPU
i7-4790
Graphics
GT 740
Mac
  1. iMac
Mobile Phone
  1. Android
I don't think your BT device is Broadcom, is it?
no, it's Qualcomm Atheros AR3012,
the kext BTFirmwareUploader supports it but it's not updated and high sierra 10.13.4 is not supported
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,169
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
no, it's Qualcomm Atheros AR3012,

Then trying to use a Broadcom firmware uploader as a base probably doesn't make sense.

the kext BTFirmwareUploader supports it but it's not updated and high sierra 10.13.4 is not supported

BTFirmwareUploader is also closed source.
 
Top