Contribute
Register

Bluetooth (BCM94352Z) not working on High Sierra

Joined
Sep 27, 2017
Messages
3
Motherboard
Gigabyte GA-Z170N-WIFI
CPU
Core i5-6600K
Graphics
Gigabyte GTX 970 G1
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
My motherboard is Gigabyte GA-Z170N-WIFI, its Intel wifi card can not be driven in macOS. So I bought BCM94352Z m.2 wifi/bluetooth card to replace it.

With following RehabMan's guide (https://github.com/RehabMan/OS-X-BrcmPatchRAM), I downloaded and put BrcmFirmwareData.kext, BrcmPatchRAM2.kext, FakePCIID_Broadcom_WiFi.kext and FakePCIID.kext into the directory /Volumes/EFI/EFI/CLOVER/kexts/Other and hacked config.plist (as below).

Code:
<dict>
    <key>Comment</key>
    <string>AirPortBrcm4360 - fcvo, 10.12.x (credit the-darkvoid)</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    gflSqgAAdSk=
    </data>
    <key>Name</key>
    <string>AirPortBrcm4360</string>
    <key>Replace</key>
    <data>
    gflSqgAAZpA=
    </data>
</dict>

<dict>
    <key>Find</key>
    <data>
    SIX/dEdIiwc=
    </data>
    <key>Name</key>
    <string>IOBluetoothFamily</string>
    <key>Replace</key>
    <data>
    Qb4PAAAA60Q=
    </data>
</dict>

Now, Wifi works well on High Sierra. But unluckily bluetooth can not discover any other devices, and also can not be discovered by my iPhone :( Bluetooth's device list is always empty. Please help.

Screen Shot 2017-10-25 at 10.54.01 PM.png Screen Shot 2017-10-25 at 10.55.01 PM.png
Screen Shot 2017-10-25 at 11.52.43 PM.png
 

Attachments

  • config.plist
    9.2 KB · Views: 351

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,354
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
My motherboard is Gigabyte GA-Z170N-WIFI, its Intel wifi card can not be driven in macOS. So I bought BCM94352Z m.2 wifi/bluetooth card to replace it.

With following RehabMan's guide (https://github.com/RehabMan/OS-X-BrcmPatchRAM), I downloaded and put BrcmFirmwareData.kext, BrcmPatchRAM2.kext, FakePCIID_Broadcom_WiFi.kext and FakePCIID.kext into the directory /Volumes/EFI/EFI/CLOVER/kexts/Other and hacked config.plist (as below).

Code:
<dict>
    <key>Comment</key>
    <string>AirPortBrcm4360 - fcvo, 10.12.x (credit the-darkvoid)</string>
    <key>Disabled</key>
    <false/>
    <key>Find</key>
    <data>
    gflSqgAAdSk=
    </data>
    <key>Name</key>
    <string>AirPortBrcm4360</string>
    <key>Replace</key>
    <data>
    gflSqgAAZpA=
    </data>
</dict>

<dict>
    <key>Find</key>
    <data>
    SIX/dEdIiwc=
    </data>
    <key>Name</key>
    <string>IOBluetoothFamily</string>
    <key>Replace</key>
    <data>
    Qb4PAAAA60Q=
    </data>
</dict>

Now, Wifi works well on High Sierra. But unluckily bluetooth can not discover any other devices, and also can not be discovered by my iPhone :( Bluetooth's device list is always empty. Please help.

View attachment 288025 View attachment 288027
View attachment 288026
all kexts should be installed to system

and in config.plist:
<key>InjectKexts</key>
<string>Yes</string>

should be:
<key>InjectKexts</key>
<string>Detect</string>

only FakeSMC.kext and ethernet kext should be in clover/kexts/other

also high sierra doesn't need config.plist patches to make it work
 
Joined
Sep 27, 2017
Messages
3
Motherboard
Gigabyte GA-Z170N-WIFI
CPU
Core i5-6600K
Graphics
Gigabyte GTX 970 G1
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
all kexts should be installed to system

and in config.plist:
<key>InjectKexts</key>
<string>Yes</string>

should be:
<key>InjectKexts</key>
<string>Detect</string>

only FakeSMC.kext and ethernet kext should be in clover/kexts/other

also high sierra doesn't need config.plist patches to make it work

I moved BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID_Broadcom_WiFi.kext and FakePCIID.kext into /System/Library/Extensions, and modified InjectKexts to Detect. However none of wifi and bluetooth can be recognized now :eek:

Screen Shot 2017-10-26 at 9.16.11 PM.png
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
20,354
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Feb 27, 2016
Messages
14
Motherboard
Gigabyte Z170N WiFi
CPU
i7-6700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Did you ever solve this problem, I have the same motherboard and wifi/bt chip with the same problem?
 
Joined
Feb 27, 2016
Messages
14
Motherboard
Gigabyte Z170N WiFi
CPU
i7-6700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I have the same issue, any solution?
I'm not entirely sure how I did it, but I changed my SMBIOS from iMac 14,2 to 17,1 as well as reinstalling the latest versions of each of Rehabman's kexts (BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID_Broadcom_WiFi.kext and FakePCIID.kext). I added this to KextstoPatch and it did the trick:
<dict>
<key>Comment</key>
<string>BCM4352-fvco, (credit Sherlocks based on the-darkvoid original)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
gf9SqgAAdMQ=
</data>
<key>Name</key>
<string>com.apple.driver.AirPort.BrcmNIC-MFG</string>
<key>Replace</key>
<data>
gf9SqgAAZpA=
</data>
</dict>

Your mileage may vary, but I'd start with those as those were the steps I took to get mine working.
 
Joined
Jul 13, 2015
Messages
2
Mac
Classic Mac
Mobile Phone
I'm not entirely sure how I did it, but I changed my SMBIOS from iMac 14,2 to 17,1 as well as reinstalling the latest versions of each of Rehabman's kexts (BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID_Broadcom_WiFi.kext and FakePCIID.kext). I added this to KextstoPatch and it did the trick:
<dict>
<key>Comment</key>
<string>BCM4352-fvco, (credit Sherlocks based on the-darkvoid original)</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
gf9SqgAAdMQ=
</data>
<key>Name</key>
<string>com.apple.driver.AirPort.BrcmNIC-MFG</string>
<key>Replace</key>
<data>
gf9SqgAAZpA=
</data>
</dict>

Your mileage may vary, but I'd start with those as those were the steps I took to get mine working.

Didn't work for me :(
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,500
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@monfard, please update your profile (personal details) with your Motherboard or Make/Model, CPU and Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Sep 13, 2015
Messages
65
Motherboard
ASUS VivoBook S15 S530Fn
CPU
i7-8565U
Graphics
UHD 620 + GeForce MX150 [1920x1080]
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Mobile Phone
  1. Android
  2. iOS
I have the same Combo card. It says that it´s working but it´s not discovering any bluetooth devices (already tried to reset bt module)... I also tried to change my system config to iMac 17,1 without any success... What else can I try to do? Does anyone else gets the same result as me ?
 
Top