Contribute
Register

Black Screen with Radeon HD 5770

Joined
Aug 31, 2013
Messages
24
Motherboard
ASUS P5QL PRO
CPU
2,5 GHz Xeon
Graphics
HD 5000
Mac
MacBook Pro
Mobile Phone
iOS
Hello,

I have successfully installed High Sierra 10.13.6 (thanks to the people here who helped me in my last post)
I have the lastest version of clover- v2.4k r4617 , but I got a black screen after the apple logo finishes to load.

I have tried many solutions read here (lilu/whatevergreen/AMD5000 kext..).You'll find a screenshot of my kext/other folder here
I have tried some config.plist but nothing changed.

My graphic card was correctly working with Sierra,but now I cannot make it work (even if the installation process was fine).

I would be happy to test any help from here, to copy/paste some working EFI/Kext/Other or config.plist working.

It is so frustrating since I was read a lot of post around here without finding a solution..

Please help!

PS: I can post any information that could be usefull to help me to fix this

Thanks
 

Attachments

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,495
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
WhateverGreen is supposed to fix the blackscreen issue with a number of graphics options. I have 10.13.5 running in a build with a HD5770 and using nothing. I haven't had time to look at updating yet....

Have you checked that you are using the latest lilu and WhateverGreen. Is that a third party AM5000 kext - If so remove it too.
 
Joined
Aug 31, 2013
Messages
24
Motherboard
ASUS P5QL PRO
CPU
2,5 GHz Xeon
Graphics
HD 5000
Mac
MacBook Pro
Mobile Phone
iOS
Hello Adrian B,
Thanks for the reply.
I’ll remove the am5000 kext and check about the number thing with whatevergreen. The number are some boot args? What was/are your working boot args?
 
Joined
Aug 31, 2013
Messages
24
Motherboard
ASUS P5QL PRO
CPU
2,5 GHz Xeon
Graphics
HD 5000
Mac
MacBook Pro
Mobile Phone
iOS
I have tried with : radpg=15 -v darkwake=0 and still black screen.
Is there any special arg for the Radeon HD 5570 ?
Mi connection with my monitor is with DVI. Do I have to change something else ?
 
Joined
Nov 9, 2015
Messages
87
Motherboard
GIGABYTE Z170XP-SLI
CPU
I5-6600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I have tried with : radpg=15 -v darkwake=0 and still black screen.
Is there any special arg for the Radeon HD 5570 ?
Mi connection with my monitor is with DVI. Do I have to change something else ?
Wait. are you using 5770 or 5570? My 5770 is working without any kexts fine.
 
Joined
Aug 31, 2013
Messages
24
Motherboard
ASUS P5QL PRO
CPU
2,5 GHz Xeon
Graphics
HD 5000
Mac
MacBook Pro
Mobile Phone
iOS
Hello,

it's a HD 5770.
Without kext it is not working.
I have managed to make it work with 2 args : radpg=15 (not working alone) and -radvesa
But it not confortable at all...
 
Joined
Nov 9, 2015
Messages
87
Motherboard
GIGABYTE Z170XP-SLI
CPU
I5-6600K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
W
Hello,

it's a HD 5770.
Without kext it is not working.
I have managed to make it work with 2 args : radpg=15 (not working alone) and -radvesa
But it not confortable at all...
What's that AMD5000 controller kext doing in your efi. That's bizarre still.. Im using the Sapphire Radeon 5770 and the card starts working without doing anything. Im using 17,1 imac smbios though
 
Joined
Aug 31, 2013
Messages
24
Motherboard
ASUS P5QL PRO
CPU
2,5 GHz Xeon
Graphics
HD 5000
Mac
MacBook Pro
Mobile Phone
iOS
I removed everything except lilu, whatevergreen and fakeSMC
 
Joined
Aug 31, 2013
Messages
24
Motherboard
ASUS P5QL PRO
CPU
2,5 GHz Xeon
Graphics
HD 5000
Mac
MacBook Pro
Mobile Phone
iOS
I can only make it work with -radvesa , which keeps off video acceleration and glitches the screen..
Here is a screenshot of my About Mac

Any idea to make it work (the radpg=15 isn't working)
I have try -rad24 and I get black screen(saw a post with this on this forum)
I have try some kext(Amdx4000.. saw on this forum, but it didnt work)
The only thing working yet is -radvesa

Thanks for my eyes
 

Attachments

Last edited:

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,495
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
Top