Contribute
Register

Black Screen with MacPro 6,1 or iMac 15 or iMac 17 System Definition

Joined
Sep 20, 2016
Messages
29
Motherboard
Gigabyte H-170
CPU
Intel Skylake i5-6500 CPU
Mac
MacBook Pro, Mac mini
Mobile Phone
Android
Just came across this topic while searching for the fix to a black screen.

When starting up Clover displays on two screens, but once it gets to the login screen the second "turns off". System Preferences displays two monitors as being available & when screen sharing the second one shows up. Im using both HDMI ports on my MOBO.

The AGDPfix doesn't seem to be making a difference for me, I've ticked "kext-dev-mode=1" in Clover
 
Joined
Sep 20, 2016
Messages
29
Motherboard
Gigabyte H-170
CPU
Intel Skylake i5-6500 CPU
Mac
MacBook Pro, Mac mini
Mobile Phone
Android
@eseanq have you resolved it? I have the same problem. Which version do you run?
Nope. Still only have the one monitor working. Haven't had much time to mess around with it. As far as the version, are you referring to OSX? If so then I'm running 10.14.2.
 
Joined
Dec 30, 2017
Messages
7
Motherboard
z370n WiFi
CPU
i7 9700K
Graphics
RX 580 OEM
Mac
MacBook Pro
Mobile Phone
Android, iOS
I have very same problem with my computer. Every time it boots, after apple loading logo there is black screen. I need to unplug and plug it back for it to work. I am using AMD OEM RX 580 card. Any suggestion how to fix the issue in my case?
 
Joined
Jan 9, 2019
Messages
14
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
GT 1030
Nope. Still only have the one monitor working. Haven't had much time to mess around with it. As far as the version, are you referring to OSX? If so then I'm running 10.14.2.
I also face the same issue. I cannot boot with 2 monitors connected with HDMI & DVI. I spent a couple of hours last night trying to resolve this to no avail.

I would love to know how to fix this
 
Top