Black Screen with MacPro 6,1 or iMac 15 or iMac 17 System Definition

Discussion in 'Graphics' started by shilohh, Jan 7, 2016.

  1. TheFatBear

    TheFatBear

    Joined:
    Feb 6, 2017
    Messages:
    22
    Mobo:
    Gigabyte GA-170X-UD3 Ultra (rev 1.0)
    CPU:
    Intel i7-6700k
    Graphics:
    Gigabyte GeForce GTX 950 (GV-N950EXTREME-2GD)
    Mac:
    MacBook Pro
    Mobile Phone:
    Android, iOS
    Sep 29, 2017 at 12:54 AM #421
    TheFatBear

    TheFatBear

    Joined:
    Feb 6, 2017
    Messages:
    22
    Mobo:
    Gigabyte GA-170X-UD3 Ultra (rev 1.0)
    CPU:
    Intel i7-6700k
    Graphics:
    Gigabyte GeForce GTX 950 (GV-N950EXTREME-2GD)
    Mac:
    MacBook Pro
    Mobile Phone:
    Android, iOS
    Thanks, apparently my problem was that I didn't update Lilu.kext to latest version.
     
  2. ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    531
    Mobo:
    GA-Z170X-ULTRA GAMING
    CPU:
    i7 6600k
    Graphics:
    HD530
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Oct 3, 2017 at 4:39 PM #422
    ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    531
    Mobo:
    GA-Z170X-ULTRA GAMING
    CPU:
    i7 6600k
    Graphics:
    HD530
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    If you are booting to a black screen after installing new Lilu and intelgraphicsfixup kexts then make sure screen sharing is enabled and the rebuild the Kernal Cache. That has worked for me a couple of times.

    Code (Text):
    sudo touch /System/Library/Extensions && sudo kextcache -u /
     
     
    Last edited: Oct 4, 2017
  3. toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 7, 2017 at 7:50 PM #423
    toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Hey I tried this and it seems like lilu and nvidiafix can’t be installed properly or loaded, it gives me a “lilu is not authentic” and it declines both kexts
     
  4. ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    531
    Mobo:
    GA-Z170X-ULTRA GAMING
    CPU:
    i7 6600k
    Graphics:
    HD530
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Oct 7, 2017 at 8:02 PM #424
    ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    531
    Mobo:
    GA-Z170X-ULTRA GAMING
    CPU:
    i7 6600k
    Graphics:
    HD530
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Sounds like you need to disable SIP?
     
  5. toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 7, 2017 at 8:10 PM #425
    toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Already disabled (0x67) right ? Same error again and still have the black screen , screen share shows that my graphics card is working
     
  6. ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    531
    Mobo:
    GA-Z170X-ULTRA GAMING
    CPU:
    i7 6600k
    Graphics:
    HD530
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    Oct 7, 2017 at 8:21 PM #426
    ovb1

    ovb1

    Joined:
    Aug 1, 2011
    Messages:
    531
    Mobo:
    GA-Z170X-ULTRA GAMING
    CPU:
    i7 6600k
    Graphics:
    HD530
    Mac:
    MacBook Air
    Mobile Phone:
    iOS
    What does 'csrutil status' tell you?
     
  7. toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 7, 2017 at 8:25 PM #427
    toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    It says disabled
     
  8. toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 7, 2017 at 8:27 PM #428
    toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    EBA218AA-4101-4DF9-8DBE-72CD2B80C5AC.png
    This is what I get (I’m using a screen share)
     
  9. iLikeHackintosh

    iLikeHackintosh

    Joined:
    Sep 22, 2016
    Messages:
    93
    Mobo:
    Z170X-UD5 TH
    CPU:
    i7-6700K
    Graphics:
    NVIDIA GeForce GTX 970 4GB
    Mobile Phone:
    iOS
    Oct 9, 2017 at 11:40 PM #429
    iLikeHackintosh

    iLikeHackintosh

    Joined:
    Sep 22, 2016
    Messages:
    93
    Mobo:
    Z170X-UD5 TH
    CPU:
    i7-6700K
    Graphics:
    NVIDIA GeForce GTX 970 4GB
    Mobile Phone:
    iOS
    but how i get into system to apply those fixes?
     
  10. toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Oct 12, 2017 at 5:50 PM #430
    toxicthroat

    toxicthroat

    Joined:
    Mar 3, 2017
    Messages:
    52
    Mobo:
    Msi z170a krait gaming x3
    CPU:
    Intel i7 6700k
    Graphics:
    EVGA Gtx 1070 sc sli
    Mac:
    iMac
    Mobile Phone:
    iOS
    Start clover with boot arg nv_disabled=1
     

Share This Page