Black screen while loading clean install

Not open for further replies.
Mar 9, 2017
RX 580
  1. MacBook Pro
Mobile Phone
  1. Android
Hi, after trying almost everything I got stuck installing Catalina on my CustoMac since a couple of months. Due to my job I didn't had time to post on the forum or to try constantly various ways to get my installation loaded and performed.
Right now I've some time and I'm trying to solve this problem, or better, I have to.
Usually, before to change my hardware (CPU and NVMe SSD), I've performed a lot of clean installations during the last years on the same MoBo without any problem.

After creating the installation USB with the createinstallmedia and installing the latest version of Clover with proper kexts and SMBIOS (18,3), I boot from the USB but after it loads instead of getting the initial screen where you can choose the language, I get a black screen (the monitor is turned on but black) and I can't continue with the installation.

The strangest thing is that if I don't reset or shutdown the computer while it shows the black screen, it will enter in sleep mode (fans and all the rest turned off) and if I press a key afterwards it wakes up showing the language selection and I can proceed with the installation, after formatting the drive and going ahead when it reboots and shows the apple logo while it is loading (continuing installation) after 20 seconds it turns to show again this black screen and then it reboots again. After rebooting I can only repeat what I wrote since the start. So the installation is not proceeding while the screen is black, I'm quite sure about this.

I tried so far everything: switching from a DP2HDMI cable to HDMI cable, switching monitor, using EFIs provided by @pastrychef who has the same MoBo (both Clover and OpenCore), using UniBeast (before to change my hardware I could use UniBeast and run the installation without even touching config.plist file).

I think that is a problem related to this damned CPU without iGPU because before to change it (I used to have a i9-9900K) i could run and perform setups without even touching the EFI folder of the installation USB drive.

My hardware is:

- Asus Z370-G Gaming
- Intel i9400F (without iGPU)
- Gigabyte RX 580 Gaming
- Samsung 970 EVO M2 SSD 240GB
- Samsung 850 EVO 500GB
- Seagate Barracuda 1TB
- Crucial Ballistix Sport LT 2400 2 x 8 GB
- Thermaltake PSU 600W

Thanks in advance for any further answer, I'm struggling.
Last edited:
Update: Solved by pastrychef here.
Not open for further replies.