Contribute
Register

<< Solved >> Black screen when trying to install catalina 10.15.7 opencore

Joined
Dec 9, 2020
Messages
4
Motherboard
Gigabyte z390-ud
CPU
i5 9400
Graphics
UHD 630
UPDATE problem is fixed. the post is for anyone with the same problem, i will be happy to answer questions!

Hello, i am new in this whole thing and trying to install catalina.
I have Gigabyte z390 ud with intel core i5 9400 and no gpu
Corsair 8x2 RAM
Samsung evo 860 500gb SSD

I followed the open core guide in this link:

and some of the files in this link:

I used gibMacOS to download mac and make the usb

The problem is when I choose the option MacOs Base System from the bootloader it shows the Apple logo and the loading bar, gets half full and then the screen becomes black while the computer keeps working.

I did change the 'AAPL,ig-platform-id' to 00009B3E but it still happened.

I want to mention that I did try to install with clover first, and the same exact thing happened as well..

I am attaching the EFI and some logs as if someone would be able to help me.
thank you very much, I'd be glad for every idea!
 
Last edited:
Joined
Jul 2, 2019
Messages
8
Motherboard
Gigabyte B360 Aorus Pro
CPU
i7-8700
Graphics
RX 580
I'm stuck with black screen like you, plz help me out.
 
Joined
Dec 9, 2020
Messages
4
Motherboard
Gigabyte z390-ud
CPU
i5 9400
Graphics
UHD 630
I'm stuck with black screen like you, plz help me out.
Ok, you need to change the settings of the graphic card, the catch here is that the same settings of the installation is not the best settings when mac is already installer.. you need to find the settings for the installation
Code:
<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
<dict>
<key>AAPL,ig-platform-id</key>
<data>
AACSPg==
</data>
<key>Igfxfw</key>
<data>
AgAAAA==
</data>
<key>framebuffer-con0-busid</key>
<data>
BQAAAA==
</data>
<key>framebuffer-con0-enable</key>
<data>
AQAAAA==
</data>
<key>framebuffer-con0-flags</key>
<data>
xwMAAA==
</data>
<key>framebuffer-con0-index</key>
<data>
AQAAAA==
</data>
<key>framebuffer-con0-pipe</key>
<data>
EgAAAA==
</data>
<key>framebuffer-con0-type</key>
<data>
AAgAAA==
</data>
<key>framebuffer-con1-busid</key>
<data>
AgAAAA==
</data>
<key>framebuffer-con1-enable</key>
<data>
AQAAAA==
</data>
<key>framebuffer-con1-flags</key>
<data>
xwMAAA==
</data>
<key>framebuffer-con1-index</key>
<data>
AgAAAA==
</data>
<key>framebuffer-con1-pipe</key>
<data>
EgAAAA==
</data>
<key>framebuffer-con1-type</key>
<data>
AAgAAA==
</data>
<key>framebuffer-con2-busid</key>
<data>
BAAAAA==
</data>
<key>framebuffer-con2-enable</key>
<data>
AQAAAA==
</data>
<key>framebuffer-con2-flags</key>
<data>
xwMAAA==
</data>
<key>framebuffer-con2-index</key>
<data>
AwAAAA==
</data>
<key>framebuffer-con2-pipe</key>
<data>
EgAAAA==
</data>
<key>framebuffer-con2-type</key>
<data>
AAgAAA==
</data>
<key>framebuffer-con3-busid</key>
<data>
AAAAAA==
</data>
<key>framebuffer-con3-enable</key>
<data>
AQAAAA==
</data>
<key>framebuffer-con3-flags</key>
<data>
IAAAAA==
</data>
<key>framebuffer-con3-index</key>
<data>
/////w==
</data>
<key>framebuffer-con3-pipe</key>
<data>
AAAAAA==
</data>
<key>framebuffer-con3-type</key>
<data>
AQAAAA==
</data>
<key>framebuffer-patch-enable</key>
<data>
AQAAAA==
</data>
 
Top