Contribute
Register

Black screen after upgrade from Mojave to Catalina +++++++++++++++

Status
Not open for further replies.
Joined
Jan 19, 2013
Messages
32
Motherboard
GA-Z97x-UD5H-BK
CPU
i5 4690
Graphics
Radeon RX 580 8 GB
Mac
  1. iMac
The first part of the installation worked fine. On reboot to clover, no matter which option I choose (install to catalina or boot to catalina) I get a black screen. I'm using HDMI cable. I've tried plugging into my Radeon RX 580 card as well as the MOBO HDMI port with the same results. I removed Whatevergreen from my kexts and updated both Clover and all kexts I previously had (all are now in kexts\other).

If I boot from clover in verbose mode, I get all +++++++++ on a black screen.

I'm using Clover 5.6.2.0
Drivers\UEFI has
apfs.efi
apfsdriverloader-64.efi
apfsdriverloader.efi

Same in drivers64uefi

Kexts\Other has:
AppleALC.kext
AtherosE2200Ethernet.kext
AtherosL1cEthernet.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
FakeSMC_SMMSensors.kext
FakeSMC.kext
Lilu.kext
USBInjectAll.kext

Config.plist is attached

Not sure what to do next to resolve the issue.

Thanks in advance for any help you can provide.
 

Attachments

  • config.plist
    4 KB · Views: 48
Last edited:
Joined
Feb 24, 2019
Messages
32
Motherboard
Asus ROG Z390 MAXIMUS XI CODE
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
The first part of the installation worked fine. On reboot to clover, no matter which option I choose (install to catalina or boot to catalina) I get a black screen. I'm using HDMI cable. I've tried plugging into my Radeon RX 580 card as well as the MOBO HDMI port with the same results. I removed Whatevergreen from my kexts and updated both Clover and all kexts I previously had (all are now in kexts\other).

If I boot from clover in verbose mode, I get all +++++++++ on a black screen.

I'm using Clover 5.6.2.0
Drivers\UEFI has
apfs.efi
apfsdriverloader-64.efi
apfsdriverloader.efi

Same in drivers64uefi

Kexts\Other has:
AppleALC.kext
AtherosE2200Ethernet.kext
AtherosL1cEthernet.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
FakeSMC_SMMSensors.kext
FakeSMC.kext
Lilu.kext
USBInjectAll.kext

Config.plist is attached

Not sure what to do next to resolve the issue.

Thanks in advance for any help you can provide.
The same..... Anybody??
 
Last edited:
Joined
Mar 10, 2011
Messages
342
Motherboard
Gigabyte Designare TRX40
CPU
Ryzen 3970x
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I notice No memory fix driver
Depending on motherboard you will need one of the four available
And the EC fix as well
 
Joined
Feb 24, 2019
Messages
32
Motherboard
Asus ROG Z390 MAXIMUS XI CODE
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
I notice No memory fix driver
Depending on motherboard you will need one of the four available
And the EC fix as well
I have Asus ROG Z390 MAXIMUS XI CODE. How to do it?
 
Joined
Jan 19, 2013
Messages
32
Motherboard
GA-Z97x-UD5H-BK
CPU
i5 4690
Graphics
Radeon RX 580 8 GB
Mac
  1. iMac
I notice No memory fix driver

Thanks Foster - I went back and looked at the backup EFI folder on the root of my drive and realized that I did have other memory fix drivers there. I guess updating Clover deletes those drivers. My system is now up and continuing the installation. Very much appreciated.
 
Joined
Mar 10, 2011
Messages
342
Motherboard
Gigabyte Designare TRX40
CPU
Ryzen 3970x
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have Asus ROG Z390 MAXIMUS XI CODE. How to do it?

Most likely use this one
OsxAptioFix2Drv-free2000.efi
Is not part of clover installer packages
 
Joined
Mar 31, 2010
Messages
310
Motherboard
ASUS Prime Z390-P
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
use Clover 5096 or newer
only install
* drivers/UEFI
ApfsDrvierLoader.efi
OsxAptioFix3Drv.efi
the kext you have are good
 
Joined
Feb 24, 2019
Messages
32
Motherboard
Asus ROG Z390 MAXIMUS XI CODE
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
For now, installation process stack on:


Any ideas?
 

Attachments

  • 7CE82D00-75D9-47EC-91E0-589BCB145E59.jpeg
    7CE82D00-75D9-47EC-91E0-589BCB145E59.jpeg
    273.4 KB · Views: 42
  • 290880D6-8E02-4A3C-86D1-B886DB6A43F5.jpeg
    290880D6-8E02-4A3C-86D1-B886DB6A43F5.jpeg
    246.8 KB · Views: 37
Joined
Feb 24, 2019
Messages
32
Motherboard
Asus ROG Z390 MAXIMUS XI CODE
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Anyone??? Please.
 

Attachments

  • A707550F-0429-49D9-A0E0-6BA30C0BAFC8.jpeg
    A707550F-0429-49D9-A0E0-6BA30C0BAFC8.jpeg
    244.6 KB · Views: 34
  • 2E116593-2218-4224-9E4A-8F7E8977E334.jpeg
    2E116593-2218-4224-9E4A-8F7E8977E334.jpeg
    273.7 KB · Views: 43
  • 9C0753CB-4362-40D8-A692-7F4F9310AB31.jpeg
    9C0753CB-4362-40D8-A692-7F4F9310AB31.jpeg
    282.6 KB · Views: 38
Status
Not open for further replies.
Top