Contribute
Register

Bios doesn't recognise my drive as an UEFI option, but it recognises my USB

Joined
Jun 11, 2022
Messages
6
Motherboard
ASRock H81M-VG4
CPU
i5-4460
Graphics
RX 560
Hi guys, need a little help. I disabled VT-d, CSM and everything that could interrupt booting. I set my bios to see UEFI devices but it only sees my USB, and yes I copied EFI folder to EFI partition. The thing is, I don't have Windows installed, so I can't use EasyUFEI, is there something else I can do? Please help.
 

trs96

Moderator
Joined
Jul 30, 2012
Messages
23,286
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
What OS did you use to format and partition the hard drive you'll be installing to ? Does the drive already have anything on it ? What is most important is that you can boot from the USB into macOS recovery to be able to format and partiition the drive with Disk Utility. Do you get that far ?
 
Joined
Jun 11, 2022
Messages
6
Motherboard
ASRock H81M-VG4
CPU
i5-4460
Graphics
RX 560
I used Disk Utility to format my SSD, and I am currently using MacOS that's on it, but can only boot into it with USB.
My problem is that after installation my BIOS doesn't recognise EFI partition on my SSD, so I need to boot with EFI from USB..
 

trs96

Moderator
Joined
Jul 30, 2012
Messages
23,286
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
My problem is that after installation my BIOS doesn't recognise EFI partition on my SSD, so I need to boot with EFI from USB..
Is the EFI folder on the SSD an exact copy of the EFI folder on the USB ? You don't need to boot the SSD from the BIOS only from the OC bootloader GUI screen.
 

trs96

Moderator
Joined
Jul 30, 2012
Messages
23,286
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
You haven't mentioned the macOS version or the boot loader that's installed.

It's most likely that you did something wrong in Disk Utility. Maybe you didn't select APFS Format when you erased the SSD ? Did you make the scheme GUID ?

1654949892604.png
 
Last edited:
Joined
Jun 11, 2022
Messages
6
Motherboard
ASRock H81M-VG4
CPU
i5-4460
Graphics
RX 560
MacOS Monterey 12.4, OpenCore.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,516
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
You haven't mentioned the macOS version or the boot loader that's installed.

It's most likely that you did something wrong in Disk Utility. Maybe you didn't select APFS Format when you erased the SSD ?

View attachment 549424
macOS would have converted the drive to APFS anyway on installation :)

best for the user to click on view, show all devices and the erase the entire drive

then after installation, mount EFI partition and then copy over entire EFI folder over
 

trs96

Moderator
Joined
Jul 30, 2012
Messages
23,286
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
mount EFI partition and then copy over entire EFI folder over
This was done already. OP says it's the exact same EFI that's on the USB that does work.
 

trs96

Moderator
Joined
Jul 30, 2012
Messages
23,286
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Top