Contribute
Register

Big Sur Sleep problems

Joined
May 29, 2012
Messages
419
Motherboard
Gigabyte Z390 Gaming X
CPU
i9-9900K
Graphics
Vega 56
Mac
  1. iMac
Classic Mac
  1. LC
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Hi all —

Since upgrading to Big Sur (latest 11.1), I’ve been dealing with sleep problems. The problem appeared during one of the later betas. Before, and in Catalina, I had no problems at all. I don’t see anyone with similar issues so I am scratching my head here. I’m putting it out here if anyone has any idea.

By sleep, I am referring to the system going into hibernation mode, so the displays turn off, and the computer hibernates (all the fans shut off, all the lights turn off). By pressing a key or mouse button once, the computer wakes up again, with the fans spinning up and the lights coming on. A second key press activates the display and password prompt. (I know there is a fix for the 2-button presses, but it broke my sleep before)

When sleep breaks, the system will not go into hibernation mode. The displays turn off, but the fans, lights are still operational, and one key press will activate the display.

Observations:

1. A fresh install (meaning reformat system drive then reinstall Big Sur) will fix the problem
2. Restoration of a CCC-backup onto the fresh install will reintroduce the problem, so I think it is a preference or settings somewhere.
3. A fresh install, then reinstallation of all my applications fixed the problem for a while. For weeks I think. But eventually, sleep broke again.
4. Using a Time Machine backup to restore the system back to when sleep was working will fix the problem, but eventually sleep breaks again.
5. Using pmset -g assertions before and after sleep breaks, there is nothing different that suggests something pops up to prevent sleep
5. When sleep breaks, I can delete the following from Library/Preferences, then restart

com.apple.powerlogd.plist
com.apple.PowerManagement.7D11C3CC-80C9-56F3-84C8-BDFB8E5B39B3.plist
com.apple.PowerManagement.plist


And sleep functions again. But eventually it will break.

Currently, I have my system to hibernate after 1 hr. I’ve tried disconnecting all my USB devices, hard drives, etc.

I have unchecked “Prevent computer from sleeping automatically when the display is off” and “Wake for Wi-Fi network access.”

I have checked “Put hard disks to sleep when possible”

Any ideas? I’m stumped.

Thanks in advance

Ted
 
Top