Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Aug 8, 2010
Messages
22
Motherboard
HP Elitedesk 800 G1
CPU
i7-4765T
Graphics
HD4600
My hardware for the machine are as follow:

  • Intel core i7-4765T processor
  • Intel Q87 express
  • Intel HD graphics on all models (integrated on processor)
  • 2 Display Ports
  • Ethernet (RJ-45): Intel I217LM Gigabit Network Connection (standard)
  • Wireless: Intel Wireless-N 7260 802.11 M.2 a/b/g/n NIC card
  • HD audio with Realtek ALC221 codec (all ports are stereo)
  • VGA port
  • 16 gb of ram
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
24,271
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
My hardware for the machine are as follow:

  • Intel core i7-4765T processor
  • Intel Q87 express
  • Intel HD graphics on all models (integrated on processor)
  • 2 Display Ports
  • Ethernet (RJ-45): Intel I217LM Gigabit Network Connection (standard)
  • Wireless: Intel Wireless-N 7260 802.11 M.2 a/b/g/n NIC card
  • HD audio with Realtek ALC221 codec (all ports are stereo)
  • VGA port
  • 16 gb of ram
please update your hardware profile to allow others to help you easier
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
21,030
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
My hardware for the machine are as follow:

  • Intel core i7-4765T processor
  • Intel Q87 express
  • Intel HD graphics on all models (integrated on processor)
It's apparent this is an HP G1 Haswell based PC with HD4600 graphics. Which is OT for this thread for the HP G4/G5. The included EFI will not work.


Screen Shot 10.jpg
 
Joined
Sep 22, 2011
Messages
1,409
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I upgraded to OC 0.7.4 on my HackBookPro15,2 (not yet on this HackMini8,1). The upgrade is very easy. For those on OC 0.7.3 using the EFI attached to Post #1, the update should require the following:

Upgrade from OC 0.7.3 to OC 0.7.4
  • OC
    • Update BOOT/BOOTx64.efi, OC/OpenCore.efi, OC/Drivers/OpenRuntime.efi
  • config.plist
    • Add Comment key to UEFI>Drivers>Items
  • Kexts
    • Update AppleALC.kext to 1.6.5
    • Update WhateverGreen.kext to 1.5.4
  • Tools
    • Update Tools

Don't forget to Reset NVRAM after making your EFI changes and before booting macOS with the new changes. Also - it's best to test your EFI changes on a USB stick before you commit the final changes to your production drive.
 
Last edited:
Joined
Sep 22, 2011
Messages
1,409
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
i was running Hackintool on my rig and noticed that my Power settings (pmset -g) were wrong. I'm not sure how/when it happened, but some of these may affect proper sleep/wake. Attached is a script that I run to restore 'proper' settings. Save the file, chmod +x the file and run it. Confirm your settings with Hackintool or pmset -g.

Read more about this here. Note that my script adds 'pmset -a hibernatemode 0'
 

Attachments

  • pmset-fix.zip
    280 bytes · Views: 32
Joined
Sep 22, 2011
Messages
1,409
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@thexsenator I fixed the printer issue that I mentioned here. It turns out that the BS upgrade to 11.6 was a coincidence and not the actual cause. Microsoft update KB5005565 which was pushed on or around 14 September 2021 was the real cause. I was able to add the DWORD below to my printer server registry (Windows Server 2016) and after restarting the printspooler on the server and re-adding the printer on my macOS clients, all printing from Big Sur 11.6 to SMB (Windows share) printers is working again.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\RpcAuthnLevelPrivacyEnabled = 0
 
Last edited:
Joined
Aug 8, 2010
Messages
22
Motherboard
HP Elitedesk 800 G1
CPU
i7-4765T
Graphics
HD4600
Joined
Sep 22, 2011
Messages
1,409
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
The OC 0.7.4 upgrade was so easy, that I took the opportunity to restore the AudioDxe.efi driver that I had dropped in my posted OC 0.7.3 EFI. OC 0.7.4 EFI R001 is now attached to Post #1. I don't like the longer boot time caused by enabling the Audio driver, so I have it disabled in config.plist. To restore boot chime, you will need to enable the Audio Driver and change AudioSupport to true in config.plist.

OC 0.7.4 EFI R001 Changes (from OC 0.7.3 EFI R001)
  • OpenCore
    • Update BOOT/BOOTx64.efi, OC/OpenCore.efi, OC/Drivers/OpenRuntime.efi
  • config.plist
    • Add Comment key to UEFI>Drivers>Items
    • Restore UEFI > Drivers > Item 2 (AudioDxe.efi) which had been dropped in OC 0.7.3 EFI R001. This driver is disabled in config.plist and must be enabled for boot chime. UEFI > Audio > AudioSupport must be changed from false to true to enable boot chime.
  • Kexts
    • Update AppleALC.kext to 1.6.5
    • Update WhateverGreen.kext to 1.5.4
  • Tools
    • Update Tools
  • Drivers
    • Restore AudioDxe.efi which had been dropped in OC 0.7.3 EFI R001. Driver is Disabled in config.plist and must be Enabled for working boot chime. Note that enabling this driver may slow boot time.

Don't forget to Reset NVRAM after making your EFI changes and before booting macOS with the new changes. Also - it's best to test your EFI changes on a USB stick before you commit the final changes to your production drive.
 
Last edited:
Joined
Apr 23, 2013
Messages
72
Motherboard
HP Elitedesk G4
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@thexsenator I fixed the printer issue that I mentioned here. It turns out that the BS upgrade to 11.6 was a coincidence and not the actual cause. Microsoft update KB5005565 which was pushed on or around 14 September 2021 was the real cause. I was able to add the DWORD below to my printer server registry (Windows Server 2016) and after restarting the printspooler on the server and re-adding the printer on my macOS clients, all printing from Big Sur 11.6 to SMB (Windows share) printers is working again.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\RpcAuthnLevelPrivacyEnabled = 0
Thanks for the info @deeveedee, My problem is different than yours. I used bonjour with my Epson AL-M2000DN network printer. This is not working anymore... The printer is discovered but after adding to macos it is only "connecting to printer". Tried everything to fix it, no go. I finally turned bonjour off and switched to HP JetDirect / Socket and is working again.
 
Top