Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Sep 22, 2011
Messages
1,399
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@MattJ2000 The EFI and advice posted in this thread is wrong for the HP EliteDesk G3. I would suggest that you create a new thread for your rig or post in an existing EliteDesk G3 thread. Just search within tonymacx86 and you'll find threads for the G3.

@MattJ2000 If you ping me in your new post (in another thread), I'll help you. I'm busy for the next couple of days, so I may be slow to respond. There are plenty of others who can help, too.
 
Last edited:
Joined
Sep 22, 2011
Messages
1,399
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
The fix for this issue is here. This ended up being a problem caused by a Microsoft update and not by the upgrade to Big Sur 11.6.

It appears that the upgrade to BS 11.6 has broken my ability to print to a Windows shared printer (an old HP LaserJet). I have two hacks (this HackMini and my HackBookPro) that now have this problem. A quick search suggests that other "real" Macs have this same problem. I have tried deleting and re-adding the printer, but no luck. Has anyone seen this problem and if so, have you found a fix for it?
 
Last edited:
Joined
Apr 23, 2013
Messages
70
Motherboard
HP Elitedesk G4
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
It appears that the upgrade to BS 11.6 has broken my ability to print to a Windows shared printer (an old HP LaserJet). I have two hacks (this HackMini and my HackBookPro) that now have this problem. A quick search suggests that other "real" Macs have this same problem. I have tried deleting and re-adding the printer, but no luck. Has anyone seen this problem and if so, have you found a fix for it?
Same here, but I have the same problem under Catalina 10.15.7 too and under BS 11.0.1 also. From windows, zorin os, ubuntu linux the network printing works without a problem. I have an old Epson AL-M2000DN. The funny part is that i can even see the supply levels on my printer, just cannot print :)
Solution for me is that I connected the printer via USB to my synology vm (xpenology) and shared the printer from DSM with airprint, so I can print from macOS.
 

Attachments

  • Screenshot 2021-09-30 at 14.00.27.png
    Screenshot 2021-09-30 at 14.00.27.png
    65 KB · Views: 15
  • Screenshot 2021-09-30 at 14.01.34.png
    Screenshot 2021-09-30 at 14.01.34.png
    65.7 KB · Views: 18
  • Screenshot 2021-09-30 at 14.01.02.png
    Screenshot 2021-09-30 at 14.01.02.png
    112.7 KB · Views: 15
Joined
Sep 22, 2011
Messages
1,399
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
See fix for this issue here.

@thexsenator My old HP LaserJet printer (PCL drivers) is connected to Windows Server 2016 via a parallel port (yeah - it's old). Up until Big Sur 11.6, I printed from macOS via SMB. With Big Sur 11.6, I tried deleting and re-adding the printer (and it re-added without any problems), but print jobs start normally and then "time-out" resulting in "Printer Paused."

I see no indications that the printer shouldn't still work. The behavior is the same on two hacks that I upgraded from BS 11.5.x to 11.6.
 
Last edited:
Joined
Sep 22, 2011
Messages
1,399
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
FYI... I don't see anything in the OC 0.7.4 commits that interests me enough to perform the upgrade from 0.7.3 to 0.7.4. I probably won't be posting an 0.7.4 EFI and I welcome posts from others. Also just a reminder that I won't be creating a Monterey thread for this HackMini. The torch is still waiting to be passed to someone else.
 
Joined
Aug 18, 2021
Messages
12
Motherboard
HP EliteDesk 800 G4 Mini
CPU
i5-8500T
Graphics
UHD 630
Mobile Phone
  1. Android
Just as a general info: I'm running the Monterey betas and everything worked fine last time I checked (not using my hackintosh much though). We'd still need to check installing it fresh since my install is an upgrade from BS.

If I find some time on the weekend I may upgrade the EFI to 0.7.4 and post it.
Prerequisite is that OC 0.7.4 is officially released.
 
Last edited:
Joined
Apr 23, 2013
Messages
70
Motherboard
HP Elitedesk G4
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@thexsenator My old HP LaserJet printer (PCL drivers) is connected to Windows Server 2016 via a parallel port (yeah - it's old). Up until Big Sur 11.6, I printed from macOS via SMB. With Big Sur 11.6, I tried deleting and re-adding the printer (and it re-added without any problems), but print jobs start normally and then "time-out" resulting in "Printer Paused."

I see no indications that the printer shouldn't still work. The behavior is the same on two hacks that I upgraded from BS 11.5.x to 11.6.
Mine is a network printer and was working for years, then it suddenly stopped working under macos. I have zero ideas why it is not working anymore :) My printer is old as hell too :) But as long it is printing i dont care :) :)
 
Joined
Aug 8, 2010
Messages
22
Motherboard
HP Elitedesk 800 G1
CPU
i7-4765T
Graphics
HD4600
Will the EFI work for the 800 G1?
 
Top