Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Aug 18, 2021
Messages
11
Motherboard
HP EliteDesk 800 G4 Mini
CPU
i5-8500T
Graphics
UHD 630
Mobile Phone
  1. Android
I just upgraded from 11.6 to the latest Monterey beta and after a quick look nothing seems to be broken.
The only problem I ran into was the FeatureUnlock kext breaking boot after unlocking FileVault2 on boot.
I didn't investigate it any further and just disabled FeatureUnlock again since I don't use any of the features.
 
Last edited:
Joined
Sep 22, 2011
Messages
1,379
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@Shadowghost The RTC ACPI patch breaks some aspects of FV2. In order to use FV2, I think you would need to eliminate the RTC ACPI patch and use RTCMemoryFixup.kext with a suitable rtcfxexclude range.
 
Joined
Aug 18, 2021
Messages
11
Motherboard
HP EliteDesk 800 G4 Mini
CPU
i5-8500T
Graphics
UHD 630
Mobile Phone
  1. Android
Thanks for the info, I'll take a look if I find some time next week. But currently FV2 works fine just by not using the FeatureUnlock kext :)
 
Joined
Apr 23, 2013
Messages
68
Motherboard
HP Elitedesk G4
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hey, thanks for your advices... Unfortunately none of them solves the problem. Also tried newest nightly IntelMausi.kext, switching WOL on in the bios... No success... Sleep and wake works perfectly, only downside is that after wake all mounted network drives are gone after wake up :( Maxbe a DSDT patch? I noticed that under hackintool PCIe tab that the Intel LAN controller ASPM is disabled. Tried switching ADPM ON witch pci-aspm-default in OC under DeviceProperties, that has no effect either, ASPM stays disabled. Any other ideas what else i could try? :)
 
Joined
Sep 22, 2011
Messages
1,379
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@thexsenator I'm not certain, but I think you might be asking the wrong question (and thus might be attempting to solve the wrong problem). Is it possible that instead of figuring out how to keep Ethernet on during sleep, that you actually need to figure out how to configure macOS to auto-reconnect to a network share after wake? Try searching for 'macos auto reconnect shared drive'
 
Joined
Apr 23, 2013
Messages
68
Motherboard
HP Elitedesk G4
CPU
i5-8500T
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@deeveedee I wasnt certain either, but you are right... Thanks for pointing me in the right direction :)
 
Last edited:
Joined
Jun 14, 2012
Messages
29
Motherboard
HP 800 G4 Mini
CPU
i5-8500
Graphics
UHD 630 ??
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Did you start with clover or did you do straight opencore.

I have downloaded the files from post 1

set up myplist i think correctly however i am running in to an error

Could not read \efi\: invalid parameter
Error: could not find boot options invalid parameter
start images returned invalid parameter
Oc boot failed invalid parameter
OCB start image failed = invalid parameter
 
Joined
Sep 22, 2011
Messages
1,379
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@logyon Always post your current EFI with your requests for help.
 
Joined
Jun 14, 2012
Messages
29
Motherboard
HP 800 G4 Mini
CPU
i5-8500
Graphics
UHD 630 ??
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
So I used gibos to create my os installer, used the Catalina recovery dmg as I didn't access to get the other way you had mentioned. then copied my EFI files to the folder on the pen drive and replacing what was there.

@deeveedee sorted it now it didn't attached properly
 

Attachments

  • EFI.zip
    3.7 MB · Views: 12
Last edited:
Joined
Sep 22, 2011
Messages
1,379
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@logyon If you are certain that you followed the steps listed here (including the BIOS configuration and macOS installation instructions), I don't know why you're experiencing those issues. Carefully read the Known Issues here and here to see if any of the listed solutions helps you.

You may also want to install Windows to make sure that your hardware is good.
 
Top