Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@logyon All of your questions are answered in this thread. Please read, starting with Post #1. Reading this will help you to prove to yourself that you have the persistence and patience to configure and own a hackintosh.
 
Joined
Sep 11, 2021
Messages
3
Motherboard
HP 800 G5 DM
CPU
i7-9700T
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
Hi all, looking for help on getting extended displays on my Hackintosh. I combed through this guide and I didn't see any. I got 2 DP connections and the screens are mirroring. I tried all the possible configs on the first page and they all only mirror. I don't have the arrangement tab and my mirror screen is selected off.

I'm using straight DP cables and both my monitors are a HP Z27n G2's.

I'm currently using the 3xDP.list config wishin my DeviceProperties.

Any suggestions on a fix?

TIA
 

Attachments

  • EFI.zip
    2.3 MB · Views: 38
Last edited:
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@coretek System Preferences > Displays > Arrangement

Post your EFI with your requests for help.
 
Last edited:
Joined
Jun 14, 2012
Messages
60
Motherboard
HP 800 G4 Mini
CPU
i5-8500
Graphics
UHD 630 ??
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi guys mine arrived today.

Sweet little device, upgraded the vga to hdmi, and have 2 display ports,
took out the internal drive and put in a ssd stick. Awaiting on my extra ram to arrive and will get the other wifi card at a later date.

Sweet running machine.

Will compare the hard drive cage mods to my original to see whats been done
 
Joined
Sep 22, 2011
Messages
1,527
Motherboard
HP EliteDesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@coretek You're not using one of the proven EFI's attached to Post #1, so you're using your own or someone else's. Not sure what else to say.

EDIT: If your intention is to create your own solution from scratch (which I do admire, since that's what I did), look at my Catalina thread for hints. Pay close attention to my methodology and my lessons learned (especially boot-args).

EDIT2: As you go back in time in the evolution of this solution, keep revisiting the EFI's attached to Post #1, because I did change my mind about some things that changed in the latest solution.
 
Last edited:
Joined
Sep 11, 2021
Messages
3
Motherboard
HP 800 G5 DM
CPU
i7-9700T
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
@deeveedee - I had some issues with your 0.7.0 and 0.7.1 packages initially. I also did a few EFI's on my own. In the end, it was due to incompatible nvme(silly I know, wasted a week on troubleshooting and created over 8 different USB tests) and wasn't sure which one I actually used to get it going.

I did just switched over to your 0.7.3 just now and I'm still having the same issue.(EFI Attached and screenshot of display settings). 3xDP was used. I have 2xDP(connected) and 1xVGA(not connected)

I'm still missing the arrangement tab.
 

Attachments

  • Screen Shot 2021-09-11 at 9.54.52 PM.png
    Screen Shot 2021-09-11 at 9.54.52 PM.png
    102.7 KB · Views: 40
  • EFI.zip
    3.7 MB · Views: 40
Top