Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Sep 22, 2011
Messages
1,167
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
  • AppleCpuPmCfgLock: NO
  • AppleXcpmCfgLock: YES
Only one of the two is required.
I'm finding conflicting reports on the proper use of these. So far, I haven't found any combination of the two to make any difference in the behavior of my EliteDesk 800 G4 Mini. I do need to enable CLOVER's KernelPm patch in order to boot macOS with CLOVER, so I would expect to require OC's 'Kernel > Quirks > AppleXcpmCfgLock = YES'
to boot macOS with OC, but I don't. No idea why.

I extracted the BIOS options from the powershell tool of my backup 600G5. I am not seeing any cfglock option but it may be called something else.
I'm not sure how to interpret those 'BIOS options' or how we would use them. I downloaded the HP installer for the latest HP EliteDesk 800 G4 Mini BiOS and extracted the BIN firmware component (see attached archive). I can view the .bin with UEFITool, but I don't see 'Setup' in the tool, so I'm unable to find CFG Lock (let alone its offset).

EDIT: A note about the Dortania docs: The Dortania docs are incredibly well written, but not without flaws. I haven't been taking anything from the docs as gospel without trying it myself. For example, in the "converting from CLOVER" section here, the Dortania docs indicate that "Clover will auto-apply this patch [KernelPm] without setting it if the MSR E2 was locked, so you may actually need AppleXcpmCfgLock even if Clover didn't." I never found CLOVER to automatically set KernelPm.
 

Attachments

  • Q21_021401.bin.zip
    12.4 MB · Views: 26
Last edited:
Joined
Nov 16, 2020
Messages
5
Motherboard
Intel Q370
CPU
Intel Core i5-9500
Graphics
UHD
Hi everyone,

first of all thank you @deeveedee for your work! I'm trying to install big sur on a EliteDesk 800G5 (non-mini). I used OC 0.6.3 and replaced the respective files with the ones you uploaded and plugged in my serial number etc. in the config.plist. I am able to get to around 60% of the installer but then the computer reboots before the installation is finished leaving a non-bootable hard drive.

The last lines in the logs are
28:118 00:614 OCI4: Matching override E8ED2C45 with E8ED2C45 - success
28:164 00:045 OCSMC: SmcReadValue Key 4D535463 Size 1
28:192 00:027 OCSMC: SmcReadValue Key 4D534163 Size 2

Anyone has an idea how I can deal with this?

Best regards
 

Attachments

  • opencore-2017-01-02-170403.txt
    256 KB · Views: 7
Joined
Sep 22, 2011
Messages
1,167
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Hi everyone,

first of all thank you @deeveedee for your work! I'm trying to install big sur on a EliteDesk 800G5 (non-mini). I used OC 0.6.3 and replaced the respective files with the ones you uploaded and plugged in my serial number etc. in the config.plist. I am able to get to around 60% of the installer but then the computer reboots before the installation is finished leaving a non-bootable hard drive.

The last lines in the logs are


Anyone has an idea how I can deal with this?

Best regards
It looks like the EliteDesk 800 G5 Small Formfactor has the same Q370 chipset. Assuming your BIOS version and settings match those specified here, we'd need your EFI to help. Please post your EFI after you sanitize your config.plist by removing the MLB, SystemSerialNumber and SystemUUID.

While we're looking at your EFI and since we don't know whether your USB port mapping is the same as the mini, try disabling USBPorts.kext (in your config.plist) and setting Kernel > Quirks > XhciPortLimit = True.
 
Last edited:
Joined
Nov 16, 2020
Messages
5
Motherboard
Intel Q370
CPU
Intel Core i5-9500
Graphics
UHD
It looks like the EliteDesk 800 G5 Small Formfactor has the same Q370 chipset. Assuming your BIOS version and settings match those specified here, we'd need your EFI to help. Please post your EFI after you sanitize your config.plist by removing the MLB, SystemSerialNumber and SystemUUID.

While we're looking at your EFI and since we don't know whether your USB port mapping is the same as the mini, try disabling USBPorts.kext (in your config.plist) and setting Kernel > Quirks > XhciPortLimit = 1.
Thanks for the reply! I configured BIOS as to the settings in the PDF you linked on page 1. I appended my EFI.

I tried disabling USBports.kext under Kernel>Add>Item 1>Enabled and setting Kernel > Quirks > XhciPortLimit = 1, but that resulted in the "ban sign" screen saying "support.apple.com/mac/startup" before I even get to the installer menu.

Edit: Just for clarification, I'm on the 800G5 Desktop (https://support.hp.com/us-en/document/c06403513?jumpid=reg_r1002_usen_c-001_title_r0001), not the SFF.
 

Attachments

  • EFI.zip
    1.9 MB · Views: 15
Last edited:
Joined
Sep 22, 2011
Messages
1,167
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Thanks for the reply! I configured BIOS as to the settings in the PDF you linked on page 1. I appended my EFI.

I tried disabling USBports.kext under Kernel>Add>Item 1>Enabled and setting Kernel > Quirks > XhciPortLimit = 1, but that resulted in the "ban sign" screen saying "support.apple.com/mac/startup" before I even get to the installer menu.
My mistake. When you enable XhciPortLimit, you also need to add USBInjectAll.kext. You'll need to place USBInjectAll.kext in your kexts folder and enable the kext in your config.plist. Read this to learn more about USB port mapping / patching.

After you generate a USBPorts.kext for your system, you'll need to disable (or remove) USBInjectAll.kext from your kexts folder and config.plist (and enable your new USBPorts.kext).

EDIT: @kapiza , after reviewing the system specs, your USB map will definitely be different (your system has more USB ports). Your video may also be different, so if you aren't using DP->DVI adapters (requiring DVI port types in your config.plist Device Properties), you will need to change your Device Properties. Read my Known Issues here for more details.

EDIT 2: @kapiza , If you search for "OpenCore stuck OCSMC: SmcReadValue Key" you'll find others with that issue. I didn't read much, but it looks like some attribute this to improper graphics patching (Device Properties). It is very possible that your PC (which is not an EliteDesk 800 G4/G5 Mini) may require different framebuffer patching. You can experiment with different AAPL,ig-platform-id values as I did here. Read my methodology here. Don't be surprised that your different PC doesn't use the same EFI.
 
Last edited:
Joined
Nov 16, 2020
Messages
5
Motherboard
Intel Q370
CPU
Intel Core i5-9500
Graphics
UHD
My mistake. When you enable XhciPortLimit = 1, you also need to add USBInjectAll.kext. You'll need to place USBInjectAll.kext in your kexts folder and enable the kext in your config.plist. Read this to learn more about USB port mapping / patching.

After you generate a USBPorts.kext for your system, you'll need to disable (or remove) USBInjectAll.kext from your kexts folder and config.plist (and enable your new USBPorts.kext).

EDIT: @kapiza , after reviewing the system specs, your USB map will definitely be different (your system has more USB ports). Your video may also be different, so if you aren't using DP->DVI adapters (requiring DVI port types in your config.plist Device Properties), you will need to change your Device Properties. Read my Known Issues here for more details.
Ok, I'm working with USBInjectAll.kext now. As for now, I'm working with a DP>DVI adapter as you suggested in the catalina guide. When I understand it correctly, the device properties in the EFI you provided are already set for the DP to DVI setup, right?

EDIT: This did not solve the issue. I still get a reboot at about 14 minues left and am stuck at the SMCreadvalue key thing, the number after OCI4: Matching override changed however:
26:292 00:616 OCI4: Matching override 9274DF02 with 9274DF02 - success
26:339 00:046 OCSMC: SmcReadValue Key 4D535463 Size 1
26:365 00:025 OCSMC: SmcReadValue Key 4D534163 Size 2
 

Attachments

  • EFI_v2.zip
    1.9 MB · Views: 20
  • opencore-2017-01-02-235234.txt
    256 KB · Views: 8
Last edited:
Joined
Sep 22, 2011
Messages
1,167
Motherboard
HP EliteDesk 800 G4 Mini
CPU
I7-8700
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Ok, I'm working with USBInjectAll.kext now. As for now, I'm working with a DP>DVI adapter as you suggested in the catalina guide. When I understand it correctly, the device properties in the EFI you provided are already set for the DP to DVI setup, right?
Great! Glad that worked for you. Be sure to create your own USB port mapping, so that you can disable XhciPortLimit.

@kapiza I spoke too soon and didn't see that you edited your previous post. Sorry that didn't work. I haven't patched your model PC and don't know the differences enough to suggest patches. Have you tried to install Catalina first?

Yes, my graphics Device Properties are set for DP->DVI.
 
Last edited:
Joined
Nov 16, 2020
Messages
5
Motherboard
Intel Q370
CPU
Intel Core i5-9500
Graphics
UHD
Great! Glad that worked for you. Be sure to create your own USB port mapping, so that you can disable XhciPortLimit.

Yes, my graphics Device Properties are set for DP->DVI.
But this is to be done after having completed the installation right? Or how am I supposed to use Hackintool on this machine without a working installation? Sorry for the confusion...
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
21,499
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
But this is to be done after having completed the installation right? Or how am I supposed to use Hackintool on this machine without a working installation? Sorry for the confusion...
after you have installed macOS
 
Joined
Jan 7, 2016
Messages
138
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@deeveedee, or anyone in the know, I might need some help here. In my pursuit of getting watch unlock to work, many on the forum have found it to be related to the enabling of the serial port in the BIOS of their motherboard. My 800G5 does not have a physical serial port, however when I boot it with USBinjectAll, I see that it creates a PCI serial adapter under networks: Screen Shot 2020-11-16 at 09.26.05.png

I have no idea to what device this corresponds to.
Looking at the PCIe section of hackingtool, I see this:

Screen Shot 2020-11-16 at 09.26.24.png

And I am suspecting the 1f:05 device to be the culprit. Any idea as to how I could disable it from any sort of patch?
 
Top