Contribute
Register

Big Sur on HP EliteDesk 800 G4/G5 Mini - The Perfect MacMini8,1 Hackintosh - OpenCore

Joined
Sep 22, 2011
Messages
1,344
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
But there is still a problem with macmini. Although the graphics card can speed up normally, after waking up and entering the desktop, some software will enter the posture of feign death. Only by restarting the computer, I want to use the rx560 graphics card. The ideal model is imac19.1
Because the rx560 has only one display output interface, I don't know how to define its output interface.
Ok - I'm willing to continue helping if you're willing to keep trying. Can you post your latest EFI for iMac19,1?
 
Joined
Sep 22, 2011
Messages
1,344
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
@lydahai please create a new thread for your EliteDesk 800 G5 / RX560. State your problem in the first post of the thread and reference this thread for history.

You may be on to something about specifying the port. See this post. I never figured out how to implement the suggested fix in OpenCore and can only make the patch work in CLOVER.
 
Joined
May 2, 2019
Messages
29
Motherboard
intel z370
CPU
intel I7 9700
Graphics
adm rx560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 128K
Mobile Phone
  1. iOS
Ok - I'm willing to continue helping if you're willing to keep trying. Can you post your latest EFI for iMac19,1?
@lydahai please create a new thread for your EliteDesk 800 G5 / RX560. State your problem in the first post of the thread and reference this thread for history.

You may be on to something about specifying the port. See this post. I never figured out how to implement the suggested fix in OpenCore and can only make the patch work in CLOVER.
I have removed all the parameters related to the startup of the graphics card, which is still the same as before. I will send my EFI to you for a look and study together.
 

Attachments

  • imac19.1 rx560 G5.zip
    9.1 MB · Views: 15
Joined
Sep 22, 2011
Messages
1,344
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
I have removed all the parameters related to the startup of the graphics card, which is still the same as before. I will send my EFI to you for a look and study together.
Please create a new thread (a topic separate from this HP EliteDesk 800 G4/G5 Mini thread) for your G5/RX560. Post the link to your new thread in this thread and I will respond there. Thank you.
 
Joined
May 2, 2019
Messages
29
Motherboard
intel z370
CPU
intel I7 9700
Graphics
adm rx560
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 128K
Mobile Phone
  1. iOS
Please create a new thread (a topic separate from this HP EliteDesk 800 G4/G5 Mini thread) for your G5/RX560. Post the link to your new thread in this thread and I will respond there. Thank you.
For new discussions, please click:
 
Joined
Jan 7, 2016
Messages
159
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Updating to 11.1... underway. Expect it to take some time.
 
Joined
Sep 22, 2011
Messages
1,344
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
Updating to 11.1... underway. Expect it to take some time.
Are you seeing any RTC issues when the installer reboots (as I did here)? If so, I think we need RTCMemoryFixup.kext / custom rtcfx-exclude.
 
Joined
Jan 7, 2016
Messages
159
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Nope, did not see any RTC issues. Went as smooth as butter maybe with the exception of the confusion when picking the right partition for OC to boot from during the installation as it is no longer labeled the same way as it used to with the "update" or upgrade in the name.
 
Joined
Jan 7, 2016
Messages
159
Motherboard
HP Elitedesk 800 G5 Mini
CPU
i9-9900
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
One strange thing I noticed after the update. It seems like at each boot, macos 11.1 wants to reset the <SystemAudioVolumeDB> value in the nvram to 0 which essentially disables the OC boot chime. I have no idea why.
In case you did not know 0.6.4 enabled control of the boot chime from the macos settings audio option like a real mac using the nvram entry <StartupMute>. That part works but now I don't know what part of the update is resetting the volume value to 00.

I am editing my config.plist to lock this value...
 
Joined
Sep 22, 2011
Messages
1,344
Motherboard
HP EliteDesk 800 G5 Mini
CPU
I9-9900
Graphics
UHD 630
Mac
  1. Mac mini
Mobile Phone
  1. iOS
One strange thing I noticed after the update. It seems like at each boot, macos 11.1 wants to reset the <SystemAudioVolumeDB> value in the nvram to 0 which essentially disables the OC boot chime. I have no idea why.
In case you did not know 0.6.4 enabled control of the boot chime from the macos settings audio option like a real mac using the nvram entry <StartupMute>. That part works but now I don't know what part of the update is resetting the volume value to 00.

I am editing my config.plist to lock this value...
Is this related?
 
Top