Contribute
Register

Big sur - Intel Black screen with internal graphics Intel UHD 630 but boot with GPU

Joined
Feb 5, 2014
Messages
3
Motherboard
MPG Z490 GAMING CARBON WIFI
CPU
i9 10850K
Graphics
GTX 1050 Ti / UHD 630
Mac
  1. MacBook Air
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Hi,

I installed Mac os Big Sur 11.2.2 on my Hackintosh, I use Open Core 0.6.7, I follow the amazing install guide from OpenCore. Succees for me with my config :

Processor :Intel Core i9 10850K 3.60 GHz

Motherboard :MPG Z490 GAMING CARBON WIFI (MS-7C73) 1.0

ChipsetPont nord : Intel Comet LakePont sud : Intel Z490

Memory : 32 Go

Graphics Card :NVIDIA GeForce GTX 1050 Ti

But as you can see I have a GPU who doens't work with Big Sur, in the futur I will buy a last AMD graphics card like AMD RX 6XXX xt who should work with Big Sur and futher versions.

In the meantime I would like to use the Internal Graphics of the processor. But I only managed to boot with my external GPU (see screenshot) :

Boot with GPU but only 8Mo graphics


So on Windows I will use the PEG card and on Macos the IGD.

But I have a black screen when I try to boot with option IGD (with HDMI port on the motherboard)

bios.PNG


My USB with OpenCore :

Capture d’écran 2021-03-13 à 20.40.56.png


Boot args : alcid=1 igfxrpsc=1 igfxonln=1

My config.plist in attachement :)


I thinks I miss something in config.plist or some kexts, have you a idea?

Thanks
 

Attachments

  • config.plist
    29.5 KB · Views: 28
Last edited:
Joined
Feb 5, 2014
Messages
3
Motherboard
MPG Z490 GAMING CARBON WIFI
CPU
i9 10850K
Graphics
GTX 1050 Ti / UHD 630
Mac
  1. MacBook Air
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Hi,

any ideas for that ??
 
Joined
Aug 13, 2020
Messages
1
Motherboard
Asus TUF Z490-h Gaming
CPU
i7-10700
Graphics
RTX 3070 + UHD 630
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi, did you manage to solve the issue? I own a similar configuration and can't get the UHD 630 Gpu to work
i tried different frame buffers and googled for a gazillion years and found multiple cases of people failing to succeed with UHD 630 on Big Sur.
 
Joined
Jun 9, 2020
Messages
1
Motherboard
Asus h81m-k
CPU
i5
Graphics
1070 gtx
You have to boot into dvi and then do the mapping of the video outputs
 
Top