Contribute
Register

Big Sur freezes within 30min of booting since 11.3.1 (and in 11.4)

Joined
Oct 12, 2019
Messages
24
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900k
Graphics
RX580
Can't seen to find a thread that would talk about this - I had a fairly stable system with USBInject+UIAC combo for many months, but after upgrading 11.3.1 I can't sort out USB and power issues.

I'm still running the rig described in my profile, with recent addition of the Inateck KT4004 card.
I have a BCM94360CS2 card that worked just fine in the past few months.

Overall, the issues I had (and reasons I got KT4004) were random rare USB drops - USB ports (Bluetooth from CS2 card too) will go dead and I would have to connect remotely to reboot the PC.

Since upgrading to 11.3.1 (and updating OC to 0.6.9) the problems got much worse and far more frequent.

Symptoms I see on 11.4 macOS running on Aorus Pro Z390:
- every 1 of 3 reboots (cold or hot) the boot hangs around USB initialisation
- when booted, WiFi via CS2 card will disappear within 2-5 minutes - device is lost, and only connectivity remains via on-board LAN. This coincides with devices on the Inateck KT4004 card disappearing as well.
- after about 30min the whole system would freeze - no pings, no screen updates. Only power off would help (reset button wouldn't work).

Things I tried:
- reflashed BIOS
- reset NVRAM (nvram -c)
- booted with USBInjectAll with and without UIAC - still freezes but quicker than 30min
- booted into Catalina from backup drive and everything works fine there with USBInjectAll (but it doesn't use UIAC)
- got DummyPowerManagement=true in OC config

Does this sound like a USB mapping issue?
And if yes, how would I proceed sorting it? I have ports mapped and the total number is under 15.

I don't know how to map ports on the KT4004 card so for now they're not showing on the Hackintool output (and I don't think this counts towards 15 limit anyway cause it's a separate controller).

Thanks for all the help and advice!
 

Attachments

  • 2021-06-03 21-27-32 screenshot.png
    2021-06-03 21-27-32 screenshot.png
    103 KB · Views: 23

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,756
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT 1030
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. Android
Can't seen to find a thread that would talk about this - I had a fairly stable system with USBInject+UIAC combo for many months, but after upgrading 11.3.1 I can't sort out USB and power issues.

I'm still running the rig described in my profile, with recent addition of the Inateck KT4004 card.
I have a BCM94360CS2 card that worked just fine in the past few months.

Overall, the issues I had (and reasons I got KT4004) were random rare USB drops - USB ports (Bluetooth from CS2 card too) will go dead and I would have to connect remotely to reboot the PC.

Since upgrading to 11.3.1 (and updating OC to 0.6.9) the problems got much worse and far more frequent.

Symptoms I see on 11.4 macOS running on Aorus Pro Z390:
- every 1 of 3 reboots (cold or hot) the boot hangs around USB initialisation
- when booted, WiFi via CS2 card will disappear within 2-5 minutes - device is lost, and only connectivity remains via on-board LAN. This coincides with devices on the Inateck KT4004 card disappearing as well.
- after about 30min the whole system would freeze - no pings, no screen updates. Only power off would help (reset button wouldn't work).

Things I tried:
- reflashed BIOS
- reset NVRAM (nvram -c)
- booted with USBInjectAll with and without UIAC - still freezes but quicker than 30min
- booted into Catalina from backup drive and everything works fine there with USBInjectAll (but it doesn't use UIAC)
- got DummyPowerManagement=true in OC config

Does this sound like a USB mapping issue?
And if yes, how would I proceed sorting it? I have ports mapped and the total number is under 15.

I don't know how to map ports on the KT4004 card so for now they're not showing on the Hackintool output (and I don't think this counts towards 15 limit anyway cause it's a separate controller).

Thanks for all the help and advice!

Hi there.

Since you have already done all the USB port mapping work, why not export Hackintool's USBPorts.kext (it is exported along with the SSDT's) and use that instead of USBInjectAll.kext and your UIAC.aml? Remember to declare it properly in OC's config.plist, and disable the other two.

Try it, test it and see if there is any difference. :thumbup:

P.S - no need to try and configure the add-on card.
 
Joined
Oct 12, 2019
Messages
24
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900k
Graphics
RX580
Thank you for noticing my thread so quickly! I actually am using just the USBPorts.kext (with other two disabled).

So I have the following enabled:

SSDTs:
- SSDT-PLUG.aml (from Dortania website)
- SSDT-USBX.aml (from previous build)
- SSDT-AWAC.aml (from Dortania website)

Kexts:
- Lilu.kext
- VirtualSMC.kext
- WhateverGreen.kext
- AppleALC.kext
- IntelMausi.kext
- USBPorts.kext

Settings:
- DummyPowerManagement=true
- XhciPortLimit=false

Last change made was to move KT4004 from mini-PCI to the full-size PCI slot - but I didn't reset NVRAM and system did the usual: wifi gone within minutes, completely frozen within half-an-hour.

PC was shut down for the night, I powered it up now to collect the above info and now wifi is still active even after 10min. USB ports on the KT4004 also keep working.
 
Joined
Oct 12, 2019
Messages
24
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900k
Graphics
RX580
Really weird, system's been stable for 12h+ now - it's as if some setting or memory flushed and now all is back to normal, with the same configs and same USB layout.
 
Joined
Mar 3, 2014
Messages
1,148
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
SSDTs:
- SSDT-PLUG.aml (from Dortania website)
- SSDT-USBX.aml (from previous build)
- SSDT-AWAC.aml (from Dortania website)
Looks like SSDT-UIAC.aml from Hackintool is missing. IIRC you need that as well as USBPorts.kext to properly configure your USB ports. But maybe your SSDT-USBX.aml is doubling for the Hackintool-generated port configuration. (That's a "crossover" I would not try.)
 
Joined
Oct 12, 2019
Messages
24
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900k
Graphics
RX580
Thanks!
I’ll double check, thought SSDT-UIAC is only needed as mapping for the USBInjectAll.
 
Joined
Mar 3, 2014
Messages
1,148
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
I’ll double check, thought SSDT-UIAC is only needed as mapping for the USBInjectAll.
Other way around. USBInjectAll is supposed to enable all USB ports so that you can see which ones you want to keep. It should not be left activated, since if you have more than 15 USB ports active, the array (memory space) allocated by Apple for USB is exceeded and may cause problems. If you use Hackintool, you should already know which ports you want to keep, and after you delete the others in Hackintool, and export the result, the app will drop "SSDT-UIAC.aml" and "USBPorts.kext" on your desktop, configured for your desired USB port configuration. At least it did that for my computer (at left).
 
Joined
Oct 12, 2019
Messages
24
Motherboard
Gigabyte Z390 AORUS PRO
CPU
i9-9900k
Graphics
RX580
Yes, but I think USBPorts.kext is one way of mapping (the one I'm using right now), and SSDT-UIAC is a different way of getting the same result.

So it's USBPorts.kext OR SSDT-UIAC+USBInjectAll.kext, both approaches resulting in the same ports configuration that was created in Hackintool.
 
Joined
Mar 3, 2014
Messages
1,148
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Air
Classic Mac
  1. Power Mac
Been years since I used USBInjectAll.kext under the direction of RehabMan. Now I have the mapping records (by that I mean the relationship between USB logical and physical ports) of all my computers and as a result I don't need it again. Perhaps the kext or the MacOS has changed and now USBInjectAll.kext is not a threat if you keep it. Hey, whatever works for you!
 
Top