Contribute
Register

Big Sur 11.3 Update Broke USB 3

JBX

Joined
Sep 17, 2016
Messages
129
Motherboard
Gigabyte Z490
CPU
i7-10700
Graphics
RX 580
bigsur113update.png


Update but stuck at iCloud sign in screen due to loss of USB 3.x ports (mouse and keyboard). Forced restarted and still no mouse or keyboard. Checked other ports and found usb 2.0 ports working which were off in my OpenCore port mapping kext. Replaced with USBInjectAll but still same issue only 2.0 ports working. My backup 11.2.3 (before I updated today) works fine. I use latest OpenCore with iMac20,1 SMBIOS

Something has changed.:problem:

update: I tested with latest Hackintool and thumb drive plugging into any 3.x port dose not show up.
 
Last edited:
Joined
Jul 12, 2017
Messages
45
Motherboard
Gigabyte GA-H170N-WIFI
CPU
i3-6100
Graphics
RX 560
Mac
  1. MacBook
  2. Mac mini
Classic Mac
  1. Classic
  2. iMac
  3. Performa
  4. Power Mac
  5. PowerBook
  6. SE
  7. SE/30
Mobile Phone
  1. iOS
Update but stuck at iCloud sign in screen due to loss of USB 3.x ports (mouse and keyboard). Forced restarted and still no mouse or keyboard. Checked other ports and found usb 2.0 ports working which were off in my OpenCore port mapping kext. Replaced with USBInjectAll but still same issue only 2.0 ports working. My backup 11.2.3 (before I updated today) works fine. I use latest OpenCore with iMac20,1 SMBIOS

Something has changed.:problem:

I've also lost the USB 3 ports after the update. USB 2 works. Using iMac17,1 SMBIOS.
 

JBX

Joined
Sep 17, 2016
Messages
129
Motherboard
Gigabyte Z490
CPU
i7-10700
Graphics
RX 580
blindowl, thanks for confirming... I tried latest hackintool and tested ports with thumb drive but no recognition.
 
Joined
Dec 31, 2013
Messages
797
Motherboard
Huawei Matebook D
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. iOS
Me too. USB 3.0 are gone. This ASRock B365M-ITX/ac motherboard doesn't have any USB 2.0 to be able to run a mouse or keyboard.
 
  • Like
Reactions: JBX
Joined
Mar 30, 2021
Messages
16
Motherboard
Asus TUF Z490-PLUS GAMING (WI-FI)
CPU
i5-10600K
Graphics
Radeon RX 580 8 Gb
Same situation here with Asus Z490 Tuf Gaming Plus Wifi, no more USB, but ok with my clone made just before the update... looking for a solution...
 
Joined
Jul 30, 2015
Messages
13
Motherboard
Gigabyte Z170XP-SLI
CPU
i7-7700k
Graphics
EVGA GT 1030
Mobile Phone
  1. Android

It came out a while ago but addresses the usb ports issue with 11.3. This issue has kinda been known for a while it just took that long for 11.3 to be released.
 

JBX

Joined
Sep 17, 2016
Messages
129
Motherboard
Gigabyte Z490
CPU
i7-10700
Graphics
RX 580
david279, Thank you. Setting XhciPortLimit to false in OC config file worked. However now even the excluded ports in my mapping kext work.
 
Last edited:
Joined
Feb 24, 2013
Messages
36
Motherboard
Gigabyte H370-HD3
CPU
i5-8400
Graphics
570
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
My front panel USB ports (x2) both are dead. However most of all the ports (USB3) on the back are working, plus one USB2 working, one USB2 dead. Even though I changed XhciPortLimit to false in config.plist, it still won't change anything.
 

NorthAmTransAm

Moderator
Joined
Jul 26, 2018
Messages
1,721
Motherboard
MSI Pro Z690-A DDR4
CPU
i7-12700k
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
If you can go back to older OS and create a USBMap then you might be ok. It seems USBInjectall needs an update otherwise.
 
Top