Contribute
Register

Before You Install Audio - Desktop/Realtek/AppleHDA [Guide]

Status
Not open for further replies.
Joined
Dec 19, 2014
Messages
76
Motherboard
ASUS Prime Z390-A
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
ok im trying to get my Realtek® ALC892 followed guides advice an nothing used layout 1, 2, 3, 5, 7,11, 28, 31, 92, 99,9 installed AppleALC.kext also Lilu.kext
 
Joined
Dec 19, 2014
Messages
76
Motherboard
ASUS Prime Z390-A
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
The thread supports layout-id 1, 2 or 3 only. For your motherboard, set to 1.
See Post #1/Problem Reporting
none of those work an i attached my config
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,928
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Dec 19, 2014
Messages
76
Motherboard
ASUS Prime Z390-A
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. iMac
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Useless; ignored the instructions, try again:
Post #1/Problem Reporting says
thanks but i think i just might stick with voodoo seems to much for my to understand as i am not veryy good at all this seems to have things been working by luck untill i came to change over to lilu an applealc crap is just frustrating me also multibeast always fails with triangle⚠️
 
Joined
Sep 22, 2016
Messages
464
Motherboard
Gigabyte Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
ok im trying to get my Realtek® ALC892 followed guides advice an nothing used layout 1, 2, 3, 5, 7,11, 28, 31, 92, 99,9 installed AppleALC.kext also Lilu.kext

After upgrading to 10.13.2 I was unable to use AppleAlC. So I used audio_cloverALC.command and voila, I have working audio.

I'm going to try to replace kext generated by audio_cloverALC.command with AppleALC kext now to see, to I get audio now.

AppleALC supported codecs and layout ID's https://github.com/vit9696/AppleALC/wiki/Supported-codecs
 
Joined
Sep 22, 2016
Messages
464
Motherboard
Gigabyte Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
An option how to get better audio on ALC1150.

1. Set Audio ID 2 on Clover config.
2. Run audio_cloverALC.command to install audio
3. Reboot and check that you have audio
4. remove realtekALC.kext, which was generated by audio_cloverALC.command
5. Add into /Volumes/EFI/EFI/CLOVER/kexts/Other/ the latest
AppleALC.kext
Lilu.kext
CodecCommander.kext​
6. Modify CodecCommander.kext/Contents/Info.plist IOKitPersonalities/Codec Profile/Realtek ALC1150
Send Delay = 300
Sleep Nodes = false
Update Nodes = true​

If I use realtekALC.kext, I have weird annoing cracks each time before audio strarts to play. By using AppleALC.kext there is no anymore cracks. CodecCommander.kext modifications are needed to have audio after sleep.

To get AppleALC.kext to work I have to run audio_cloverALC.command first.
 
Joined
Sep 22, 2016
Messages
464
Motherboard
Gigabyte Z170X-UD5 TH-Clover
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. Mac mini
Mobile Phone
  1. iOS
The codec specific files are the same with both methods for Audio ID 1, 2 and 3.

The only caveat with audio_cloverALC.command is that I get this annoying cracks before audio starts to play. But with AppleALC I don't have those. But I have to apply audio_cloverALC.command before to get AppleALC to work, no audio otherwise. I haven't got time to deep examine why so.
 
Joined
Jun 28, 2013
Messages
115
Motherboard
ASUS ROG STRIX Z370-H GAMING
CPU
i3-8350K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. Mac Pro
Mobile Phone
  1. iOS
multibeast always fails with triangle⚠️

I had the same problem with MultiBeast until I realized that I had the EFI partition mounted. Make certain to unmount EFI, then run MultiBeast.
 
Status
Not open for further replies.
Top