Contribute
Register

Before You Install Audio - Desktop/Realtek/AppleHDA [Guide]

Status
Not open for further replies.
Joined
Jun 18, 2017
Messages
18
Motherboard
Asus Z-170 Sabertooth
CPU
Intel i5-6600k
Graphics
GTX 970
Mobile Phone
iOS
Post #1/IOReg/link

Realtek Codec
(detected by cloverALC, realtekALC, pikeraokhaALC, and AppleALC, skip)
  1. Supported: 885, 887, 888, 889, 892, 898, 1150, 1220
  2. IOReg/Search: CodecDevice (note IOHDACodecVendorID)
    1. Realtek: 0x10ec
    2. Codec/Device ID: 0900 (ALC1150)
    3. If no 0x10de, not supported; full stop
  3. Verify: Realtek ALC AppleHDA/Post #1/Requirements/2. Realtek ALC
Little confused on step 2 substep 3, does 0x10de have to be present somewhere? all i see is this do i meet the requirement?
 

Attachments

toleda

Moderator
Joined
May 20, 2010
Messages
24,366
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Little confused on step 2 substep 3
My mistake, Post #1 edited.
The correct Vendor ID is 10ec, Realtek.
You have a Realtek codec, proceed.
 
Joined
Aug 7, 2017
Messages
126
Motherboard
GA-Z270N - WIFI
CPU
i3-7320
MultiBeast
Before You Install Audio: MultiBeast/Desktop/Realtek

All macOS versions, 10.11 and newer
  1. Remove previous installed methods (skip, if clean install)
    1. Realtek ALC AppleHDA/Post #1/Uninstall Realtek ALC AppleHDA
  2. Native AppleHDA required (skip, if clean install)
    1. Restore native AppleHDA [Guide].pdf
  3. Disable SIP (10.11 and newer, if enabled)
    1. Clover: config.plist/RtVariables/CsrActiveConfig/0x3 or 0x67
    2. Restart
  4. Mount EFI partition (Clover only)
    1. Community Software/EFI Mounter v3
  5. IOReg/HDEF
    1. Supported: HDEF
    2. IOReg/Search: HDEF (if HDEF present, proceed to 6. Realtek Codec)
      1. Screenshot - IOReg/Search: HDEF (HDEF@1B or HDEF@1F,3 valid):View attachment 251592
    3. IOReg/Search: HDAS
      1. if HDAS present, install one HDAS > HDEF method (A or B, below)
      2. Restart
      3. Return to 4. Mount EFI partition
    4. If no HDEF, installing MultiBeast audio will fail
      1. See Problem Reporting, Post #1; full stop
  6. Realtek Codec
    1. Supported/Codec Name (Device ID):
      • 885/889a (0885)
      • 887/888b (0887)
      • 888/888s (0888)
      • 889 (0889)
      • 892 (0892)
      • 898 (0899)
      • 1150 (0900)
      • 1220 (1220)
      • 1220A (1168)
    2. IOReg/Search: CodecDevice (note IOHDACodecVendorID)
      1. Realtek: 0x10ec
        • If no 0x10ec, not supported; full stop
      2. Codec/Device ID: 0900 (ALC1150)
        • If codec not in list above, not supported; full stop
      3. Determine Codec Name from Codec Device ID
      4. Screenshot - IOReg/Search: CodecDevice: View attachment 251594
  7. Ready to install MultiBeast audio
Install MultiBeast Audio (previous selections are not preserved)
  1. MultiBeast > Drivers > Audio > RealtekALCxxx
    1. √ ALC Codec Name
    2. √ 100 Series Audio (if 100/200 Series motherboard)
    3. Options (Audio ID: 1, 2 or 3)
      1. None (Audio ID: 1)
        • Inputs: Pink (motherboard/mb and front panel/fp), Blue (mb)
        • Outputs: Green (mb and fp), Orange (mb), Black (mb), Optical
      2. √ Optional 3 Port (5.1) Audio (Audio ID: 2)
        • Inputs: Pink (fp)
        • Outputs: Green (mb and fp), Orange (Pink/mb), Black (Blue/mb), Optical
      3. √ Optional HD3000/HD4000 HDMI Audio (Audio ID: 3)
        • Inputs: Pink (mb and fp), Blue (mb)
        • Outputs: Green (mb and fp), Black (mb), Optical
    4. Screenshot/MultiBeast > Drivers > Audio: View attachment 251595
  2. Build
  3. Install
  4. Restart
How do I get to the IOREG screen to check for HDEF in step 5?
 
Joined
Aug 7, 2017
Messages
126
Motherboard
GA-Z270N - WIFI
CPU
i3-7320
Realtek Codec (detected by cloverALC, realtekALC, pikeraokhaALC, and AppleALC, skip)
  1. Supported: 885, 887, 888, 889, 892, 898, 1150, 1220
  2. IOReg/Search: CodecDevice (note IOHDACodecVendorID)
    1. Realtek: 0x10ec
    2. Codec/Device ID: 0900 (ALC1150)
    3. If no 0x10de, not supported; full stop
  3. Verify: Realtek ALC AppleHDA/Post #1/Requirements/2. Realtek ALC
Little confused on step 2 substep 3, does 0x10de have to be present somewhere? all i see is this do i meet the requirement?
How do I get to the page in your photo?
 
Joined
Aug 7, 2017
Messages
126
Motherboard
GA-Z270N - WIFI
CPU
i3-7320
MultiBeast
Before You Install Audio: MultiBeast/Desktop/Realtek

All macOS versions, 10.11 and newer
  1. Remove previous installed methods (skip, if clean install)
    1. Realtek ALC AppleHDA/Post #1/Uninstall Realtek ALC AppleHDA
  2. Native AppleHDA required (skip, if clean install)
    1. Restore native AppleHDA [Guide].pdf
  3. Disable SIP (10.11 and newer, if enabled)
    1. Clover: config.plist/RtVariables/CsrActiveConfig/0x3 or 0x67
    2. Restart
  4. Mount EFI partition (Clover only)
    1. Community Software/EFI Mounter v3
  5. IOReg/HDEF
    1. Supported: HDEF
    2. IOReg/Search: HDEF (if HDEF present, proceed to 6. Realtek Codec)
      1. Screenshot - IOReg/Search: HDEF (HDEF@1B or HDEF@1F,3 valid):View attachment 251592
    3. IOReg/Search: HDAS
      1. if HDAS present, install one HDAS > HDEF method (A or B, below)
      2. Restart
      3. Return to 4. Mount EFI partition
    4. If no HDEF, installing MultiBeast audio will fail
      1. See Problem Reporting, Post #1; full stop
  6. Realtek Codec
    1. Supported/Codec Name (Device ID):
      • 885/889a (0885)
      • 887/888b (0887)
      • 888/888s (0888)
      • 889 (0889)
      • 892 (0892)
      • 898 (0899)
      • 1150 (0900)
      • 1220 (1220)
      • 1220A (1168)
    2. IOReg/Search: CodecDevice (note IOHDACodecVendorID)
      1. Realtek: 0x10ec
        • If no 0x10ec, not supported; full stop
      2. Codec/Device ID: 0900 (ALC1150)
        • If codec not in list above, not supported; full stop
      3. Determine Codec Name from Codec Device ID
      4. Screenshot - IOReg/Search: CodecDevice: View attachment 251594
  7. Ready to install MultiBeast audio
Install MultiBeast Audio (previous selections are not preserved)
  1. MultiBeast > Drivers > Audio > RealtekALCxxx
    1. √ ALC Codec Name
    2. √ 100 Series Audio (if 100/200 Series motherboard)
    3. Options (Audio ID: 1, 2 or 3)
      1. None (Audio ID: 1)
        • Inputs: Pink (motherboard/mb and front panel/fp), Blue (mb)
        • Outputs: Green (mb and fp), Orange (mb), Black (mb), Optical
      2. √ Optional 3 Port (5.1) Audio (Audio ID: 2)
        • Inputs: Pink (fp)
        • Outputs: Green (mb and fp), Orange (Pink/mb), Black (Blue/mb), Optical
      3. √ Optional HD3000/HD4000 HDMI Audio (Audio ID: 3)
        • Inputs: Pink (mb and fp), Blue (mb)
        • Outputs: Green (mb and fp), Black (mb), Optical
    4. Screenshot/MultiBeast > Drivers > Audio: View attachment 251595
  2. Build
  3. Install
  4. Restart
How do I uninstall previous methods?
 
Joined
Oct 30, 2011
Messages
90
Motherboard
Lenovo x250
CPU
i5-5300U
Graphics
HD 5500, 1366x768
Mobile Phone
iOS
Good day,

I have this codec Device: 0x10ec0292
Do you confirm I can't use this guide in my case ?
 
Status
Not open for further replies.
Top