Contribute
Register

BCM94360CS2 - Catalina- Wifi and Bluetooth working but no Handoff and no Apple watch unlock

Joined
May 2, 2019
Messages
2
Motherboard
Asrock B85M Pro
CPU
Intel i5-4670k
Graphics
GeForce GT 730
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi everybody,
Just bought and installed in my hackintosh BCM94360CS2 card. Just booted and wifi and bluetooth worked oob. I can connect logitech bluetooth trackpad without any issue and connect to my home wifi. Also airdrop from my iphone works like a charm. The problem is that i cannot manage to get handoff and apple watch unlock feature working in any way.
Even if working oob I tryed using several kext without anyluck:

AirportBrcmFixup.kext
BrcmBluetoothInjector.kext
BrcmFirmwareData.kext
BrcmPatchRAM3.kext
BT4LEContinuityFixup.kext

Don't know why it is not working cause even in System report I see all features available (Handroff supported: Yes, Auto Unlock: Yes)
Thanks for your hep!
 
Joined
May 2, 2019
Messages
2
Motherboard
Asrock B85M Pro
CPU
Intel i5-4670k
Graphics
GeForce GT 730
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Finally got it working. I'm on Catalina 10.15.4
Solution was easier than i thought

For handoff:
Sign out from iCloud then sign back in

For unlock with apple watch:
I could enable the flag in "System Preferences" -> "Security and Privacy" -> "Use your Apple watch to unlock apps and your Mac" without any issue but it didn't work since i disabled the flag "wake for network access" in "System Preferences" -> "Energy saver"
 
Joined
Mar 11, 2017
Messages
10
Motherboard
Gigabyte Z170 HD3P
CPU
i5-6600
Graphics
RX 480
Mac
  1. iMac
Mobile Phone
  1. iOS
Finally got it working. I'm on Catalina 10.15.4
Solution was easier than i thought

For handoff:
Sign out from iCloud then sign back in

For unlock with apple watch:
I could enable the flag in "System Preferences" -> "Security and Privacy" -> "Use your Apple watch to unlock apps and your Mac" without any issue but it didn't work since i disabled the flag "wake for network access" in "System Preferences" -> "Energy saver"

Hi,
I am using FENVI FV-T919 PCI wifi/bt card in my hackintosh..handoff running still fine but unlock hac with my Applewatch run only one cycle..More interested situations is when I connected my Airpods pro lagging And loosing signal but my wifi/BT 4 antennas is in the case and I sitting in 1 meter in front of pc case.
Next interesting when I Use On hac iphone scan documents or photos. Not working!
Please say me any fix them .
Thanks for your
 
Joined
Sep 22, 2010
Messages
165
Motherboard
ASUS PRIME Z390-A
CPU
i7-9700K
Graphics
Vega 64
curious if anyone's made more progress on this. just got my AW 6 with iOS 14 and upgraded Catalina to 10.15.7 19H2 but still can't get the unlock working. handoff working fine. also using a FV-T919.
 
Joined
Mar 4, 2014
Messages
440
Motherboard
Gigabyte Z390 M Gaming
CPU
i5 9400F
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
curious if anyone's made more progress on this. just got my AW 6 with iOS 14 and upgraded Catalina to 10.15.7 19H2 but still can't get the unlock working. handoff working fine. also using a FV-T919.
I have played with this for hours/days/weeks! I have mine working perfectly now.

Before you do anything, you need to disable serial port in your BIOS settings, you will have problems if this is enabled. You may need to update to a beta BIOS if your BIOS does not have this option under IO Devices. See here for latest beta BIOS, flash at your own risk - https://www.tweaktownforum.com/foru...dors/gigabyte/28656-gigabyte-latest-beta-bios

Firstly I would unpair your watch, then sign out of icloud on your phone and your hack. Then follow the instructions here: https://discussions.apple.com/thread/251803595

One additional step after the procedure above. Turn bluetooth off on your hack, delete library/preferences/com.apple.Bluetooth.plist

Reboot your hack, phone, watch. Log in to iCloud on your hack, then your phone. Set up watch as a new watch. Go to system preferences/security & Privacy and tick the box for watch unlock. If you get error, tick again and it should work the second time
 
Joined
Sep 22, 2010
Messages
165
Motherboard
ASUS PRIME Z390-A
CPU
i7-9700K
Graphics
Vega 64
wow, just tried step 1 first - disabled serial port, all working! thank you @Humanate !
 
Top