Contribute
Register

BCM943602CS Combo Card For Hackintosh

Status
Not open for further replies.
Joined
Aug 9, 2017
Messages
11
Motherboard
P8Z68V-PRO
CPU
Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Graphics
NVIDIA GeForce GTX 960
I just received my board today and I did installed with no problems the it got recognized OOB no problem.
this is what says for the WIFI on the system info

Software Versions:
CoreWLAN: 13.0 (1339)
CoreWLANKit: 13.0 (1339)
Menu Extra: 13.0 (1345)
System Information: 12.0 (1300.1)
IO80211 Family: 12.0 (1200.12.2)
Diagnostics: 1.0 (805)
AirPort Utility: 6.3.8 (638.5)
Interfaces:
en5:
Card Type: AirPort Extreme (0x14E4, 0x133)
Firmware Version: Broadcom BCM43xx 1.0 (7.77.37.5.1a3)
MAC Address: ac:bc:32:84:f4:8b
Locale: FCC
Country Code: X0
Supported PHY Modes: 802.11 a/b/g/n/ac
Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 144, 149, 153, 157, 161, 165
Wake On Wireless: Supported
AirDrop: Supported
AirDrop Channel: 0
Auto Unlock: Supported
Status: Connected

and this is what it says for the bluetooth

Address: ac-bc-32-84-f4-8c
Bluetooth Low Energy Supported: Yes
Handoff Supported: Yes
Instant Hot Spot Supported: Yes
Manufacturer: Broadcom
Transport: USB
Chipset: 20703A1
Firmware Version: v153 c4801
Bluetooth Power: On
Discoverable: Off
Connectable: Yes
Auto Seek Pointing: On
Remote wake: On
Vendor ID: 0x05AC
Product ID: 0x8290
HCI Version: 4.2 (0x8)
HCI Revision: 0x12C1
LMP Version: 4.2 (0x8)
LMP Subversion: 0x2199
Device Type (Major): Computer
Device Type (Complete): Mac Desktop
Composite Class Of Device: 0x380104
Device Class (Major): 0x01
Device Class (Minor): 0x01
Service Class: 0x1C0
Auto Seek Keyboard: On

the wifi is working and the bluetooth also working fine i tested with my beats.

but I can not get Continuity, handoff to work. air drop works from iphone to imac only.

can anyone please help me with this.
thanks in advance
 
Joined
Aug 9, 2017
Messages
11
Motherboard
P8Z68V-PRO
CPU
Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
Graphics
NVIDIA GeForce GTX 960
update: every thing is working fine now
all I had to do is sign out and sign in again on both iPhone and iMac and everything is working
 
Joined
May 18, 2014
Messages
3
Motherboard
Asrock Z390m pro
CPU
i7-6700K
Graphics
GTX-1070
mine the same problem. Have you fixed it yet?
I met this problem too. It worked before. But suddenly the wifi adapter couldn't be detected. I tried the following, both can fix it(You only need to do one of them):
1. Move the card to other slot.
2. Disable all options in "Platform Misc Configuration" in BIOS (See attached photo)
 

Attachments

  • IMG_2728.JPG
    IMG_2728.JPG
    1.9 MB · Views: 558
Last edited:
Joined
Jul 31, 2012
Messages
24
Motherboard
Asus P8 Z68 -V
CPU
Intel i7 2600K
Graphics
Zotac GTX 570
Mobile Phone
  1. Android
  2. iOS
Hi guys I just received this card and now I have wifi, bt, continuity, airdrop etc all works good.
However I have a strange problem: I cannot locate my Mac. I tried to go to system pref and check and uncheck the option for location, reboot , etc but nothing change. Sometimes the location works and other times not.
With my previous card (wdn4800) location was perfect.
What can I do?

EDIT: I noticed that evreytime I boot the infos of my wificard in System preference change.. in particular the country code...could this be related?

SOLVED: it was a problem with low WiFi signal/no signal. I moved my desktop near the router and now the location services works.

EDIT2: problem persists... location services works for a bit when I switch on Mac and then after a few minutes they stops.
 
Last edited:
Joined
Nov 16, 2017
Messages
12
Motherboard
Gigabyte GA-Z270X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
A7FBFE26-5F1C-4F74-A2E5-AFC51A78886D.jpeg
Hello.
I have some problems with this card.
I bought this (BCM943602CS with 3antenas) and I have problems with wifi and bluetooth. Wifi speed is not the same what I get with my macbook pro from same wifi in same location.
The problem with bluetooth is that, when I use wifi and bluetooth with my apple trackpad 2, the trackpad is lagging veru much. It is imposible to work.

Did someone had this problem? Maybe some ideas how to fix that?
 

Attachments

  • AB3E74CB-02C5-4C9F-9870-214BF957EA0C.jpeg
    AB3E74CB-02C5-4C9F-9870-214BF957EA0C.jpeg
    80.1 KB · Views: 377
Joined
Feb 9, 2018
Messages
43
Motherboard
HP 8300 Elite full size tower
CPU
i7 - 3770
Graphics
Intel HD 4000
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys, I am having some trouble with my BCM943602CS card, I have issues with bluetooth. WiFi works great so thank God I have no issues there. I am using a Magic Mouse that I have had for a while and used, without issue, with my 13" '11 MBP. The Magic Mouse is very laggy and glitchy. I have a wireless USB keyboard and mouse combo that I was using and left plugged in to use the keyboard and when the Magic Mouse is laggy, I can grab the USB wireless mouse and not have any issues at all.

I had an old PC that belonged to my wife a long time ago that she asked me to get some data off of, we are talking Windows XP old. I had it sitting on a table I setup in my office close to the Hackintosh and with it on, the Magic Mouse was unusable. I looked at the RSSI and with the XP computer on nearby, the RSSI hung out between -62 and -68. When I shut the XP computer down, its dropped to -57.

Now here is what is strange, the USB wireless mouse had the same exact intermittent lag issues as the Magic Mouse, prior to the BCM943602CS card being installed. At that time I had the wireless dongle that came with the mouse and keyboard plugged into the back of tower. It is now plugged into a USB hub sitting on the top of my desk.

This is the wifi/bluetooth card and adapter I bought:https://www.ebay.com/itm/Dual-Band-...rentrq:ab8a69f21620ab1d05bbd7ebfffa7620|iid:1

I also removed the card from the adapter to check for authenticity of being a Broadcom card and it checked out, I attached a photo so y'all can see it. I tried reaching out to the Ebay seller in China and despite their supposed no questions asked 1 year warranty, they hit me with a bunch of questions and then only offered a $5 refund. Needless to say, I don't think I will be getting any further there.

What do y'all think?
 
Joined
Jul 27, 2013
Messages
6
Motherboard
Gigabyte Aorus 5 Z370
CPU
Intel 8700K
Graphics
Integrated Graphics
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. Android
Hi!
Here is my Build:

Gigabyte Aorus Gaming 5 Z370
Intel 8700K
Corsair Vengeance 32GB - 3000Mhz

And this network card -

https://www.aliexpress.com/item/WTX...423.html?spm=a2g0s.9042311.0.0.341f4c4d7BhC5x

After trying many guides and workarounds, I am not able to get Hand-off working, though it should work OOB with this network card. Airdrop has started working after many attempts but it is very slow. I have a Dlink DIR 850L Router, which should give me 867Mbps on 5Ghz, but Network Utility says 400Megabits on this card)


I'm posting screenshots of the current problem.
The bluetooth can't be turned off, and it doesn't find or connect to devices.

Strangely in System Report under Bluetooth, it says the Manufacturer is Intel, which makes me think if the integrated BT is working along with the Broadcom one.

It will be great if somebody can help me rectify this problem.

I'll be grateful if you can tell me what exactly I need to provide as information and how (for example - IOReg, DSDT etc)
 

Attachments

  • Screen Shot 2018-05-23 at 5.18.08 PM.png
    Screen Shot 2018-05-23 at 5.18.08 PM.png
    51.2 KB · Views: 356
  • Screen Shot 2018-05-23 at 5.18.28 PM.png
    Screen Shot 2018-05-23 at 5.18.28 PM.png
    90.7 KB · Views: 378
  • Screen Shot 2018-05-23 at 5.18.58 PM.png
    Screen Shot 2018-05-23 at 5.18.58 PM.png
    100 KB · Views: 362
Joined
May 14, 2018
Messages
33
Motherboard
HP PRODESK 600 G1 S
CPU
i5 4670
Graphics
Intel hd 4600 / EVGA GT 630 2GB
Mac
  1. Mac mini
Mobile Phone
  1. iOS
How much did u end up paying?

Just ordered this card and plugged it in. Replaces my TP-Link TL-WDN4800 wireless card and IOGear GBU521 USB bluetooth adapter.

I've got my magic trackpad paired to this card, it's running my wireless, AirDrop is working, handoff/continuity support is working. Great card, and I got it from TaoBao. The shipping was very fast, but a little weird. You pay for shipping inside China first, then a warehouse gets the shipment, then you process a separate payment for overseas shipping. Received 5 days after I paid for overseas shipping. Hope this helps you or someone else.

One added bonus is that my system now reboots and boots more quickly, ostensibly because I'm not needing to sideload kexts for hardware not intended to run natively on a Mac.
 
Joined
May 19, 2012
Messages
1
Motherboard
ASRock Z370M Pro4
CPU
i7 8700K
Graphics
Sapphire RX570 8192Mb GDDR5
Mac
  1. iMac
Mobile Phone
  1. Android
Hello everyone, friends!

Today received the following card: Ali
Everything started to work without dances with kekst's. Below attached screenshots. The bluetooth works fine.

But with WiFi a strange problem. The computer determines the card, everything is as it should be. But I can not activate WiFi. It just does not turn on.

Below is also the characteristics of my hackintosh:
ASRock Z370M Pro4 | Intel Core i7-8700K | 250Gb Samsung 960 EVO SSD M.2 | RX 570 "Sapphire" 8192Mb GDDR5 | Corsair Vengeance LPX DDR4 2133Mhz - 32Gb

Also I have attached ioreg log.
 

Attachments

  • ioreg.txt
    147.1 KB · Views: 228
  • Screenshot 2018-06-01 14.40.01.png
    Screenshot 2018-06-01 14.40.01.png
    395.8 KB · Views: 343
  • Screenshot 2018-06-01 14.40.20.png
    Screenshot 2018-06-01 14.40.20.png
    124.9 KB · Views: 351
  • Screenshot 2018-06-01 14.40.27.png
    Screenshot 2018-06-01 14.40.27.png
    147.1 KB · Views: 345
  • Screenshot 2018-06-01 14.40.37.png
    Screenshot 2018-06-01 14.40.37.png
    121.8 KB · Views: 303
Status
Not open for further replies.
Top