Contribute
Register

Bcm94352z | dw1560 causes Windows 10 Lockup / Freeze

Status
Not open for further replies.
Joined
Oct 5, 2016
Messages
48
Motherboard
Dell XPS 9570 - Clover
CPU
i7-8750h/CM246
Graphics
UHD630, 1920x1080
Mobile Phone
  1. iOS
My DW1560 arrived today and I encountered the same issue. After trying the fix from @sparc1234 the card still freezes sadly... It worked for a really long time at the first boot, but after a reboot it went all downhill again...
My laptop is a Dell XPS 9570 on Windows 10 (Pro) build 1809.

Someone could share the driver's link, and the steps to follow, because that driver I finds it but for another old card version(Network_Driver_71T5D_WN32_7.35.340.0_A03.EXE) and not work for my. Thanks
That's the correct one. At install click 'Extract' instead of 'Install' and then install the driver manually using Device Manager. That package also contains a DW1560 driver.
 
Joined
Oct 11, 2018
Messages
4
Motherboard
Dell XPS 9570
CPU
i7-8750H
Graphics
GTX 1050 Ti + UHD 630
Hello, @userpakal, thanks for answering, but following your advice and installing those drivers, Windows continues to recognize the wifi card, but I do not get any network, in fact windows shows me the wifi card as "Turned off".
I do not know if any additional BIOS configuration will be necessary
 

Attachments

  • error.png
    error.png
    1.2 MB · Views: 602
Joined
Jul 13, 2013
Messages
37
Motherboard
Dell XPS 15 9570 4K
CPU
i7-8750H
Graphics
UHD 630 + GTX 1050 Ti
My DW1560 arrived today and I encountered the same issue. After trying the fix from @sparc1234 the card still freezes sadly... It worked for a really long time at the first boot, but after a reboot it went all downhill again...
My laptop is a Dell XPS 9570 on Windows 10 (Pro) build 1809.


That's the correct one. At install click 'Extract' instead of 'Install' and then install the driver manually using Device Manager. That package also contains a DW1560 driver.

Yeah it worked well for a while but then again I started having problems. Got frustrated and went with Windows for now with an Intel 9260 until I pickup a DW1830 / DW1820A and do hackintosh on this laptop again later
 
Last edited:
Joined
Apr 13, 2013
Messages
20
Motherboard
Razer Blade Advanced (Early 2019)
CPU
i7 8750H
Graphics
RTX 2070
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hey, I was experiencing this issue as well, however it seems to only happen when the system is not using the network, at least with me, the fix for me was to disable the PCI-E power management in the powerprofile:
1. go to power plan settings
2. go to the advanced settings
3. got to PCI Express
4. deactivate the Link State Power Management

Hope this helps someone.

EDIT: I have the stock windows driver for the card and have also applied other fixes from this thread before trying my solution, like disabling magic packet and wake on LAN, however the freezes where still happening. I dont know if deactivating Link State Power Management is sufficient on its own however, but in combination with the other fixes it seems to do the trick for me.
 
Last edited:
Joined
May 4, 2019
Messages
1
Motherboard
MSI X99A SLI PLUS
CPU
Intel 5820k
Graphics
Aorus GTX 1080TI
For anyone still looking for a solution to this issue like I was:

I found an updated driver on Dell's site (newer than the one you find on Google) at https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverid=wmn95

I had to extract (not install) and then replace the drivers that were in System32/Drivers. After 50+ reboots trying to get a fix, this was it for me


Edit: STRIKE ALL OF THAT. It worked longer with those files, but still locked up eventually. After doing a bit of digging, I found a Lenovo driver that actually matches the chipset (BCM4352) instead of the model (BCM94352Z). I kind of realized this when I was trying to install the DW1560 driver and it was saying it couldn't find the hardware, then confirmed it by looking at the Events on the adapter page.

Installing the Lenovo driver (https://support.lenovo.com/us/en/downloads/ds103388) directly was my silver bullet

Evidence that it installed correctly:

Capture.PNG
 
Last edited:
Joined
May 5, 2014
Messages
187
Motherboard
X1 Carbon 6th
CPU
i7-8550U
Graphics
UHD620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@Killuminati91,

Yes it's a known issue that affects some systems, the root cause is that the windows driver is just a repackaged Win 7 BCM95342 mini PCIe version and is not specific to the M.2 BCM95342Z version running on Windows 10. The driver file bcmwl63a.sys crashes when a badly timed interrupt occurs (confirmed using an oscilloscope on the interrupt line) .

However, it only seems to do it on some systems and/or BCM95342Z suggesting that the interrupt line level logic on some cards is tighter than on others ... I did a lot of research and investigation on the issue but never found a solution ... in the end I gave up on the BCM95342Z (DW1560) and replaced it with a DW1830,

I posted my findings in this post:-

https://www.tonymacx86.com/threads/...7-7500u-kaby-lake.213327/page-17#post-1609866

The BCM43602 WiFi chipset on a DW1830 card is a much better WiFi solution with MacOS native support but you must add a 3rd Antenna, Bluetooth is handled by a BCM20450 chipset which supports BT4.1LE thus allowing much better continuity and handoff compatibility.

Trust me you wont find a solution, save yourself the pain and get a DW1830, you may (like i did) have to tape the enable/disable pins 54 & 56 which i covered in the above link.

Cheers
Jay

Hi Jay,

I am quite interested in your conclusion DW1830 vs. BCM95342Z, which I have been investigating since while on both cards(m.2) in my X1C6.

N.B.: BCM95342Z seems to have unified PID & VID for WiFi but multiple PID & VID for BT. Due to concerns of BIOS I installed Lenovo variant, i.e. (PN) 20-200480, although it could be no problem.

My experiment results show:
  • Compatibility in both OS: DW1830 is better (WiFi and BT);
  • Connection speed: BCM95342Z is equally good(or better) as DW1830, although the latter specs 1.3Gbps. The Gbps WiFi speed was my main interest for test.But 1.3Gbps shown in connection speed only if my PC is directly closed to router, but if PC is 2~3 m away, it drops to 585/526/4xx Mbps, that is the same as BCM95342Z 's specs. But the latter shows higher and stable transfer speed within internal network, e.g. NAS, both in Wx and macOS, so my conclusion is DW1830 is not superior on speed although it specs 1.3Gbps;
  • WiFi for me has no problem since using Lenovo driver [1], although it is W7.
  • My biggest headache is BT; in Wx I got always another unknown USB device, which blocked my real BT module. Once I remove the unknown USB device and refresh device manager, I got my BT back; In macOS, I got often lost BT, even after reboot, but sometimes I can use iPhone to activate Airdrop although at that moment BT sign is n/a; with ~.
Could you confirm your DW1830 speed? and how is your antenna( esp. 3rd) arrangement? how is your experience of BT in Wx and macOS? totally reliable?​
(I have a feeling that he unstable BT comes from energy management both in Wx and macOS, but don't know if anything related to BIOS or firmware injection, in addition to the Wx 1803 => 1903 updating)​
BTW: my best antenna arrangement is:​

  • J0 => black wire ( wire labelled AUX )
  • J1 => extra antenna
  • J2 => grey/white wire (wire labelled MAIN)

Thanks!​
 
Last edited:

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,983
Motherboard
GB Z490 Vision G
CPU
i9 10850K OC @ 5.2 GHz
Graphics
Vega 64 LC + HD 630
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Mobile Phone
  1. iOS
Could you confirm your DW1830 speed? and how is your antenna( esp. 3rd) arrangement? how is your experience of BT in Wx and macOS? totally reliable?


@Cabriolet,

For me the DW1560 was ok in MacOS but very problematic in Windows ... BT in macOS would occasionally stop working and only a reboot would bring it back.

DW1830 is totally reliable in both MacOS and Windows 10 for both WiFi and BT .. works all the time with no issues.

DW1830 supports BT 4.1 LE (Low Energy) which MacOS uses so I guess that why it's been the best combo card I've ever used in a laptop Hack, DW1560 only supports BT 4.0.

AS For DW1830 WiFi speeds like you I only get >1000Mbs if with-in 1-2 meters of my AC router.
Usual connection speed for DW1830 for me is 867Mbs ... pretty much al the time unless ai'm really far from the router.

Cheers
Jay
 
Joined
Apr 15, 2019
Messages
13
Motherboard
Lenvo Thinkpad T450s
CPU
i7-5600U
Graphics
HD 5500 & GTX 940M
Mobile Phone
  1. Android
  2. iOS
I've replaced my card with another (nearly) identical Chinese DW1560 and downloaded the following drivers from the Dell site "Network_Driver_71T5D_WN32_7.35.340.0_A03.EXE" (google is your friend) which is the latest DW1560 Windows 10 driver Dell provides for any notebook. Run the executable, extract the files and manually replace the current broadcom driver with the DW1560 one. After that I disabled "Minimal Power Consumption" as well as "Wake On Magic Packet" and "Wake on Pattern Match". I haven't had a 'freeze' in two days. Since I've changed several things at one time I didn't mention it since it didn't particularly narrow it down to one thing and it could even be that the new card is less tricky than the previous one... Also I’ve never encountered the issue in any OS other than Windows so far.
Hi, do you already fix the issue? I am on thinkpad t450s with the same issue of DW1560
 
Joined
May 5, 2014
Messages
187
Motherboard
X1 Carbon 6th
CPU
i7-8550U
Graphics
UHD620
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@Cabriolet,

For me the DW1560 was ok in MacOS but very problematic in Windows ... BT in macOS would occasionally stop working and only a reboot would bring it back.

DW1830 is totally reliable in both MacOS and Windows 10 for both WiFi and BT .. works all the time with no issues.

DW1830 supports BT 4.1 LE (Low Energy) which MacOS uses so I guess that why it's been the best combo card I've ever used in a laptop Hack, DW1560 only supports BT 4.0.

AS For DW1830 WiFi speeds like you I only get >1000Mbs if with-in 1-2 meters of my AC router.
Usual connection speed for DW1830 for me is 867Mbs ... pretty much al the time unless ai'm really far from the router.

Cheers
Jay

Thanks for your feedback, that encourage to re-test DW1830 swapping BCM95342Z(Lenovo variant),
I am sorry maybe this is off-topic(let me know if I should open a new thread).
in macOs is fine. But in Wx, my DW1830's network properties shown very low speed: R/T = 216/175(Mbps), I would expect at least 877 bps(spec 1.3Gbps), you have mentioned somewhere your DW1830 at macOS was 450bps due to 80Mhz was not switch in...

How could I check in Wx if the driver is for channel width 80Mhz is opened or capable? check driver detailed panel or cmd: "netsh wlan show drivers " not found this info. What's your driver version?

How is your 3 antenna connecting?

thanks!
 
Status
Not open for further replies.
Top