Contribute
Register

BCM94352HMB bluetooth problem Catalina

Status
Not open for further replies.
Joined
Mar 20, 2013
Messages
90
Motherboard
Gigabyte Z390 I Aorus Pro Wifi
CPU
i5 9500
Graphics
Radeon RX560
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Hello
I recently bought BCM94352HMB wifi module with BLuetooth4.0.
I saw on this forum many people had success with this half mini PCIe board.

So I was following this thread https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/#post-1664577
Wifi is working but I cant seem to make bluetooth work

What I did:

In Clover/Kext/Other i have:
  • BrcmFirmwareData.kext
  • BrcmPatchRAM2.kext
  • FakePCIID_Broadcom_WiFi.kext
  • FakePCIID.kext
also applied kext patch (screenshot)
Maybe there is some USB issues (as far as I know bluetooth is treated as bluetooth).
I tried to make my usb mess clean with usbinjectall, changed EHCI1 to EH01 and EHCI2 to EH02, selected all ports
but this did not help either (is this a correct way how to handle usbs for the future?).

Thank you for help
 

Attachments

  • ioreg.ioreg
    9.6 MB · Views: 166
  • Screenshot 2019-10-24 at 17.31.09.png
    Screenshot 2019-10-24 at 17.31.09.png
    135.2 KB · Views: 474
  • Screenshot 2019-10-24 at 17.31.50.png
    Screenshot 2019-10-24 at 17.31.50.png
    30 KB · Views: 434
  • bootlog.txt
    24.5 KB · Views: 168
Joined
Dec 11, 2015
Messages
31
Motherboard
Asus ROG STRIX Z490-I GAMING
CPU
i7-10700KF
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hello
I recently bought BCM94352HMB wifi module with BLuetooth4.0.
I saw on this forum many people had success with this half mini PCIe board.

So I was following this thread https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/#post-1664577
Wifi is working but I cant seem to make bluetooth work

What I did:

In Clover/Kext/Other i have:
  • BrcmFirmwareData.kext
  • BrcmPatchRAM2.kext
  • FakePCIID_Broadcom_WiFi.kext
  • FakePCIID.kext
also applied kext patch (screenshot)
Maybe there is some USB issues (as far as I know bluetooth is treated as bluetooth).
I tried to make my usb mess clean with usbinjectall, changed EHCI1 to EH01 and EHCI2 to EH02, selected all ports
but this did not help either (is this a correct way how to handle usbs for the future?).

Thank you for help

i have the same card and i couldn't get it to work , my hackintosh is now connected via Cable and i am using a usb doungle to connect my keyboard and magic mouse 2, i disconnected the BCM94352 HMB card and i am waiting to see someone posted about getting it to work normaly and might like to share with us how he did it so we can follow-up his work.
 
Joined
Mar 20, 2013
Messages
90
Motherboard
Gigabyte Z390 I Aorus Pro Wifi
CPU
i5 9500
Graphics
Radeon RX560
Mac
  1. MacBook Air
  2. Mac Pro
Mobile Phone
  1. iOS
Ok, so these files I do have in Efi/clover/kexts/Other folder
No other kexts in S/L/E or L/E.
With Hackintool rebuild cache and fix permission. Hope it helps. And try to turn off your machine (power off - do not restart) Let me know if it helped
 

Attachments

  • BrcmBluetoothInjector.kext.zip
    3.4 KB · Views: 383
  • BrcmFirmwareData.kext.zip
    2.2 MB · Views: 404
  • FakePCIID_Broadcom_WiFi.kext.zip
    2.6 KB · Views: 401
  • BrcmPatchRAM2.kext.zip
    20.5 KB · Views: 329
  • FakePCIID.kext.zip
    13.6 KB · Views: 382

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,080
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Please note that Catalina requires BrcmPatchRAM3 as explained (and downloadable from) here:


Screen Shot 2020-01-08 at 8.51.32 AM.png
 
Joined
Dec 11, 2015
Messages
31
Motherboard
Asus ROG STRIX Z490-I GAMING
CPU
i7-10700KF
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Ok, so these files I do have in Efi/clover/kexts/Other folder
No other kexts in S/L/E or L/E.
With Hackintool rebuild cache and fix permission. Hope it helps. And try to turn off your machine (power off - do not restart) Let me know if it helped
should i just mount the efi with clover configurator and copy these kexts in the other folder and shut down ?
 
Joined
Dec 11, 2015
Messages
31
Motherboard
Asus ROG STRIX Z490-I GAMING
CPU
i7-10700KF
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Ok, so these files I do have in Efi/clover/kexts/Other folder
No other kexts in S/L/E or L/E.
With Hackintool rebuild cache and fix permission. Hope it helps. And try to turn off your machine (power off - do not restart) Let me know if it helped

i copied the files to the other folder, the wifi is working but bluetooh not , it says bluetooth on but no devices were found
 

Attachments

  • Screenshot 2020-01-08 at 22.43.38.png
    Screenshot 2020-01-08 at 22.43.38.png
    3.1 MB · Views: 377
  • Screenshot 2020-01-08 at 22.47.11.png
    Screenshot 2020-01-08 at 22.47.11.png
    2.5 MB · Views: 378
Joined
Dec 11, 2015
Messages
31
Motherboard
Asus ROG STRIX Z490-I GAMING
CPU
i7-10700KF
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Ok, so these files I do have in Efi/clover/kexts/Other folder
No other kexts in S/L/E or L/E.
With Hackintool rebuild cache and fix permission. Hope it helps. And try to turn off your machine (power off - do not restart) Let me know if it helped

so i copied the files to /Library⁩/⁨Extensions/⁩ Ireplaced the exsisting files and powerd off my hackintosh
after i turned it on everything works like a charm WiFi and Bluetooth hurrrrraaaaaayyyyyy finally
 

Attachments

  • Screenshot 2020-01-08 at 22.59.44.png
    Screenshot 2020-01-08 at 22.59.44.png
    3.1 MB · Views: 468
Joined
Apr 7, 2019
Messages
15
Motherboard
Gigabyte GA-Z97-HD3
CPU
i7-4790K
Graphics
GTX 780 Ti
so i copied the files to /Library⁩/⁨Extensions/⁩ Ireplaced the exsisting files and powerd off my hackintosh
after i turned it on everything works like a charm WiFi and Bluetooth hurrrrraaaaaayyyyyy finally

Thank you very much!!! with files posted by kajaba copied in L/E all work properly! thanks to kajaba and to bassel.gustav!
 
Joined
Nov 24, 2019
Messages
2
Motherboard
ROG M7I
CPU
E3-1231 V3
Graphics
GTX680
[QUOTE =“ bassel.gustav,帖子:2056687,成员:1481217”]
所以我将文件复制到/Library⁩/⁨Extensions/⁩替换了现有文件并关闭了我的hackintosh
在我打开它之后,一切都像魅力WiFi和蓝牙一样正常工作hurrrrraaaaaayyyyyy
[/引用]
Hei,man.Can you share your kexts documents.Thank,you.
 
Last edited:
Status
Not open for further replies.
Top