Contribute
Register

BCM94350ZAE/DW1820A only 802.11n wifi and no bluetooth devices

Joined
Aug 12, 2017
Messages
104
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
512K, iBook, iMac, LC, Performa, Plus, Power Mac, PowerBook, SE, SE/30
Mobile Phone
Android, iOS, Other
I am sorry if I post this in the wrong section as I see most M.2 Wifi cards are discussed in the laptop sections.
Here is my build:
- ASRock Fatal1ty Z370 Professional Gaming
- Intel i7-8700k Coffee Lake
- ASUS Radeon RX 580 8GB ROG Strix Gaming
- 32 GB DDR4 2666MHz

This motherboard has the usual M.2 NGFF Intel Wifi/BT so I bought the BCM94350ZAE/DW1820A M.2 card that is identical in size and form factor. I attached an image of the Intel and the DW1802A.

My problems are:
- Wifi is working but I only get 802.11n and not 802.11ac like this card supports.
- Bluetooth seems to work (icon) but I see no devices


I followed this advice https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/ and have listed my EFI/CLOVER/kexts/Other:

AppleALC.kext
AtherosE2200Ethernet.kext
BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext
CodecCommander.kext
FakePCIID_Broadcom_WiFi.kext
FakeSMC.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
IntelGraphicsFixup.kext
IntelMausiEthernet.kext
Lilu.kext
Lilu.kext.dSYM
NvidiaGraphicsFixup.kext
RealtekRTL8111.kext
Shiki.kext
SmallTreeIntel82576.kext
USBInjectAll.kext
WhateverGreen.kext
XHCI-200-series-injector.kext

As for WIFI you can see that the card is recognized as 802.11 ac but only works as 802.11n, connected to newest Airport Extreme (ac)



upload_2018-4-19_14-11-17.png


As for bluetooth it seems to be on but I can not see any devices. Maybe this section explains that? "Brikkesett:" is "Chipset" (sorry for the Norwegian)
upload_2018-4-19_15-38-45.png

I have attached my config.plist. Sorry if I am a newbie and don't really understand this DSDT stuff :)
I would be glad to get this working as the wifi/bt card is pretty cheap on Ebay and I would like to use it for further projects with motherboards that have onboard wifi/bt.

- One note is that I have all kexts in EFI/CLOVER/kexts/Others. I have not tried to put anything in /S/L/E as some suggest. But I am afraid the system will crash as I have read on other posts.
 

Attachments

Joined
Mar 17, 2016
Messages
49
Motherboard
GB-BKi5A-7200
CPU
Intel Core i5-7200U
Graphics
Intel HD 620
same problem here
 
Joined
Aug 12, 2017
Messages
104
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
512K, iBook, iMac, LC, Performa, Plus, Power Mac, PowerBook, SE, SE/30
Mobile Phone
Android, iOS, Other
Joined
Mar 17, 2016
Messages
49
Motherboard
GB-BKi5A-7200
CPU
Intel Core i5-7200U
Graphics
Intel HD 620
But no one seems to respond. Meaning there is no solution? Did you try the Broadcom Mini-PCIe WIFI guide?
https://www.tonymacx86.com/threads/dw1560-dont-work-macos-10-12-6.249561/page-2
https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/

Is your WIFI working? My WIFI works but I only get 802.11n and Bluetooth does not see any devices.
Same thing as you. Only 2G WiFi. No 5Ghz or bluetooth. Maybe we need to do the 5Ghz patch like the DW1560 and all the USB stuff to get bluetooth recognized. In my case there is no bluetooth anyway, I have no icon
 
Joined
Aug 12, 2017
Messages
104
Motherboard
Z390 I AORUS PRO WIFI
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac Pro
Classic Mac
512K, iBook, iMac, LC, Performa, Plus, Power Mac, PowerBook, SE, SE/30
Mobile Phone
Android, iOS, Other
Same thing as you. Only 2G WiFi. No 5Ghz or bluetooth. Maybe we need to do the 5Ghz patch like the DW1560 and all the USB stuff to get bluetooth recognized. In my case there is no bluetooth anyway, I have no icon
Do you have a link to the 5GHz patch? Is this really a USB issue when the card is not USB?
 
Joined
Mar 17, 2016
Messages
49
Motherboard
GB-BKi5A-7200
CPU
Intel Core i5-7200U
Graphics
Intel HD 620
Do you have a link to the 5GHz patch? Is this really a USB issue when the card is not USB?
well, I'm trying to patch it in the same way as the DW1560 but it doesn't work. Maybe @RehabMan knows something about that. The card is compatible, it works fine natively. The only trouble is bluetooth and 5Ghz
 
Joined
Mar 17, 2016
Messages
49
Motherboard
GB-BKi5A-7200
CPU
Intel Core i5-7200U
Graphics
Intel HD 620
btw, I tried swapping antennas and everything works exact the same way, no changes. I know that BT isn't an usb card, but I think we need to have the correct SSDT for the USB in order to make it happen.

For the 5Ghz WiFi, no news. I'm trying to patch it but I can't. 2.4Ghz band works fine natively, that's all I can say
 
Joined
Feb 4, 2017
Messages
168
Motherboard
Dell XPS 13 9350 - BIOS 1.7
CPU
i7-6600U
Graphics
HD 520, 3200 x 1800
Mac
iMac, MacBook Air, Mac mini
Mobile Phone
iOS
Joined
Feb 4, 2017
Messages
168
Motherboard
Dell XPS 13 9350 - BIOS 1.7
CPU
i7-6600U
Graphics
HD 520, 3200 x 1800
Mac
iMac, MacBook Air, Mac mini
Mobile Phone
iOS
I am sorry if I post this in the wrong section as I see most M.2 Wifi cards are discussed in the laptop sections.
Here is my build:
- ASRock Fatal1ty Z370 Professional Gaming
- Intel i7-8700k Coffee Lake
- ASUS Radeon RX 580 8GB ROG Strix Gaming
- 32 GB DDR4 2666MHz

This motherboard has the usual M.2 NGFF Intel Wifi/BT so I bought the BCM94350ZAE/DW1820A M.2 card that is identical in size and form factor. I attached an image of the Intel and the DW1802A.

My problems are:
- Wifi is working but I only get 802.11n and not 802.11ac like this card supports.
- Bluetooth seems to work (icon) but I see no devices


I followed this advice https://www.tonymacx86.com/threads/broadcom-wifi-bluetooth-guide.242423/ and have listed my EFI/CLOVER/kexts/Other:

[

- One note is that I have all kexts in EFI/CLOVER/kexts/Others. I have not tried to put anything in /S/L/E as some suggest. But I am afraid the system will crash as I have read on other posts.



but just looking at your config.plist you posted
you did not do any of the
kernel and kext patches for config.plist for BRCM as per guide

  • download config-bcm....
  • paste patch to config...

Clover Broadcom Patches/Download (View Raw)
config-bcm94352-130.plist.zip


WiFi Injection Methods (select one method, remove before installing a different method)
  1. kext enabler, FakePCIID/RehabMan
    • All supported Broadcom WiFi cards/AirPortBrcm4360.kext
    • README: RehabMan/OS-X-Fake-PCI-ID
    • Download: RehabMan / OS-X-Fake-PCI-ID
    • Install with kext installer to ~/Library/Extension:
      • FakePCIID.kext
      • FakePCIID_Broadcom_WiFi.kext
      • Install latest versions as available
    • Download config-bcm94352-1x0.plist.zip (above)
      • use AirPort.Brcm4360 patches (10.12)
    • Paste patch to config.plist/KernelAndKextPatches/KextsToPatch
      • 10.12+-BCM94352-fvco-darkvoid
      • 10.13/10.12 only
      • 10.11/10.10/10.9 patches - see VII. Previous macOS Support
if you are running high Sierra 10.13
you would need these added to your config plist

KernelAndKextPatches = {

KextsToPatch = (
{
Comment = "10.13-BCM94352-fvco-darkvoid-Sherlocks";
Find = <81f952aa 000074bf>;
MatchOS = "10.13.x";
Name = "com.apple.driver.AirPort.BrcmNIC-MFG";
Replace = <81f952aa 00006690>;
},
{
Comment = "10.13-BCM94352-iovar-Sherlocks";
Find = <85db4c8b 65c87971>;
MatchOS = "10.13.x";
Name = "com.apple.driver.AirPort.BrcmNIC-MFG";
Replace = <85db4c8b 65c8eb71>;
},
{
Comment = "10.13-BCM94352-iovar-Sherlocks";
Find = <4883c410 89c385db 7946>;
MatchOS = "10.13.x";
Name = "com.apple.driver.AirPort.BrcmNIC-MFG";
Replace = <4883c410 89c385db eb46>;
},
{
Comment = "10.13-BCM94352-CC-Sebinouse-(edit 55 53 to CC)-PMheart - change the 55 53 in the replace hex to your country code hex - Norway would be 4e 4f ";
Find = <4183fcff 7435488d 55d0>;
MatchOS = "10.13.x";
Name = "com.apple.driver.AirPort.BrcmNIC-MFG";
Replace = <66c70655 53eb348d 55d0>;
},
{
Comment = "10.13-BCM94352-Airport-Extreme-Skvo-Sherlocks";
Find = <6b100000 750d>;
MatchOS = "10.13.x";
Name = "com.apple.driver.AirPort.BrcmNIC-MFG";
Replace = <6b100000 9090>;
},
{
Comment = "10.13-Disable-Whitelist-check-RehabMan";
Find = <31db4ccb 65d87512>;
MatchOS = "10.11.x,10.12.x";
Name = "com.apple.driver.AirPort.BrcmNIC-MFG";
Replace = <31dbffc3 90909090>;
},
{
Comment = "10.12+-BCM94352-fvco-darkvoid";
Find = <81f952aa 00007529>;
MatchOS = "10.12.x";
Name = "com.apple.driver.AirPort.Brcm4360";
Replace = <81f952aa 00006690>
}
note:
regarding PMHeart Patch for country above (helpful for 5Ghz working properly)
to convert ASCII to HEX you can go to terminal but i use this
https://www.rapidtables.com/convert/number/ascii-to-hex.html
just type in your country code and it will show you the HEX value.
eg
NO: 4e 4f
US: 55 53
AU: 41 55

US would be
Replace = <66c70655 53eb348d 55d0>

NO would be
Replace = <66c7064e 4feb348d 55d0>

please see my post #11 using AirportBrcmFixup.kext (Lilu plugin) which can accomplish the same thing with bootargument - and also does other patches
 
Last edited:
Joined
Feb 4, 2017
Messages
168
Motherboard
Dell XPS 13 9350 - BIOS 1.7
CPU
i7-6600U
Graphics
HD 520, 3200 x 1800
Mac
iMac, MacBook Air, Mac mini
Mobile Phone
iOS
@asleb
with regards to your bluetooth injection

BrcmFirmwareRepo.kext : has to be copied properly into /L/E - does not work in clover/kext/other
BrcmPatchRAM2.kext: can be via clover or copied properly into /L/E
I would put both into /L/E
and remove them from clover

(also fakePCIID and fakePCIIDbroadcom_WiFi - best to put in S/L/E or /L/E as well)

according to your information: you have brcmfirmwarerepo in clover/kext/other


see
https://github.com/RehabMan/OS-X-BrcmPatchRAM

BrcmFirmwareRepo.kext does not work with Clover kext injection, unless using a device specific firmware injector. BrcmFirmwareData.kext can work with Clover kext injection.
if using terminal you can use these commands to copy the two kexts to /L/E
replace <file location> with path to your kexts


Code:
sudo cp -R  /<file location>/BrcmFirmwareRepo.kext  /Library/Extensions
sudo cp -R  /<file location>/BrcmPatchRam2.kext  /Library/Extensions
rebuild the cache with this

sudo touch System/Library/Extensions && sudo kextcache -u
Code:
sudo touch
/Library/Extensions && sudo kextcache -u /
 
Last edited:
Top