Contribute
Register

BCM5709C is not detected in High Sierra

Joined
Aug 31, 2019
Messages
2
Motherboard
ASRock P55 Pro/USB3
CPU
Intel Xeon X3440
Graphics
Nvidia Gigabyte GeForce GTX 650 Ti (2GB Version)
Mac
MacBook Pro
Mobile Phone
Android
Hi,

Recently I have installed High Sierra on my not so compatible Hackintosh:
MB: ASRock P55 Pro/USB3
CPU: Xeon X3440 (overclocked to 3.6 GHz)
RAM: 8 GB DDR3-1333 (OC 1950)
HDD: Seagate Barracuda 7200.10 200 GB
GPU: Gigabyte GeForce GTX 650 Ti (not Boost) 2 GB

I was post-installing the system, when I needed to upgrade High Sierra (build 66) to last build, but there was no internet connection at all. I found out that built-in Realtek Ethernet chip is dead, so instead of it I use network card with Broadcom BCM5709C chip. And the OS detect it, but cannot initialize:
bcm5709 log.png

I tried to patch network kexts - no result. I deleted network preferences - no result. Lastly, I pasted those kexts not to the /L/E, but to the Clover's kexts folder - results in error showed above.

Modified and original kexts are attached.

UPD: I modified Clover's config.plist and, after turn off-on, network card was detected. But, anyway, there is still no internet, because, even with plugged in the card cable, OS can't detect connection.

Thanks.
 

Attachments

Last edited:
Joined
Feb 11, 2013
Messages
16
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i5-2500K
Graphics
GT 210 + HD 3000
ASRock P55 Pro/USB3 You have an RLT8111E not a BCM5709C

So you have Modifying kext for nothing because RLT8111E is part of Multibeast
If it not work reinstall from scratch then choose the network on multibeast or install the kext In Clover manually
 
Joined
Aug 31, 2019
Messages
2
Motherboard
ASRock P55 Pro/USB3
CPU
Intel Xeon X3440
Graphics
Nvidia Gigabyte GeForce GTX 650 Ti (2GB Version)
Mac
MacBook Pro
Mobile Phone
Android
ASRock P55 Pro/USB3 You have an RLT8111E not a BCM5709C

So you have Modifying kext for nothing because RLT8111E is part of Multibeast
If it not work reinstall from scratch then choose the network on multibeast or install the kext In Clover manually
But I mentioned that MB's RTL8111 is dead, so I need to use Broadcom adapter.
 
Top