Contribute
Register

BCM 94352HMB WiFi - Catalina Problems

Joined
Mar 29, 2020
Messages
3
Motherboard
HP Spectre 13 x360
CPU
i7-7500U (KabyLake)
Graphics
HD 620
Hey,
I recently installed Catalina 10.15.3 on my HP Spectre 13 x360 (13-ac013dx, i7-7500U) but I cannot get my WiFI (BCM 94352HMB) to turn on. The icon shows, but selecting the turn on option does nothing.
The surprising thing is that I got the WiFi to work after my first few bootups with Catalina using the BrcmPatchRam2 kexts, but shortly afterwards it stopped turning on. Before this, Mojave was installed and had no problems whatsoever with the WiFi / BT.
The WiFI device is recognised in System Information as Airport Extreme (0x14e4,0x523) with Firmware Version Broadcom BCM 43xx 1.0.
As of now, I have BrcmPatchRAM3, BrcmFramwareRepo, AirportBrcmFixUp, Lilu, FakePCIID_BroadcomWiFi, FakePCIID kexts in L/E. I have also added fvco darkvoid's patch for the config.plist, but that brought around no effect. DSDT has been customized with some fixes such as OC Check Fix.
I have attached my Clover (r5106) directory with all kernel logs etc. as per the problem reporting guidelines.
I have tried almost everything I came across, from including the new BRCMPatchRam3 kexts to all applying all possible fixes (also a fresh Catalina install). Can someone PLEASE help me figure this out? I have spent DAYS trying to fix this but to no avail.
 

Attachments

  • Clover+Logs_29Mar.zip
    6 MB · Views: 63
Last edited:
Joined
Feb 24, 2013
Messages
38
Motherboard
Gigabyte H370-HD3
CPU
i5-8400
Graphics
570
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Try to put it under EFI partition, and remove all the kexts by following this post?
 
Joined
Apr 15, 2020
Messages
16
Motherboard
Dell XPS 9560
CPU
i7-7700HQ
Graphics
HD630
Mac
  1. iMac
  2. MacBook Pro
https://github.com/acidanthera/BrcmPatchRAM this did the trick for me. Read everything carefully specially this portion:

I see you have some of the kexts so I would re-read the link and place them as they suggest:


Installation
Note if you have an Apple MacBook/iMac/Mac Pro etc, follow the Mac instructions

Install one of BrcmPatchRAM.kext or BrcmPatchRAM2.kext or BrcmPatchRAM3.kext depending on macOS version, never both.

  • BrcmPatchRAM.kext: for 10.10 or earlier.
  • BrcmPatchRAM2.kext: for 10.11 or later.
  • BrcmPatchRAM3.kext: for 10.15.
Also, install one firmware kext BrcmFirmwareData.kext or BrcmFirmwareRepo.kext, depending on installation location, never both.

  • BrcmFirmwareData.kext: Most appropriate for bootloader injection. This is the preferred configuration.
  • BrcmFirmwareRepo.kext: Install to /System/Library/Extensions (/Library/Extensions on 10.11 and later). This kext is slightly more memory efficient than BrcmFirmwareData.kext, but cannot be injected by a bootloader.
  • Advanced users: For custom firmware injectors, install the injector plus BrcmFirmwareRepo.kext. This works from either /S/L/E or through bootloader injection. Optionally, you may remove all the firmwares from BrcmFirmwareRepo.kext/Contents/Resources. If you're using the injector through the bootloader, the IOProviderClass in the Info.plist for BrcmFirmwareRepo.kext must be changed from "disabled_IOResources" to "IOResources".
Keep in mind that BrcmPatchRAM3.kext also requires BrcmBluetoothInjector.kext to be installed. Starting with macOS 10.15, this is the only supported configuration because due to framework changes BrcmPatchRAM.kext and BrcmPatchRAM2.kext are incompatible with macOS 10.15. In case you forget to install BrcmBluetoothInjector.kext, Bluetooth will appear to be available but it won't work at all.
 
Joined
Mar 29, 2020
Messages
3
Motherboard
HP Spectre 13 x360
CPU
i7-7500U (KabyLake)
Graphics
HD 620
Thanks guys! I resolved this by resetting my BIOS settings to default - somehow that was all that was needed.
However, I have thus far been unsuccessful in getting the bluetooth to work with the same card. Any help would be greatly appreciated.
I've added FakePCIID, FakePCIID_Broadcom, BrcmPatchRam3, BrcmBluetoothInjector and BrcmFirmwareRepo to L/E with all permissions set properly. The bluetooth device isn't detected by Catalina.
 
Top