Contribute
Register

Audio + WiFi doesn't work on Thinkpad T430 Hackintosh

Joined
Dec 1, 2016
Messages
4
Mobile Phone
Android
Hello!

This is my first time setting up a hackintosh, so I apologize if this is somewhat of a stupid question. I followed this guide to turn my Thinkpad T430 into a Hackintosh, but I used OSX Sierra instead of El Capitan. Almost everything works, aside from the audio input/output and the WiFi.

From what I've read, I'm pretty sure the internal WiFi card will never work, because it's an Intel brand WiFi card, and there's no drivers for OSX, please correct me if I'm wrong.

However, I'm not sure why the audio doesn't work. When I look in System Preferences > Sound, I see "no input devices found" and "no output devices found." I'm not sure how to diagnose and resolve this issue, could it be I'm loading the wrong kext for my audio card?

Thanks very much!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello!

This is my first time setting up a hackintosh, so I apologize if this is somewhat of a stupid question. I followed this guide to turn my Thinkpad T430 into a Hackintosh, but I used OSX Sierra instead of El Capitan. Almost everything works, aside from the audio input/output and the WiFi.

From what I've read, I'm pretty sure the internal WiFi card will never work, because it's an Intel brand WiFi card, and there's no drivers for OSX, please correct me if I'm wrong.

However, I'm not sure why the audio doesn't work. When I look in System Preferences > Sound, I see "no input devices found" and "no output devices found." I'm not sure how to diagnose and resolve this issue, could it be I'm loading the wrong kext for my audio card?

Thanks very much!
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
 
Joined
Dec 1, 2016
Messages
4
Mobile Phone
Android
OK, I've looked through this guide as well, and fixed most of my problems. The only issue I have is audio still doesn't work. I've followed the guides on kext patches I needed to add to Clover, but after several attempts, lots of tweaking, and countless reboots, I still can't get my audio card recognized.

As in the post I linked in the OP, I've got a Realtec ACL3202 aka. ALC269 audio card.

What should I do to get help with this issue? I'd really like my speakers to work.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,088
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
OK, I've looked through this guide as well, and fixed most of my problems. The only issue I have is audio still doesn't work. I've followed the guides on kext patches I needed to add to Clover, but after several attempts, lots of tweaking, and countless reboots, I still can't get my audio card recognized.

As in the post I linked in the OP, I've got a Realtec ACL3202 aka. ALC269 audio card.

What should I do to get help with this issue? I'd really like my speakers to work.
Audio also covered in the FAQ. You need patched AppleHDA components that match your codec (many flavors of ALC269) and appropriate DSDT patches.
 
Joined
Dec 1, 2016
Messages
4
Mobile Phone
Android
Audio also covered in the FAQ. You need patched AppleHDA components that match your codec (many flavors of ALC269) and appropriate DSDT patches.
Ok, I'll keep banging my head against this wall :crazy:
Thanks for all the hard work you do on stuff like VoodooPS2 and the like, by the way! Even though I'm having trouble with this, I appreciate how hassle-free everything else has been thanks to your tools!
 
Top