Contribute
Register

Audio problems with ALC282

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS

Your kextcache output proves kexts are not installed correctly.
Note that as per FAQ, kexts on 10.11 and later should be installed to /L/E, not /S/L/E.
 
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
Your kextcache output proves kexts are not installed correctly.
Note that as per FAQ, kexts on 10.11 and later should be installed to /L/E, not /S/L/E.
installed to /L/E.
 

Attachments

  • debug_18686.zip
    1.7 MB · Views: 45

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
installed to /L/E.

This configuration looks ok, except for:
- the USB WiFi... USB WiFi not recommended (install supported PCIe WiFi instead).
- remove VirtualBox
- FakeSMC sensor kexts not necessary (they are inefficient also...)
- config.plist/SMBIOS/Trust should be set true/Yes (you have no/false)
- if it works, AptioMemoryFix.efi preferrred over OsxAptioFixDrv-64.efi
- TRIM on 10.13 can be problematic
 
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
- the USB WiFi... USB WiFi not recommended (install supported PCIe WiFi instead).
I installed DW1560 wifi card but my laptop doesn't support it, removed USB wifi driver and install HoRNDIS but it didn't work so I installed USB wifi again as I've no broadband connection.

- remove VirtualBox
I had Parallel Desktop installed but I removed it few days ago.

- FakeSMC sensor kexts not necessary (they are inefficient also...)
- config.plist/SMBIOS/Trust should be set true/Yes (you have no/false)
- if it works, AptioMemoryFix.efi preferrred over OsxAptioFixDrv-64.efi
- TRIM on 10.13 can be problematic
done
 

Attachments

  • debug_8040.zip
    1.8 MB · Views: 38

Sniki

Moderator
Joined
Jan 5, 2016
Messages
2,312
Motherboard
HP Elite 8300 SFF
CPU
i7-3770
Graphics
HD 3000 | GTX 1650 LP
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm having the same mute issue but this happens when I close the lid of my laptop.
when I close the lid audio gets mute but it doesn't get mute when I select sleep from 
can I try these SSDTs you've attached?
my laptop has same audio codec ALC282
I forgot what i did on these files, so i will check them if i find time for it.
What type of muted audio are you exactly refering to ?
1. Example: volume at 100% but no audio (like being muted).
2. When you wake from sleep volume bar goes to 0 ?

If it is case 1 we may have to experiment with resetting codec on SSDT and do a debug of verbs before and after wake from sleep to see if something changes so we can adjust the SSDT/Codec/ or if needed build a custom ALCplugFix.
 
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
I forgot what i did on these files, so i will check them if i find time for it.
What type of muted audio are you exactly refering to ?
1. Example: volume at 100% but no audio (like being muted).
2. When you wake from sleep volume bar goes to 0 ?
my issue is when I close the lid audio gets mute.
theres nothing to do with sleep as I've tried closing lid then instantly open the lid the audio got mute without even going to sleep mode
 
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
Without an external monitor/keyboard/mouse attached, it is probably expected.
but this issue wasn't with El Capitan.
this issue occurred in Sierra and still there in High Sierra.
 
Last edited:
Joined
Oct 7, 2016
Messages
278
Motherboard
Broadwell, UEFI
CPU
Core i3-5005U
Graphics
Intel HD 5500 (1366 x 768), AMD Radeon R5 M330 2GB
Mobile Phone
  1. Android
  2. iOS
If it is case 1 we may have to experiment with resetting codec on SSDT and do a debug of verbs before and after wake from sleep to see if something changes so we can adjust the SSDT/Codec/ or if needed build a custom ALCplugFix.
I don't know how to do that
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,490
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
but this issue wasn't with El Capitan.
this issue occurred in Sierra and still there in High Sierra.

Experiment with a real Mac in the same test scenario so you know what to expect.

My thought is that lid closed indicates the user wants the laptop to sleep, therefore it is expected that audio playback will stop as soon as the lid is closed.
 
Status
Not open for further replies.
Top