Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Oct 19, 2012
Messages
61
Motherboard
Asrock z87 Extreme3
CPU
i7-4770K
Graphics
GTX 660
Mobile Phone
  1. Android
Hi!

No way to HDMI Audio on my Laptop and when starts the boot logo screen is black. With white backgrounds i have like interferences (with chameleon all works great). Now I'm clover with Yosemite 10.10.5. (Yes, I've hardware acceleration, and HDMI graphics work, is rare)

Laptop > Fujitsu UH552 i3 1,8Ghz + HM76 Chipset + 1366x768 resolution + Realtek ALC269VB

Thanks

PD.: Yes, this topic is only for audio, but I think that the problem can be with the HD4000 in general (ig-platform?)

All the files are View attachment 170499
 
Joined
Dec 12, 2015
Messages
3
Motherboard
asus b85me/br
CPU
I5 4430
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
hi, I having trouble with the audio in the HDMI output my config its asus b85me, already followed several posts on the forum but could not solve.

i used the
audio_cloverALC-110_v1.0o11 and reboot but not work
i download ssdt_hdmi-hd4600+.zip and follow the pdf but not work.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,090
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
i used the audio_cloverALC-110_v1.0o11 and reboot but not work
i download ssdt_hdmi-hd4600+.zip and follow the pdf but not work.
Not done, see Post #1, framebuffer edits required.
 
Joined
Dec 12, 2015
Messages
3
Motherboard
asus b85me/br
CPU
I5 4430
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
ok i little confused with framebuffer
i follow the pdf HD4600+-HD4000-HD3000_Framebuffer_Edits.pdf and i get three AppleIntelFramebuffer
AppleIntelFramebuffer@0
AppleIntelFramebuffer@1
AppleIntelFramebuffer@2

with port number 0x5,0x6 and 0x7 respectively
but now I do not know how to proceed
 
Joined
Dec 12, 2015
Messages
3
Motherboard
asus b85me/br
CPU
I5 4430
Graphics
intel 4600
Mac
Classic Mac
Mobile Phone
it works now.
thanks.
 
Joined
Mar 7, 2013
Messages
92
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello, Im Having issues trying to get hd4600 Hdmi audio. Here's my files for the machine. Hopefully it complete.

1. No hdmi audio. Video works perfectly.


2. 10.11.1, asrock h81m-itx, Bios: 2.20, Cpu I3-4360, No GPU.


3. Used This to get onbroad audio working: audio_cloverALC-110_v1.0o10.command
then used this guide for hdmi Audio:[Guide]_HD4600-hdmi_audio_(dsdt_or_ssdt)_v3.pdf

It won't let me upload the console Log. It states its too big for this file type.

View attachment iMac.iojones
View attachment AppleHDA.kext.zip
View attachment config.plist
View attachment debug.log
View attachment System DSDT.aml



 

toleda

Moderator
Joined
May 20, 2010
Messages
24,090
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
used this guide for hdmi Audio:[Guide]_HD4600-hdmi_audio_(dsdt_or_ssdt)_v3.pdf
won't let me upload the console Log. It states its too big for this file type.
pdf does not mention config.plist/ACPI/DSDT/Patches because it doesn't work, remove.
pdf does mention 8 Series/Step 2: OS X HDMI Audio Guides - select dsdt or ssdt and install.
zip any file attached.
 
Joined
Mar 7, 2013
Messages
92
Motherboard
GA-X99M-Gaming 5
CPU
i7-5820K
Graphics
RX560
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Got it figured out.
Thanks toleda For your Awesome effort!
 
Status
Not open for further replies.
Top