Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Apr 30, 2012
Messages
24
Motherboard
GA H97N-Wifi
CPU
i5-4590
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
I'm trying to get HDMI Audio working on a fresh El Capitan install, but am a little confused of what I need to do.

I followed the guide here to install ElCapitan, including the manual process (no Multibeast) for updating the DSDT and SSDT files.

I downloaded and ran the audio_cloverALC-110.zip and that enabled my 1/8" audio jacks, but I still do not get any HDMI, or any HDMI audio options in my System Information.

When I ran the audio_cloverALC-110_v1.0n10.command script, one of the things it listed was something about HD4600 HDMI. However, reading through this forum seems to indicate a much more manual process. I'm not sure, however, if the steps presented here are instead of running the script, or in addition to.

My build:
Gigabyte H97N-Wifi
i5-4590
8G Ram
500G SSD
Using the integrated graphics


I found the link for the ssdt_Hdmi-hd4600_AirPlay so I tried to copy the SSDT-1.aml to the EFI/CLOVER/ACPI/patched folder, and now I do see an AirPlay icon in the menu bar and a new HDMI output option in my System Information, but still no HDMI in my Sound preference pane (so I am unable to select HDMI as an Audio output).



Is there something additional I need to do to enable the HDMI Audio?

Thanks,

Eric
 

Attachments

  • Screen Shot 2015-12-27 at 12.33.40 AM.png
    Screen Shot 2015-12-27 at 12.33.40 AM.png
    85 KB · Views: 105
  • Screen Shot 2015-12-27 at 12.35.43 AM.png
    Screen Shot 2015-12-27 at 12.35.43 AM.png
    98.5 KB · Views: 98
  • Screen Shot 2015-12-27 at 12.36.20 AM.png
    Screen Shot 2015-12-27 at 12.36.20 AM.png
    48.4 KB · Views: 135
  • debug files.zip
    2.4 MB · Views: 55
Joined
Apr 30, 2012
Messages
24
Motherboard
GA H97N-Wifi
CPU
i5-4590
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
See Post #1.

That's just my problem - I'm having difficulty understanding exactly what needs to be done. I'm sure I'm missing a step, but am not sure exactly what/which one.

I have added the SSDT-1.aml to my EFI/CLOVER/ACPI/patches folder and tried running the audio_realtekALC110.command file, but get the following output:

Code:
erics-iMac:~ eric$ /Users/eric/Downloads/audio_realtekALC-110_v1.0n.command ; exit;
 
Agreement
The audio_realtekALC-110 script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_realtekALC-110 script is
provided as is and without any kind of warranty.
 
File: File: audio_realtekALC-110.command_v1.0n1
rm: /tmp/org.chameleon.Boot.txt: No such file or directory
Confirm Realtek ALC892 (y/n): y
HDAU@3 found, HD4600 HDMI audio capable
/Users/eric/Downloads/audio_realtekALC-110_v1.0n.command: line 1237: syntax error: unexpected end of file
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.


[Process completed]

I also tried using the MultiBeast Optional HD4600 Audio installation, but I still do not see any HDMI option for my sound output in my Preference pane.

What am I missing? I have updated my prior post with all the data files.

Thanks,

Eric
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I also tried using the MultiBeast Optional HD4600 Audio installation, but I still do not see any HDMI option for my sound output in my Preference pane.

What am I missing? I have updated my prior post with all the data files.
Script updated, download latest version and run
Script/MultiBeast does not enable HD4600 HDMI audio
Post #1/HDMI/DP Audio Guides​/Part A and Part B required for HD4600 HDMI audio
Attach new files to reply.
 
Joined
Apr 30, 2012
Messages
24
Motherboard
GA H97N-Wifi
CPU
i5-4590
Graphics
HD4600
Mac
Classic Mac
Mobile Phone
Script updated, download latest version and run
Script/MultiBeast does not enable HD4600 HDMI audio
Post #1/HDMI/DP Audio Guides​/Part A and Part B required for HD4600 HDMI audio
Attach new files to reply.

Thanks! All the different combinations of the Post #1 configuration were a little confusing, but I finally got it working by adding the kexts to the config.plist as specified in Part B. I had mistakenly thought that the Clover command script took care of that automatically.

I am still having trouble enabling AirPlay. Is that related to HDMI Audio (I would doubt it) at all?

Thanks,

Eric
 
Joined
Sep 13, 2014
Messages
143
Motherboard
Lenovo G580 (2189)
CPU
i5-3210M/HM76
Graphics
HD4000 + GT 610M, 1366x768
Mobile Phone
  1. Android
  2. iOS
Hi Toleda,

my HDMI Audio didnt working...

can u help me to solve that?

my patched dsdt and my IOreg

thank you :)View attachment Archiv.zip
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top