Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Oct 5, 2013
Messages
505
Mac
Classic Mac
Mobile Phone
Is there a question?

Yes, there is an implied question in the end of what I posted.

You stated in post #68 that the two connector types are what matter.

Clearly, the OS can get a lot of information about connected devices since we can see this in the System Report.

So, more directly 'How does one find out the connector type of the connected device?'.
 
Joined
Aug 19, 2010
Messages
25
Motherboard
Gigabyte H61M
CPU
i3 3220
Graphics
HD 7970
I have Upgraded (Fresh Install) to Yosemite and cannot get AMD Diamond HD7750 "HDMI" Audio to be detected. Everything else including graphics working perfectly for primary monitor on DVI and secondary monitor to to Samsung TV via HDMI (but no sound).
In Mavericks I could ALT-Click sound Icon and select either onboard analog audio or HDMI audio

Specs:

OS X Yosemite 10.10 New Install, Gigabyte H61M-D2P-B3, F12 Bios, AMD Diamond HD7750 1GB, Clover Bootloader, DSDT.aml with edits done in actual DSDT.aml for all including onboard analog audio and AMD 7750 Graphics w/Chutoro framebuffer referenced in DSDT.
Only extra Kexts loaded by Clover are FakeSMC and Ethernet.
Only modified Kext is AppleHDA for analog audio.

All related files attached.

I am stuck as to know what to do next.

Any help would be great.

Thanks
Steve
 

Attachments

  • config.plist
    2.5 KB · Views: 173
  • DSDT.aml
    17.9 KB · Views: 115
  • Steve's Console.log.zip
    69.2 KB · Views: 81
  • Steve's IOREG.ioreg
    5.8 MB · Views: 85
  • AppleHDA.kext.zip
    921 KB · Views: 52

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
DSDT.aml with edits done in actual DSDT.aml for all including onboard analog audio and AMD 7750 Graphics w/Chutoro framebuffer referenced in DSDT.
No HDMI audio edits in the attached dsdt/IOReg.
 
Joined
Sep 10, 2014
Messages
291
Motherboard
Asus Z97-A/USB3.1
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
It must be me, but I think I will have to wait until there is an easier way to enable HDMI.
My Yosemite Clover install works great and I have analog sound working. Don't want to risk mucking it up.

I handled the Mavericks Multibeast install with no problem, and completed the Yosemite Clover install and even followed the guide to get iMessage working successfully, but for some reason this guide seems to be way over my head.

Maybe there will be an easier way in the future.

To those of you that have been successful with this, I salute you.

Len
 
Joined
Sep 10, 2014
Messages
291
Motherboard
Asus Z97-A/USB3.1
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iBook
  2. iMac
Mobile Phone
  1. iOS
What is the purpose of this post?

The only purpose was admitting that the task is way beyond my knowledge of the process.
I'm afraid if I just blindly follow the guide not really understanding it, I will mess up my install.
I do have respect for those who were able to finish it successfully.
Sorry if I offended you.

Len
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
The only purpose was admitting that the task is way beyond my knowledge of the process.
No offense taken.
If you tried the process, you would know considerably more than you know now. Opportunity lost.
 
Joined
Aug 19, 2010
Messages
25
Motherboard
Gigabyte H61M
CPU
i3 3220
Graphics
HD 7970
Sorry my mistake. Uploaded the wrong DSDT. See attached for one I am currently using. HDMI Audio not functioning. Please have another look and advise.

Thanks
Steve
 

Attachments

  • DSDT.aml
    18.2 KB · Views: 120
Status
Not open for further replies.
Top