Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Sep 12, 2017
Messages
37
Motherboard
ASRock B250 PRO4
CPU
i5-7500
Graphics
HD 630
  1. HDMI Audio not working at all.
  2. 10.13/ASROCK PRO4 B250/Intel i5 7500/HD630
  3. Output of script:
  4. Last login: Sun Oct 8 15:46:00 on ttys001

    Fruitys-iMac:~ fruityfaiz$ /Users/fruityfaiz/Downloads/audio_cloverHDMI-130_v0.5.command ; exit;

    Agreement

    The audio_cloverHDMI script is for personal use only. Do not distribute

    the patch, any or all of the files for any reason without permission.

    The audio_cloverHDMI script is provided as is and without any warranty.


    File: audio_cloverHDMI-130_v0.5.command

    Release Mode

    EFI partition is mounted

    HDMI audio codec(s)

    Intel: 0x8086280b

    HD630 HDMI audio is not enabled

    Install SSDT-HDMI-HD630 HDMI audio ssdt (y/n): y

    Download SSDT-HDMI-HD630 ...

    Password:

    % Total % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed

    100 45203 100 45203 0 0 174k 0 --:--:-- --:--:-- --:--:-- 175k

    Download SSDT-HDEF-HDAS-3.aml ...

    % Total % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed

    100 44817 100 44817 0 0 222k 0 --:--:-- --:--:-- --:--:-- 223k

    /Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDMI-HD630 installed

    /Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDEF-HDAS-3 installed

    One display connected, proceeding

    HD630/00001259 detects and sets HDMI connector, no patch required

    rm: /tmp/config.plist6: No such file or directory

    rm: /tmp/HDEF.txt: No such file or directory

    Install AMD/Nvidia HDMI audio (y/n): n


    Install finished, restart required.

    To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...

    logout

    Saving session...

    ...copying shared history...

    ...saving history...truncating history files...

    ...completed.


    [Process completed]
  5. System Info: https://i.imgur.com/5ueHZJM.png
  6. config.plist: https://pastebin.com/BkycuL5s
 
Last edited:
Joined
Jul 5, 2012
Messages
369
Motherboard
asus z170-k
CPU
i5-6400
Graphics
HD530/GTX 650
Mac
  1. Mac Pro
Mobile Phone
  1. Android
  2. iOS
Ok gcn 1.1 are Hawaii which I really cared about and probably the rest you listed as the exception.
Pretty cool those guys are getting those to work apparently. And it slept too once I followed the directions
to go into efi/clover/kexts/other with the kexts. Says that there may be some editing required but hdmi
audio was confirmed working on the Xs.

So this is what I was trying to get figured out into clover

  • How do I get HDMI audio to work?
    In general it should be enough to rely on WhateverGreen automatic HDAU correction. It renames the device to HDAU, and injects missing layout-id and hda-gfx (starting with onboard-2) properties. This will not work well with two or more cards of different vendors (e.g. NVIDIA and ATI/AMD), please manually inject the properties in such a case.
    For identifiers not present in AppleHDAController and AppleHDA you have to add necessary kext patches, see AppleALC example for 290X.

So should be working as there is no nvidia card. Maybe since the dsdt edit has hdmi enabled it got confused?
Maybe not... if identifiers not present?
 
Last edited:
Joined
Jun 20, 2014
Messages
1,017
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Hi toleda I'm moving my post here.

I can't get HDMI audio output working after using the audio_cloverALC.command and audio_cloverHDMI.command patches.

Attached are the relevant files.

EDIT: If I use the DisplayPort (and remove SSDT-HDEF-HDAS-3.aml and place SSDT-HDEF-HDAS-1.aml from ssdt_hdef-1-100-hdas.zip into patched as suggested) I now get audio out (along with the Headphone port). I've also got 4k working. So essentially I'm happy although it would be nice to have audio out working for the HDMI port. Thanks toleda for all the work you do for the community.
 
Last edited:

toleda

Moderator
Joined
May 20, 2010
Messages
24,092
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
would be nice to have audio out working for the HDMI port.
That is the problem I'm trying to solve
See Post #1/Download cloverHDMI and run.
Attach Terminal output and the other files
 
Status
Not open for further replies.
Top