Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
I just noticed an issue. I can't control the volume for DP (Icons are faded). See attached screenshot.
 

Attachments

  • Screen Shot 2017-08-06 at 8.00.46 PM.png
    Screen Shot 2017-08-06 at 8.00.46 PM.png
    84.8 KB · Views: 114

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
See Post #1/OS X HDMI and/or DP audio support/Before you begin

Got it..."macOS does not provide HDMI/DP audio controls. No volume, no mute, no balance, etc. Use the connected DP/HDMI device (TV, receiver, etc.).

Well, it looks a I've all that is possible to work in place. Toleda, I truly appreciate your help! Thanks man!
 
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
I just would like to share that I learned about SoundFlower + SoundflowerBed to control volume on HDMI or DisplayPort Audio. It's working great for me on 10.12.6.
 

ole

Joined
Jul 11, 2010
Messages
8
Motherboard
H97N-Wifi
CPU
i5-4690
Graphics
GTX1050Ti
Mac
  1. MacBook
  2. MacBook Air
  3. Mac mini
Classic Mac
  1. iMac
  2. Portable
  3. PowerBook
Mobile Phone
  1. iOS
Hi Toleda,

I tried, again and again, but I still can't see the reason, need your help, please:

Description of HDMI audio problem
System audio works fine (green/SPDIF), but unable to get HDMIAudio (nor DPAudio) for some reason… Oh, and why it is in Spanish, not a clue…

macOS version/motherboard model/BIOS version/processor/graphics
10.12.5/Gigabyte H97N-WIFI/F9b/i5-4690/GTX1050Ti

Procedure/Guide Used
CloverHDMI script

cloverHDMI terminal output (Shell/Export Text As ...)
Attached

Copy of IORegistryExplorer/IOJones (either)
Attached

Screenshots
DPCIManager/Status (Tools 2.)
Attached

System Information/Hardware/Graphics/Displays
Attached

Copy Of Console/All Messages (last boot)
Attached

System/Library/Extensions/AppleHDA.kext
Attached

Clover
EFI/CLOVER/config.plist

Attached
DPCIManager/Misc/Boot Log (Tools 2.)
Attached
EFI/CLOVER/ACPI/Patched/dsdt.aml (if installed)
N/A
EFI/CLOVER/ACPI/Patched/ssdt.aml
Attached

Thx!
 

Attachments

  • Problem Reporting.zip
    2.7 MB · Views: 70
Status
Not open for further replies.
Top