Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
Hello Toleda and all,

I’m working on my first Hackintosk. And I spent the last three days (almost all day on it) trying to make my HDMI and DP sound to work.

I really tried hard. I tried almost all solutions available that I could find. Before each one of them I reverted the previous change to a clean install (reverting Clove changes, deleting files and recovering config.plist backup everytime).

Procedures:
1. ssdt_hdef-1-100-hdas.zip
2. audio_200_Series_hda-124_v1.0.command
3. audio_cloverALC-1220-120.command.zip
4. audio_cloverHDMI-120_v1.0d.command

Guides:
1. https://www.tonymacx86.com/threads/...p-realtek-applehda-guide.219810/#post-1492288
2. https://www.tonymacx86.com/threads/...lake-audio-onboard-and-or-hd-6x0-hdmi.221618/
3. https://www.tonymacx86.com/threads/audio-realtek-alc-applehda-guide.143757 - cloverALC/Beta method
4. https://github.com/toleda/audio_CloverHDMI - cloverHDMI method

Results:
- Mobo 5.1 audio and front panel is working
- when I choose Internal speaker, the sound output goes to the green audio jack.
- SPDIF output doesn’t work
- DP output doesn’t work
- HDMI output doesn’t work

My built:
OSX: Sierra 10.12.6
Mobo: Asus ROG Strix Z270i Gaming
Mobo Bios version: 0607 x64
CPU: Intel Core i7-7700K Kaby Lake
GPU: Asus ROG Strix GTX1080-O8G-11GBPS

ALL information requested for Problem Reporting is on the attached zip file.

I appreciate your attention and look forward to your help.

Mark
Sorry.. I forgot to say that I cleaned all previous tries and did the procedure above. That is the best I got up to this moment.
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Results:
- when I choose Internal speaker, the sound output goes to the green audio jack.
- SPDIF output doesn’t work
- DP output doesn’t work
- HDMI output doesn’t work
Green: Expected
SPDIF: If green works, SPDIF works, details?
DP: Details
HDMI: HDMI audio does not work on the HDMI port, Nvidia problem.

IOReg: shows GFX0@0 and PEG0/GFX1@0 instead of PEG0/GFX0@0, how and why?
IOReg: what display is connected to what port?
 
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
Green: Expected
SPDIF: If green works, SPDIF works, details?
DP: Details
HDMI: HDMI audio does not work on the HDMI port, Nvidia problem.

IOReg: shows GFX0@0 and PEG0/GFX1@0 instead of PEG0/GFX0@0, how and why?
IOReg: what display is connected to what port?
 
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
Green: Expected
SPDIF: If green works, SPDIF works, details?
DP: Details
HDMI: HDMI audio does not work on the HDMI port, Nvidia problem.

IOReg: shows GFX0@0 and PEG0/GFX1@0 instead of PEG0/GFX0@0, how and why?
IOReg: what display is connected to what port?

Tkx for the quick response!

DP: No sound
Green: Ok then, this is no biggie
SPDIF: since you mentioned it should work I decided to test my cable. Cable is not working properly. I don't have another to test it so, it should be it.
HDMI: didn't know...i lost so much time trying...

IOReg / GFX0@0 and PEG0/GFX1@0: to be honest, I have no clue. How do I fix it?
IOReg / Displays: I just have one monitor so I have DP and HDMI are both connected to my Predator X34. Just for tests. I’m planning to connect HDMI to my Home Theater.

I hope I answered your answers correctly (I’m a newbie on this is stuff).

Thank you!
 

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
have no clue. How do I fix it?
It is not in the dsdt or attached ssdts, Have to remove something, don't know what is doing it.
Did not answer if IOReg shows HDMI connector or DP connector.
Attach IOReg using DP connector.
Once DP works, a DP2HDMI adapter will provide HDMI audio
 
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
It is not in the dsdt or attached ssdts, Have to remove something, don't know what is doing it.

The only way I could make my GPU works with the right definition was installing the driver "emuvariableuefi" from Clove Configurator. Do you think it could have something to do with this?

Did not answer if IOReg shows HDMI connector or DP connector.
Attach IOReg using DP connector.

IOReg I sent was showing HDMI. Attached you will find IOReg using DP connector.
 

Attachments

  • iMac (2).ioreg
    16.8 MB · Views: 72

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
could have something to do with this?
No, attached IOReg shows GFX0 as expected. Something changed between the capture of the two IORegs.
Attached you will find IOReg using DP connector.
DP audio is working. For HDMI audio, use a DP2HDMI adapter.
 
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
No, attached IOReg shows GFX0 as expected. Something changed between the capture of the two IORegs.
The only thing I did was uninstall the driver "emuvariableuefi" and install it back. Could that really be reason it changed?

DP audio is working. For HDMI audio, use a DP2HDMI adapter.
That's great !!! I didn't noticed before, just after you mentioned it was working. Probably, it wasn't working because the PEG0/GFX1@0 issue...
 
Joined
Jul 28, 2017
Messages
9
Motherboard
ASUS ROG STRIX Z270I GAMING
CPU
Intel Core i7-7700K Kaby Lake
Graphics
ASUS ROG-STRIX-GTX1080-O8G-11GBPS
Mac
  1. iMac
I just noticed an issue. I can't control the volume for DP (Icons are faded). See attached screenshot.
 

Attachments

  • Screen Shot 2017-08-06 at 8.00.46 PM.png
    Screen Shot 2017-08-06 at 8.00.46 PM.png
    84.8 KB · Views: 117

toleda

Moderator
Joined
May 19, 2010
Messages
22,935
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top