Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Feb 14, 2014
Messages
8
Motherboard
Asus Maximus VI Impact
CPU
4770k
Graphics
MSI Gaming GTX N780 TF 3GD5/OC
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Thank you for the heads up. I now have working onboard audio (screenshot attached). My goal now is working hdmi audio from my GTX 780. Screenshots and files attached once again. Thanks for everything you do and tolerating us newer folks! Please let me know if I need to provide anything else! -THANK YOU!

Screen Shot 2014-12-09 at 10.54.25 PM.pngScreen Shot 2014-12-09 at 10.53.22 PM.pngScreen Shot 2014-12-09 at 10.50.55 PM.pngView attachment AppleHDA.kext.zipView attachment config.plist
 
Joined
Feb 14, 2014
Messages
8
Motherboard
Asus Maximus VI Impact
CPU
4770k
Graphics
MSI Gaming GTX N780 TF 3GD5/OC
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Ok. First I had followed the audio_CLOVERALC-master. Which was my original post. But as you had mentioned I originally posted in the wrong thread so apologies again for that.

According to your original response I needed to get onboard audio working before posting here. I went to the link you included... No Audio Devices - Realtek ALC AppleHDA [Guide]

And noticed that multibeast was the suggested option for enabling onboard audio first... So I used multibeast to patch the native AppleHDA.kext for ALC1150 and also selected the "optional efi boot loader option."

I then made sure that my kext-dev-mode=1 was enabled and that npci=0x3000 was not enabled.

After reboot I had audio.

I then went back to the original CLOVERALC guide because its appealing to have audio survive updates etc...(Which if I have been reading right can't happen with other methods?)


I ran audio_cloverALC-100.sh and it told me AppleHDA.kext was not native.... so I grabbed the native kext from my macbook air running 10.10.1 and ran the command again

I ran audio_cloverALC-100.sh it asked:
ALC1150 - y
then clover injection - y
one other question i forget. ... but I rebooted and audio was still working... no hdmi

I then copied and pasted the contents of config-hdmi_hd4600-100.plist from Audio_CLOVERHDMI guid to my config.plist to kernelandkextpatches thinking I needed that specifically to HDMI function working.

My question is - is there only one guide I should be following? Sorry I am very new at this. Is CLOVERALC supposed to enable HDMI or is that in addition to a separate HDMI fix?

I am completely willing to rebuild the whole system and start from scratch... I have everything but audio down to a science. I.E. on board AC wifi & handoff and nvidia graphics etc.

I am not using ssdt or dsdt edits... I am booting full uefi incase that helps. Thanks again! hopefully something in this rambling helps.
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Feb 14, 2014
Messages
8
Motherboard
Asus Maximus VI Impact
CPU
4770k
Graphics
MSI Gaming GTX N780 TF 3GD5/OC
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Using Guide HD4600-hdmi_audio(dsdt_or_ssdt_v2.1.2


[Guide]_OS_X_hdmi_audio-dsdt_v2.1


Used:
audio_hdmi_8series-master
audio_CloverHDMI-master


ran audio_hdmi_hd4600-hda-100_patch (Terminal Output is attached) - moved to step 2 (MaciASL)


Problem: When attempting to build dsdt I get errors no matter what method I attempt.


I am not using any form of DSDT.


I can successfully access your patches with the provided URL in MaciASL


My BIOS for my Asus Maximus VI Impact is version 1603.


Scenario 1
When I load MaciASL and create new from acpi > dsdt, I then hit patch and select AMI-Clean_Compile-8series, I then hit Apply followed by compile. NO ERRORS (screen shot attached)


I then hit patch again and select AMI-HD4600-AMD-Nvidia-A1 > APPLY > Compile. ERRORS
Simply removing the errors listed from Compiler Summary leads to A LOT more errors


Scenario 2
When I load MaciASL and create new from acpi > dsdt,, I then select AMI-add_dsdt/PCI0/P0P2(w/ssdt/PEG0), Apply, Compile. MANY MANY ERRORS


Scenario 3
When I load MaciASL and create new from acpi > dsdt, I then hit patch and select AMI-Clean_Compile-8series, I then hit Apply followed by compile. NO ERRORS


I then hit patch again and select AMI-add_dsdt/PCI0/P0P2(w/ssdt/PEG0),Apply, Compile. ERRORS


I attempt to resolve errors, by removing lines with issues > More errors










View attachment audio_hdmi_hd4600 Terminal Output.txtClean compile and AMI-add_dsdt:PCI0:P0P2(w:ssdt:PEG0).pngClean Compile and  AMI-HD4600-AMD-Nvidia-A1 .pngClean Compile Results.pngSystem DSDT no clean compile and AMI add pci0 p0p2.png
 

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Using Guide HD4600-hdmi_audio(dsdt_or_ssdt_v2.1.2
Screenshots of complier errors are a complete waste of your time and mine.
See Post #1, Problem Reporting. Attach all requested files.
 
Joined
Feb 14, 2014
Messages
8
Motherboard
Asus Maximus VI Impact
CPU
4770k
Graphics
MSI Gaming GTX N780 TF 3GD5/OC
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
1)HDMI Audio Problem: Unable to build DSDT


2) OS X 10.10.1
Asus Maximus VI Impact v1603
4770k
MSI GTX 780


3) Guides:
audio_hdmi_8series-master
audio_CloverHDMI-master


4) Copy of IORegistryExplorer attached


5) Console all Messages attached


6) AppleHDA attached


7) N/A


8)
A. config.plist attached
B. DPCI Log attached
C. N/A
D. N/A


Thanks for your time. I & We all do truly not only appreciate it, but in some cases need it. So seriously- Thank you.
 

Attachments

  • All Messages.log
    91 KB · Views: 64
  • AppleHDA.kext.zip
    1.3 MB · Views: 53
  • config.plist
    5.5 KB · Views: 163
  • DPCI Boot Log.txt
    18.1 KB · Views: 107
  • ioreg.ioreg
    4.3 MB · Views: 75

toleda

Moderator
Joined
May 20, 2010
Messages
23,008
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
1)HDMI Audio Problem: Unable to build DSDT
8)
A. config.plist attached
B. DPCI Log attached
C. N/A
How can the dsdt be N/A?
Attach the dsdts; native and every version that errored.
 
Joined
Feb 14, 2014
Messages
8
Motherboard
Asus Maximus VI Impact
CPU
4770k
Graphics
MSI Gaming GTX N780 TF 3GD5/OC
Mac
  1. iMac
Classic Mac
Mobile Phone
  1. iOS
Here they are.

Zipped contains 5 files.


Native

Native - Clean Compile

Native - Clean Compile - AMI NVIDIA AMD ....

Native - ADD PCI0/P0P2

Native - Clean Compile- ADD PCI/P0P2
 

Attachments

  • DSDT.zip
    202.9 KB · Views: 54
Status
Not open for further replies.
Top