Contribute
Register

Audio - HDMI Audio AppleHDA [Guide]

Status
Not open for further replies.
Joined
Feb 4, 2016
Messages
30
Motherboard
K56CM (Clover)
CPU
Intel Core i5 3317U/HM76
Graphics
Intel HD4000,1366x768 + NVIDIA GeForce GT 635M 2GB
Mobile Phone
  1. Android
Remove config.plist/KernelAndKextPatches/KextsToPatch/t2-10.10-10.11-Capri-Port _0x7-HDMI2DP
Download (View Raw) config-hdmi_hd4000-100.plist.zip
Add config.plist/KernelAndKextPatches/KextsToPatch/10.10-Capri-Port _0x6-DP2HDMI
Edit: Find
From: 030400000004000007010000
To: 030400000004000081000000
Save

still no audio hdmi. The screenshot will explain the situation
 

Attachments

  • Screen Shot 2016-11-01 at 22.25.58.png
    Screen Shot 2016-11-01 at 22.25.58.png
    1.3 MB · Views: 96
Joined
Feb 4, 2016
Messages
30
Motherboard
K56CM (Clover)
CPU
Intel Core i5 3317U/HM76
Graphics
Intel HD4000,1366x768 + NVIDIA GeForce GT 635M 2GB
Mobile Phone
  1. Android
Useless. See Post #1833
After made the change you told me the situation is still the same. I cannot see the audio device inside the menu sound in preferences. If you want and if this can help you i can upload the same file I have uploaded in Post#1833 with the only change you have told me in Post #1835.
 
Joined
Aug 28, 2011
Messages
59
Motherboard
Z270X-Gaming 5
CPU
i7 7700k
Graphics
AMD
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Can't get HDMI to work

  1. Description of HDMI audio problem: no devices in sound->output
  2. OS X version/motherboard model/BIOS version/processor/graphics: Sierra 10.12.1, MOBO Gyg Z77X-UD5H, i7-4790, nVidia 750 TI
  3. Procedure/Guide Used: tried to use the automated script for Sierra. Also tied the HDMI Kext provided in the forum, always uninstalling before trying the other method. Until now nothing worked.
  4. Copy of IORegistryExplorer/IOJones (either) - file is attached
  5. Copy Of Console/All Messages (last boot) - I can;t save file. Is it changed in Sierra?.
  6. System/Library/Extensions/AppleHDA.kext - file is attached

  7. Clover
    1. EFI/CLOVER/config.plist - attached
      1. DPCIManager/Misc/Boot Log - attached
    2. EFI/CLOVER/ACPI/Patched/dsdt.aml (if installed) - no file
    3. EFI/CLOVER/ACPI/Patched/ssdt.aml - no file
 

Attachments

  • enm1.zip
    2.5 MB · Views: 74
Joined
Sep 22, 2013
Messages
13
Motherboard
GA Z390 MASTER
CPU
Intel Core I5 -9700F
Graphics
RADEON RX 570 8GB
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hi Toleda.
I still have the same problem.
The hdmi is working but no sound on hdmi, only bluetooth. What i do?
 

Attachments

  • Captura de Tela 2016-10-30 às 20.26.14.png
    Captura de Tela 2016-10-30 às 20.26.14.png
    102.2 KB · Views: 78
  • config.plist
    6.1 KB · Views: 197
  • iMac de User.ioreg
    4.1 MB · Views: 82
  • Screen Shot 2016-11-02 at 09.43.27.png
    Screen Shot 2016-11-02 at 09.43.27.png
    39.9 KB · Views: 81
  • Screen Shot 2016-11-02 at 09.43.50.png
    Screen Shot 2016-11-02 at 09.43.50.png
    96 KB · Views: 82
  • Screen Shot 2016-11-02 at 09.44.43.png
    Screen Shot 2016-11-02 at 09.44.43.png
    95.5 KB · Views: 74
  • Screen Shot 2016-11-02 at 09.45.00.png
    Screen Shot 2016-11-02 at 09.45.00.png
    97.7 KB · Views: 83
  • Screen Shot 2016-11-02 at 09.46.27.png
    Screen Shot 2016-11-02 at 09.46.27.png
    58.4 KB · Views: 77

toleda

Moderator
Joined
May 20, 2010
Messages
22,971
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
i can upload the same file I have uploaded in Post#1833
Did you reboot? If no, then no change. If yes, all files changed.
It is very simple; if the fix did not work, make new files and attach.
Otherwise; no files attach, no reply. Clear?
 
Status
Not open for further replies.
Top